summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-01-24 00:12:08 +0000
committerMike Frysinger <vapier@gentoo.org>2012-01-24 00:12:08 +0000
commitdc754f3de72f04fc69ba185a63ed62d291f7bfaa (patch)
treeb3ea32947f164632c2a97fa85006d70860ea5ee4 /app-misc/pax-utils
parenthttp://my.opera.com/desktopteam/blog/2012/01/23/11-61-rc (diff)
downloadhistorical-dc754f3de72f04fc69ba185a63ed62d291f7bfaa.tar.gz
historical-dc754f3de72f04fc69ba185a63ed62d291f7bfaa.tar.bz2
historical-dc754f3de72f04fc69ba185a63ed62d291f7bfaa.zip
Version bump.
Package-Manager: portage-2.2.0_alpha84/cvs/Linux x86_64
Diffstat (limited to 'app-misc/pax-utils')
-rw-r--r--app-misc/pax-utils/ChangeLog9
-rw-r--r--app-misc/pax-utils/pax-utils-0.3.0.ebuild35
2 files changed, 42 insertions, 2 deletions
diff --git a/app-misc/pax-utils/ChangeLog b/app-misc/pax-utils/ChangeLog
index 864811c97152..538cb83b544b 100644
--- a/app-misc/pax-utils/ChangeLog
+++ b/app-misc/pax-utils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/pax-utils
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/pax-utils/ChangeLog,v 1.131 2011/12/30 16:11:30 halcy0n Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/pax-utils/ChangeLog,v 1.132 2012/01/24 00:12:08 vapier Exp $
+
+*pax-utils-0.3.0 (24 Jan 2012)
+
+ 24 Jan 2012; Mike Frysinger <vapier@gentoo.org> +pax-utils-0.3.0.ebuild:
+ Version bump.
30 Dec 2011; Mark Loeser <halcy0n@gentoo.org> pax-utils-0.2.3.ebuild:
Stable for ppc64; bug #381625
diff --git a/app-misc/pax-utils/pax-utils-0.3.0.ebuild b/app-misc/pax-utils/pax-utils-0.3.0.ebuild
new file mode 100644
index 000000000000..d185fc77b76a
--- /dev/null
+++ b/app-misc/pax-utils/pax-utils-0.3.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/pax-utils/pax-utils-0.3.0.ebuild,v 1.1 2012/01/24 00:12:08 vapier Exp $
+
+inherit flag-o-matic toolchain-funcs eutils
+
+DESCRIPTION="ELF related utils for ELF 32/64 binaries that can check files for security relevant properties"
+HOMEPAGE="http://hardened.gentoo.org/pax-utils.xml"
+SRC_URI="mirror://gentoo/pax-utils-${PV}.tar.xz
+ http://dev.gentoo.org/~solar/pax/pax-utils-${PV}.tar.xz
+ http://dev.gentoo.org/~vapier/dist/pax-utils-${PV}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="caps"
+#RESTRICT="mirror"
+
+RDEPEND="caps? ( sys-libs/libcap )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils"
+
+src_unpack() {
+ # avoid newer EAPI for easy upgrade paths
+ xz -dc "${DISTDIR}/${A}" | tar xf - || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" USE_CAP=$(use caps && echo yes) || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc BUGS README TODO
+}