summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2003-12-13 07:30:44 +0000
committerGeorge Shapovalov <george@gentoo.org>2003-12-13 07:30:44 +0000
commiteafa828679b4e2ae6081c71eabaf1620ff809fbb (patch)
tree709d1c8e28c9fb801c2868043eea627529354081 /app-misc/nomad-tool/nomad-tool-1.3-r1.ebuild
parentmedia-libs/libjackasync -> media-libs/libjackasyn (diff)
downloadhistorical-eafa828679b4e2ae6081c71eabaf1620ff809fbb.tar.gz
historical-eafa828679b4e2ae6081c71eabaf1620ff809fbb.tar.bz2
historical-eafa828679b4e2ae6081c71eabaf1620ff809fbb.zip
new revision, - cpntains a gui for the tool and few cleanups to ebuild
Diffstat (limited to 'app-misc/nomad-tool/nomad-tool-1.3-r1.ebuild')
-rw-r--r--app-misc/nomad-tool/nomad-tool-1.3-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-misc/nomad-tool/nomad-tool-1.3-r1.ebuild b/app-misc/nomad-tool/nomad-tool-1.3-r1.ebuild
new file mode 100644
index 000000000000..33ea0952f04a
--- /dev/null
+++ b/app-misc/nomad-tool/nomad-tool-1.3-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/nomad-tool/nomad-tool-1.3-r1.ebuild,v 1.1 2003/12/13 07:30:38 george Exp $
+
+GUI_V=0.5.5
+
+DESCRIPTION="Controls the Nomad II MG and IIc portable MP3 players"
+HOMEPAGE="http://www.swiss.ai.mit.edu/~cph/nomad.php"
+SRC_URI="http://www.swiss.ai.mit.edu/~cph/nomad/${P}.tar.gz
+ http://www.its.caltech.edu/~georges/gentoo/proj/nomad-gui/nomad-gui-${GUI_V}.py.bz2"
+
+SLOT="0"
+KEYWORDS="~x86"
+LICENSE="GPL-2"
+IUSE="tcltk"
+
+DEPEND=""
+
+
+src_compile() {
+ cd ${WORKDIR}
+ make PREFIX="/usr" || die "compile failed"
+}
+
+src_install() {
+ cd ${WORKDIR}
+ dobin nomad-tool
+ dolib nomad-open
+ chmod 4755 ${D}/usr/lib/nomad-open
+
+ doman nomad-tool.1
+ dodoc ChangeLog COPYING README
+
+ #optional gui interface, needs python with tkinter
+ use tcltk && (
+ mv nomad-gui-${GUI_V}.py nomad-gui.py
+ dobin nomad-gui.py
+ )
+}