summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2003-09-22 00:47:33 +0000
committerMamoru Komachi <usata@gentoo.org>2003-09-22 00:47:33 +0000
commitdc3eeb2cbbe8b7c03bc85e454d7170becf0bfb89 (patch)
tree3efa4725eac1e3c8c302b18e129c3d753054e0b9 /app-i18n
parentNew CVS snapshot. Rewritten ebuilds with elisp-common.eclass. Closes Bug #29190 (diff)
downloadhistorical-dc3eeb2cbbe8b7c03bc85e454d7170becf0bfb89.tar.gz
historical-dc3eeb2cbbe8b7c03bc85e454d7170becf0bfb89.tar.bz2
historical-dc3eeb2cbbe8b7c03bc85e454d7170becf0bfb89.zip
New CVS snapshot. Rewritten ebuilds with elisp-common.eclass. Closes Bug #29190
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/anthy/Manifest10
-rw-r--r--app-i18n/anthy/anthy-4300b.ebuild32
-rw-r--r--app-i18n/anthy/anthy-4507.ebuild20
-rw-r--r--app-i18n/anthy/anthy-4515.ebuild20
-rw-r--r--app-i18n/anthy/anthy-4519.ebuild72
-rw-r--r--app-i18n/anthy/files/digest-anthy-45191
6 files changed, 106 insertions, 49 deletions
diff --git a/app-i18n/anthy/Manifest b/app-i18n/anthy/Manifest
index c53ce2e62061..7e04280bb00e 100644
--- a/app-i18n/anthy/Manifest
+++ b/app-i18n/anthy/Manifest
@@ -1,9 +1,9 @@
-MD5 c8705914e6d4b55d82ea00b4b299cc19 anthy-4300b.ebuild 1041
+MD5 0e66c441f8e430640bd8662b54b3da31 anthy-4300b.ebuild 951
MD5 110027f473a759d42095c0b178b41f19 metadata.xml 846
-MD5 9de87e6c84f6e6715c969bda90a7df1a ChangeLog 1630
-MD5 37faaf1168c495cd077d1cc376cc1537 anthy-4507.ebuild 1925
-MD5 e88d55217b9c935e727fd2b92a9b0e89 anthy-4515.ebuild 1926
-MD5 e2bdbdaedf862f65ebd3aed38f40a9df anthy-4519.ebuild 1729
+MD5 872a69c5b767628664655b39ce5b9f1f ChangeLog 1978
+MD5 504ba8bdd957163fd2a58579465236a7 anthy-4507.ebuild 1800
+MD5 3ef881b5012bdeb81381bda691712ebe anthy-4515.ebuild 1801
+MD5 76cba2c8d88c3dd75cd6358c18dd7c6a anthy-4519.ebuild 1798
MD5 83e271d277525e627be3756f01c7010e files/digest-anthy-4300b 64
MD5 d91fcb424ec63b588900d2d88a8bcee2 files/50anthy-gentoo.el 99
MD5 7bbcd511928477630332c6bd34c6e528 files/digest-anthy-4507 63
diff --git a/app-i18n/anthy/anthy-4300b.ebuild b/app-i18n/anthy/anthy-4300b.ebuild
index 7d14cef9a374..ec564d22d139 100644
--- a/app-i18n/anthy/anthy-4300b.ebuild
+++ b/app-i18n/anthy/anthy-4300b.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy/anthy-4300b.ebuild,v 1.3 2003/09/04 19:15:04 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy/anthy-4300b.ebuild,v 1.4 2003/09/22 00:47:28 usata Exp $
-inherit elisp
+inherit elisp-common
IUSE="emacs"
@@ -16,20 +16,10 @@ SLOT="0"
S="${WORKDIR}/${P}"
-E_DEPEND="emacs? ( ${E_DEPEND} )"
-E_RDEPEND="emacs? ( ${E_DEPEND} )"
-DEPEND="virtual/glibc"
-
-if [ -n "`use emacs`" ] ; then
- SITEFILE="50anthy-gentoo.el"
-else
- pkg_postinst () {
- einfo "Emacs support is disabled."
- }
- pkg_postrm () {
- einfo "Emacs support is disabled."
- }
-fi
+DEPEND="virtual/glibc
+ emacs? ( virtual/emacs )"
+
+SITEFILE="50anthy-gentoo.el"
src_compile() {
@@ -46,3 +36,13 @@ src_install() {
dodoc AUTHORS ChangeLog DIARY INSTALL NEWS README \
doc/[A-Z][A-Z]* doc/protocol.txt
}
+
+pkg_postinst() {
+
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+
+ use emacs && elisp-site-regen
+}
diff --git a/app-i18n/anthy/anthy-4507.ebuild b/app-i18n/anthy/anthy-4507.ebuild
index d1e8b6433c4c..21a65454f2f3 100644
--- a/app-i18n/anthy/anthy-4507.ebuild
+++ b/app-i18n/anthy/anthy-4507.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy/anthy-4507.ebuild,v 1.2 2003/09/12 22:22:06 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy/anthy-4507.ebuild,v 1.3 2003/09/22 00:47:29 usata Exp $
+
+inherit elisp-common
IUSE="emacs"
@@ -24,7 +26,6 @@ RDEPEND="virtual/glibc
emacs? ( virtual/emacs )"
SITEFILE="50anthy-gentoo.el"
-SITELISP=/usr/share/emacs/site-lisp
src_compile() {
@@ -54,10 +55,7 @@ src_compile() {
src_install() {
einstall || die
- if [ -n "` use emacs`" ] ; then
- insinto ${SITELISP}
- doins ${FILESDIR}/${SITEFILE}
- fi
+ use emacs && elisp-site-file-install ${FILESDIR}/${SITEFILE}
dodoc AUTHORS ChangeLog DIARY INSTALL NEWS README \
doc/[A-Z0-9][A-Z0-9]* doc/protocol.txt
@@ -65,16 +63,10 @@ src_install() {
pkg_postinst() {
- if [ -n "` use emacs`" ] ; then
- inherit elisp
- elisp-site-regen
- fi
+ use emacs && elisp-site-regen
}
pkg_postrm() {
- if [ -n "` use emacs`" ] ; then
- inherit elisp
- elisp-site-regen
- fi
+ use emacs && elisp-site-regen
}
diff --git a/app-i18n/anthy/anthy-4515.ebuild b/app-i18n/anthy/anthy-4515.ebuild
index a11f29c9dccd..da89df0b4393 100644
--- a/app-i18n/anthy/anthy-4515.ebuild
+++ b/app-i18n/anthy/anthy-4515.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy/anthy-4515.ebuild,v 1.1 2003/09/15 13:09:37 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy/anthy-4515.ebuild,v 1.2 2003/09/22 00:47:29 usata Exp $
+
+inherit elisp-common
IUSE="emacs"
@@ -24,7 +26,6 @@ RDEPEND="virtual/glibc
emacs? ( virtual/emacs )"
SITEFILE="50anthy-gentoo.el"
-SITELISP=/usr/share/emacs/site-lisp
src_compile() {
@@ -54,10 +55,7 @@ src_compile() {
src_install() {
einstall || die
- if [ -n "` use emacs`" ] ; then
- insinto ${SITELISP}
- doins ${FILESDIR}/${SITEFILE}
- fi
+ use emacs && elisp-site-file-install ${FILESDIR}/${SITEFILE}
dodoc AUTHORS ChangeLog DIARY INSTALL NEWS README \
doc/[A-Z0-9][A-Z0-9]* doc/protocol.txt
@@ -65,16 +63,10 @@ src_install() {
pkg_postinst() {
- if [ -n "` use emacs`" ] ; then
- inherit elisp
- elisp-site-regen
- fi
+ use emacs && elisp-site-regen
}
pkg_postrm() {
- if [ -n "` use emacs`" ] ; then
- inherit elisp
- elisp-site-regen
- fi
+ use emacs && elisp-site-regen
}
diff --git a/app-i18n/anthy/anthy-4519.ebuild b/app-i18n/anthy/anthy-4519.ebuild
new file mode 100644
index 000000000000..9ffbb828bca8
--- /dev/null
+++ b/app-i18n/anthy/anthy-4519.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy/anthy-4519.ebuild,v 1.1 2003/09/22 00:47:29 usata Exp $
+
+inherit elisp-common
+
+IUSE="emacs"
+
+DESCRIPTION="Anthy -- free and secure Japanese input system"
+HOMEPAGE="http://anthy.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp/anthy/6003/${P}.tar.gz"
+
+# This branch, so-called anthy-ss (snapshot) is a development branch,
+# so it is not intended to be marked as stable. It will remain unstable
+# all the time unless there comes another -ss branch.
+KEYWORDS="~x86"
+LICENSE="GPL-2"
+SLOT="0"
+
+S="${WORKDIR}/${P}"
+
+DEPEND="virtual/glibc
+ emacs? ( virtual/emacs )
+ >=app-dicts/canna-cannadic-0.95a"
+RDEPEND="virtual/glibc
+ emacs? ( virtual/emacs )"
+
+SITEFILE="50anthy-gentoo.el"
+
+src_compile() {
+
+ local myconf cannadicdir
+ cannadicdir=/var/lib/canna/dic/canna
+
+ use emacs \
+ || myconf="${myconf} EMACS=no"
+
+ if has_version 'app-dicts/canna-zipcode' ; then
+ einfo "Adding zipcode.t and jigyosyo.t to anthy.dic."
+ cp ${cannadicdir}/{zipcode,jigyosyo}.t mkanthydic
+ sed -i -e "/^EXTRA_DICS/s|$| zipcode.t jigyosyo.t|" \
+ mkanthydic/Makefile.{in,am}
+ fi
+ if has_version 'app-dicts/canna-2ch' ; then
+ einfo "Adding nichan.ctd to anthy.dic."
+ cp ${cannadicdir}/nichan.ctd mkanthydic/2ch.t
+ sed -i -e "/^EXTRA_DICS/s|$| 2ch.t|" \
+ mkanthydic/Makefile.{in,am}
+ fi
+
+ econf ${myconf} --with-cannadic=${cannadicdir} || die
+ emake || die
+}
+
+src_install() {
+ einstall || die
+
+ use emacs && elisp-site-file-install ${FILESDIR}/${SITEFILE}
+
+ dodoc AUTHORS ChangeLog DIARY INSTALL NEWS README \
+ doc/[A-Z0-9][A-Z0-9]* doc/protocol.txt
+}
+
+pkg_postinst() {
+
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+
+ use emacs && elisp-site-regen
+}
diff --git a/app-i18n/anthy/files/digest-anthy-4519 b/app-i18n/anthy/files/digest-anthy-4519
new file mode 100644
index 000000000000..2f8be8a9a1e3
--- /dev/null
+++ b/app-i18n/anthy/files/digest-anthy-4519
@@ -0,0 +1 @@
+MD5 249dc4249240b428590a5c1e8d0819b7 anthy-4519.tar.gz 1419951