summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2011-04-06 13:51:58 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2011-04-06 13:51:58 +0000
commit92dfc33d4812251d53be5a63cba577e96ee43fd2 (patch)
tree1d67222bba2a7c3678cdb4167be23b7c5374d749 /app-i18n
parentUse EAPI="3". (diff)
downloadhistorical-92dfc33d4812251d53be5a63cba577e96ee43fd2.tar.gz
historical-92dfc33d4812251d53be5a63cba577e96ee43fd2.tar.bz2
historical-92dfc33d4812251d53be5a63cba577e96ee43fd2.zip
Version bumped.
Package-Manager: portage-2.1.9.44/cvs/Linux x86_64
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/imsettings/ChangeLog7
-rw-r--r--app-i18n/imsettings/imsettings-1.2.1.ebuild62
2 files changed, 68 insertions, 1 deletions
diff --git a/app-i18n/imsettings/ChangeLog b/app-i18n/imsettings/ChangeLog
index 77fb9a8078ee..3f867a644dd2 100644
--- a/app-i18n/imsettings/ChangeLog
+++ b/app-i18n/imsettings/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/imsettings
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/imsettings/ChangeLog,v 1.3 2011/02/01 00:07:39 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/imsettings/ChangeLog,v 1.4 2011/04/06 13:51:58 matsuu Exp $
+
+*imsettings-1.2.1 (06 Apr 2011)
+
+ 06 Apr 2011; MATSUU Takuto <matsuu@gentoo.org> +imsettings-1.2.1.ebuild:
+ Version bumped.
*imsettings-1.0.1 (01 Feb 2011)
diff --git a/app-i18n/imsettings/imsettings-1.2.1.ebuild b/app-i18n/imsettings/imsettings-1.2.1.ebuild
new file mode 100644
index 000000000000..48c1811444c9
--- /dev/null
+++ b/app-i18n/imsettings/imsettings-1.2.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/imsettings/imsettings-1.2.1.ebuild,v 1.1 2011/04/06 13:51:58 matsuu Exp $
+
+EAPI=3
+
+DESCRIPTION="Delivery framework for general Input Method configuration"
+HOMEPAGE="http://code.google.com/p/imsettings/"
+SRC_URI="http://imsettings.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc qt4 static-libs xfconf"
+
+# X11 connections are required for test.
+RESTRICT="test"
+
+RDEPEND=">=dev-libs/check-0.9.4
+ >=dev-libs/glib-2.26
+ sys-apps/dbus
+ >=x11-libs/gtk+-2.12:2
+ >=x11-libs/libgxim-0.3.1
+ x11-libs/libnotify
+ x11-libs/libX11
+ qt4? ( x11-libs/qt-core:4 )
+ xfconf? ( xfce-base/xfconf )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( dev-util/gtk-doc )"
+
+MY_XINPUTSH="90-xinput"
+
+src_prepare() {
+ # Prevent automagic linking to libxfconf-0.
+ if ! use xfconf; then
+ sed -i -e 's:libxfconf-0:dIsAbLe&:' configure || die
+ fi
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ --with-xinputsh="${MY_XINPUTSH}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ find "${ED}" -name '*.la' -exec rm -f '{}' +
+
+ fperms 0755 /usr/libexec/xinputinfo.sh || die
+ fperms 0755 "/etc/X11/xinit/xinitrc.d/${MY_XINPUTSH}" || die
+
+ dodoc AUTHORS ChangeLog NEWS README || die
+}
+
+pkg_postinst() {
+ if [ ! -e "${EPREFIX}/etc/X11/xinit/xinputrc" ] ; then
+ ln -sf xinput.d/xcompose.conf "${EPREFIX}/etc/X11/xinit/xinputrc"
+ fi
+}