summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMasatomo Nakano <nakano@gentoo.org>2005-04-20 16:44:43 +0000
committerMasatomo Nakano <nakano@gentoo.org>2005-04-20 16:44:43 +0000
commit31750ffc78472bd7d4161471644d0d85d1479ee6 (patch)
treef2b5807b19d4831d015b9ed66feaf34a2567bd0a /app-i18n
parentNew version (diff)
downloadhistorical-31750ffc78472bd7d4161471644d0d85d1479ee6.tar.gz
historical-31750ffc78472bd7d4161471644d0d85d1479ee6.tar.bz2
historical-31750ffc78472bd7d4161471644d0d85d1479ee6.zip
Added python support.
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/nkf/ChangeLog8
-rw-r--r--app-i18n/nkf/Manifest5
-rw-r--r--app-i18n/nkf/files/digest-nkf-2.0.5-r11
-rw-r--r--app-i18n/nkf/files/nkf-python.patch221
-rw-r--r--app-i18n/nkf/nkf-2.0.5-r1.ebuild55
5 files changed, 288 insertions, 2 deletions
diff --git a/app-i18n/nkf/ChangeLog b/app-i18n/nkf/ChangeLog
index 62c463778cb3..582310912337 100644
--- a/app-i18n/nkf/ChangeLog
+++ b/app-i18n/nkf/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-i18n/nkf
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/nkf/ChangeLog,v 1.22 2005/04/11 22:43:30 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/nkf/ChangeLog,v 1.23 2005/04/20 16:44:43 nakano Exp $
+
+*nkf-2.0.5-r1 (20 Apr 2005)
+
+ 20 Apr 2005; Masatomo Nakano <nakano@gentoo.org> +files/nkf-python.patch,
+ +nkf-2.0.5-r1.ebuild:
+ Added python support. Thanks to Atzm Watanabe <sitosito@p.chan.ne.jp>.
*nkf-2.0.5 (11 Apr 2005)
diff --git a/app-i18n/nkf/Manifest b/app-i18n/nkf/Manifest
index 81c2f623b53a..806b5adfa323 100644
--- a/app-i18n/nkf/Manifest
+++ b/app-i18n/nkf/Manifest
@@ -1,8 +1,11 @@
MD5 45ef483a748c2ea6333098ab54cc8eaa nkf-2.0.4.ebuild 1019
MD5 cc6f9b15d524cd51b550a4b06396727d nkf-2.0.2-r1.ebuild 1013
+MD5 4545e981bd3ff0761354a4eef8573cc7 nkf-2.0.5-r1.ebuild 1264
MD5 e1110d22c390dc1baad69e683a7cc0f9 nkf-2.0.5.ebuild 1022
-MD5 2f1bd76ebbea2621b6420c1aeedfb59b ChangeLog 2344
+MD5 b3bd2f7ded1d7fe89f25fed53f0d69a1 ChangeLog 2547
MD5 e92a48548554c80cf90e18df17ff6a82 metadata.xml 156
+MD5 7051b70711c1c06f04b58b13d41437ee files/nkf-python.patch 5459
MD5 846425777c3e9f5dcb205262a1548d7a files/digest-nkf-2.0.4 58
MD5 36914cd105ffe822ba5703b3c521be30 files/digest-nkf-2.0.5 58
MD5 9cb8e05b1ef22ec8e3e5e7ad852e0f9c files/digest-nkf-2.0.2-r1 57
+MD5 36914cd105ffe822ba5703b3c521be30 files/digest-nkf-2.0.5-r1 58
diff --git a/app-i18n/nkf/files/digest-nkf-2.0.5-r1 b/app-i18n/nkf/files/digest-nkf-2.0.5-r1
new file mode 100644
index 000000000000..47552ab72d5e
--- /dev/null
+++ b/app-i18n/nkf/files/digest-nkf-2.0.5-r1
@@ -0,0 +1 @@
+MD5 e34d936b20aaf581da5759fbaf0438f3 nkf205.tar.gz 149809
diff --git a/app-i18n/nkf/files/nkf-python.patch b/app-i18n/nkf/files/nkf-python.patch
new file mode 100644
index 000000000000..daa55ebc4d2c
--- /dev/null
+++ b/app-i18n/nkf/files/nkf-python.patch
@@ -0,0 +1,221 @@
+diff -Naur nkf205/NKF.python/NKF_python.c nkf205-py/NKF.python/NKF_python.c
+--- nkf205/NKF.python/NKF_python.c Thu Jan 1 09:00:00 1970
++++ nkf205-py/NKF.python/NKF_python.c Thu Apr 14 23:16:11 2005
+@@ -0,0 +1,185 @@
++/** Python Interface to NKF
++***************************************************************************
++** Copyright (c) 2005 Matsumoto, Tadashi <ma2@city.plala.jp>
++** All Rights Reserved.
++**
++** Everyone is permitted to do anything on this program
++** including copying, modifying, improving,
++** as long as you don't try to pretend that you wrote it.
++** i.e., the above copyright notice has to appear in all copies.
++** Binary distribution requires original version messages.
++** You don't have to ask before copying, redistribution or publishing.
++** THE AUTHOR DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE.
++***************************************************************************/
++
++#include "Python.h"
++#include <setjmp.h>
++
++#define PYNKF_OPTSLEN 100
++
++#undef getc
++#undef ungetc
++#define getc(f) pynkf_getc(f)
++#define ungetc(c,f) pynkf_ungetc(c,f)
++
++#undef putchar
++#undef TRUE
++#undef FALSE
++#define putchar(c) pynkf_putchar(c)
++
++static char *PYNKF_ARGV[PYNKF_OPTSLEN/2 + 3];
++static long pynkf_ibufsize, pynkf_obufsize;
++static unsigned char *pynkf_inbuf, *pynkf_outbuf;
++static int pynkf_icount,pynkf_ocount;
++static unsigned char *pynkf_iptr, *pynkf_optr;
++static jmp_buf env;
++
++static int
++pynkf_getc(FILE *f)
++{unsigned char c;
++ if (pynkf_icount >= pynkf_ibufsize) return EOF;
++ c = *pynkf_iptr++;
++ pynkf_icount++;
++ return (int)c;
++}
++
++static int
++pynkf_ungetc(int c, FILE *f)
++{
++ if (pynkf_icount--){
++ *(--pynkf_iptr) = c;
++ return c;
++ }else{ return EOF; }
++}
++
++static void
++pynkf_putchar(int c)
++{
++ size_t size;
++ unsigned char *p;
++
++ if (pynkf_ocount--){
++ *pynkf_optr++ = c;
++ }else{
++ size = pynkf_obufsize + pynkf_obufsize;
++ p = (unsigned char *)PyMem_Realloc(pynkf_outbuf, size + 1);
++ if (pynkf_outbuf == NULL){ longjmp(env, 1); }
++ pynkf_outbuf = p;
++ pynkf_optr = pynkf_outbuf + pynkf_obufsize;
++ pynkf_ocount = pynkf_obufsize;
++ pynkf_obufsize = size;
++ *pynkf_optr++ = c;
++ pynkf_ocount--;
++ }
++}
++
++#define PERL_XS 1
++#include "../utf8tbl.c"
++#include "../nkf.c"
++
++static void
++pynkf_parseopts(char *opts, int *argcp, char **argv)
++{
++ register char *p;
++ register int argc, flg;
++ p = opts;
++ argc = 1;
++ flg = 1;
++ *argv++ = "nkf";
++ while(*p){
++ if (*p == ' '){ *p = '\0'; flg = 1; p++; continue; }
++ if (*p != ' ' && flg){*argv++ = p; argc++; flg = 0; }
++ p++;
++ }
++ *argcp = argc;
++}
++
++static PyObject *
++pynkf_convert(unsigned char* str, long strlen, char* opts, int optslen)
++{
++ unsigned char *cp;
++ int argc;
++ char **argv;
++ register char **p;
++ PyObject * res;
++
++ if (optslen > PYNKF_OPTSLEN) {
++ PyErr_SetString(PyExc_ValueError, "Too many options.");
++ return NULL;
++ }
++ pynkf_ibufsize = strlen + 1;
++ pynkf_obufsize = pynkf_ibufsize * 1.5 + 256;
++ pynkf_outbuf = (unsigned char *)PyMem_Malloc(pynkf_obufsize);
++ if (pynkf_outbuf == NULL){
++ PyErr_NoMemory();
++ return NULL;
++ }
++ pynkf_outbuf[0] = '\0';
++ pynkf_ocount = pynkf_obufsize;
++ pynkf_optr = pynkf_outbuf;
++ pynkf_icount = 0;
++ pynkf_inbuf = str;
++ pynkf_iptr = pynkf_inbuf;
++ argv = PYNKF_ARGV;
++
++ pynkf_parseopts(opts, &argc, argv);
++
++ if (setjmp(env) == 0){
++
++ reinit();
++
++ p = argv;
++ for (argc--,p++; (argc > 0) && **p == '-'; argc--, p++) {
++ cp = *p;
++ options(cp);
++ }
++
++ if(x0201_f == WISH_TRUE)
++ x0201_f = ((!iso2022jp_f)? TRUE : NO_X0201);
++
++ kanji_convert(NULL);
++
++ }else{
++ PyMem_Free(pynkf_outbuf);
++ PyErr_NoMemory();
++ return NULL;
++ }
++
++ *pynkf_optr = 0;
++ res = PyString_FromString(pynkf_outbuf);
++ PyMem_Free(pynkf_outbuf);
++ return res;
++}
++
++#ifndef EXTERN_NKF
++static
++#endif
++PyObject *pynkf_nkf(PyObject *self, PyObject *args)
++{
++ unsigned char *str;
++ long strlen;
++ char *opts;
++ int optslen;
++ PyObject* res;
++
++ if (!PyArg_ParseTuple(args, "s#s#", &opts, &optslen, &str, &strlen)) {
++ return NULL;
++ }
++ res = pynkf_convert(str, strlen, opts, optslen);
++ return res;
++}
++
++#ifndef EXTERN_NKF
++static PyMethodDef
++nkfmethods[] = {
++ {"nkf", pynkf_nkf, METH_VARARGS},
++ {NULL, NULL}
++};
++
++/* Module initialization function */
++void
++initnkf(void)
++{
++ Py_InitModule("nkf", nkfmethods);
++}
++#endif
+diff -Naur nkf205/NKF.python/README nkf205-py/NKF.python/README
+--- nkf205/NKF.python/README Thu Jan 1 09:00:00 1970
++++ nkf205-py/NKF.python/README Thu Apr 14 23:16:11 2005
+@@ -0,0 +1,12 @@
++Python Interface to NKF
++
++1. How to Install
++
++ # python setup.py install
++
++2. Usage
++
++ from nkf import nkf
++ output = nkf(flag, input)
++
++Matsumoto, Tadashi ma2@city.plala.jp
+diff -Naur nkf205/NKF.python/setup.py nkf205-py/NKF.python/setup.py
+--- nkf205/NKF.python/setup.py Thu Jan 1 09:00:00 1970
++++ nkf205-py/NKF.python/setup.py Thu Apr 14 23:16:11 2005
+@@ -0,0 +1,12 @@
++#!/usr/bin/env python
++
++from distutils.core import setup, Extension
++
++setup (name = "nkf",
++ version="1.0",
++ description="Python Interface to NKF",
++ author="Matsumoto Tadashi",
++ author_email="ma2@city.plala.jp",
++ ext_modules = [
++ Extension("nkf", ["NKF_python.c"],
++ extra_link_args = ['-s'])])
diff --git a/app-i18n/nkf/nkf-2.0.5-r1.ebuild b/app-i18n/nkf/nkf-2.0.5-r1.ebuild
new file mode 100644
index 000000000000..1b267933df33
--- /dev/null
+++ b/app-i18n/nkf/nkf-2.0.5-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/nkf/nkf-2.0.5-r1.ebuild,v 1.1 2005/04/20 16:44:43 nakano Exp $
+
+inherit gcc eutils perl-module distutils
+
+MY_P="${PN}${PV//./}"
+DESCRIPTION="Network Kanji code conversion Filter with UTF-8/16 support"
+HOMEPAGE="http://sourceforge.jp/projects/nkf/"
+SRC_URI="http://www01.tcp-ip.or.jp/~furukawa/nkf_utf8/${MY_P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~amd64 ~ppc64 ~ia64"
+IUSE="perl cjk python"
+
+DEPEND="virtual/libc"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ emake CC="$(gcc-getCC)" CFLAGS="${CFLAGS}" nkf || die
+ if use perl; then
+ cd ${S}/NKF.mod
+ perl-module_src_compile
+ perl-module_src_test
+ fi
+ if use python; then
+ cd ${WORKDIR}
+ epatch ${FILESDIR}/nkf-python.patch
+ cd ${S}/NKF.python
+ distutils_src_compile
+ distutils_src_test
+ fi
+}
+
+src_install() {
+ dobin nkf || die
+ doman nkf.1
+ if use cjk; then
+ dodir /usr/share/man/ja/man1
+ insinto /usr/share/man/ja/man1
+ ./nkf -e nkf.1j > nkf.1
+ doins nkf.1
+ fi
+ dodoc INSTALL* nkf.doc
+ if use perl; then
+ cd ${S}/NKF.mod
+ perl-module_src_install
+ fi
+ if use python; then
+ cd ${S}/NKF.python
+ distutils_src_install
+ fi
+}