summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2004-07-01 22:14:13 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2004-07-01 22:14:13 +0000
commit5aefb6b3908602cd3e7f3f7fb4ff2d40d3f9892c (patch)
tree1268b06b15c50bf915ed3965a4322ceed449db19 /app-i18n/freewnn/freewnn-1.1.1_alpha20-r1.ebuild
parentvirtual/glibc -> virtual/libc (diff)
downloadhistorical-5aefb6b3908602cd3e7f3f7fb4ff2d40d3f9892c.tar.gz
historical-5aefb6b3908602cd3e7f3f7fb4ff2d40d3f9892c.tar.bz2
historical-5aefb6b3908602cd3e7f3f7fb4ff2d40d3f9892c.zip
Fixed compile issue.
Diffstat (limited to 'app-i18n/freewnn/freewnn-1.1.1_alpha20-r1.ebuild')
-rw-r--r--app-i18n/freewnn/freewnn-1.1.1_alpha20-r1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/app-i18n/freewnn/freewnn-1.1.1_alpha20-r1.ebuild b/app-i18n/freewnn/freewnn-1.1.1_alpha20-r1.ebuild
new file mode 100644
index 000000000000..ecc3e0660614
--- /dev/null
+++ b/app-i18n/freewnn/freewnn-1.1.1_alpha20-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/freewnn/freewnn-1.1.1_alpha20-r1.ebuild,v 1.1 2004/07/01 22:14:12 matsuu Exp $
+
+inherit eutils
+
+MY_P="FreeWnn-${PV/_alpha/-a0}"
+
+DESCRIPTION="Network-Extensible Kana-to-Kanji Conversion System"
+HOMEPAGE="http://www.freewnn.org/"
+SRC_URI="ftp://ftp.freewnn.org/pub/FreeWnn/alpha/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~amd64 ~ia64"
+IUSE="X ipv6"
+
+DEPEND="virtual/libc
+ X? ( virtual/x11 )"
+
+S="${WORKDIR}/FreeWnn-1.10-pl020"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ #Change WNNOWNER to root so we don't need to add wnn user
+ sed -i -e "s/WNNOWNER = wnn/WNNOWNER = root/" makerule.mk.in || die
+ epatch ${FILESDIR}/${P}-gentoo.diff
+}
+
+src_compile() {
+ econf \
+ --disable-cWnn \
+ --disable-kWnn \
+ --without-termcap \
+ `use_with X x` \
+ `use_with ipv6` || die "./configure failed"
+
+ emake || die
+ #make || die
+}
+
+src_install() {
+ # install executables, libs ,dictionaries
+ make DESTDIR=${D} install || die "installation failed"
+ # install man pages
+ make DESTDIR=${D} install.man || die "installation of manpages failed"
+ # install docs
+ dodoc ChangeLog* INSTALL* CONTRIBUTORS
+ # install rc script
+ exeinto /etc/init.d ; newexe ${FILESDIR}/freewnn.initd freewnn
+}