summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-02-25 18:13:29 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-02-25 18:13:29 +0000
commit5d6e6929e5b5dcb04a00fd2a548b00b29e1e6632 (patch)
treec8aceb7a600f47894fafb3bfeabce1b2ce7a8c66 /app-i18n/enca/enca-1.13.ebuild
parentVersion bump (new translations and "install -s" fix). (diff)
downloadhistorical-5d6e6929e5b5dcb04a00fd2a548b00b29e1e6632.tar.gz
historical-5d6e6929e5b5dcb04a00fd2a548b00b29e1e6632.tar.bz2
historical-5d6e6929e5b5dcb04a00fd2a548b00b29e1e6632.zip
Version bump.
Package-Manager: portage-15455-svn/cvs/Linux x86_64
Diffstat (limited to 'app-i18n/enca/enca-1.13.ebuild')
-rw-r--r--app-i18n/enca/enca-1.13.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-i18n/enca/enca-1.13.ebuild b/app-i18n/enca/enca-1.13.ebuild
new file mode 100644
index 000000000000..c36ab901badf
--- /dev/null
+++ b/app-i18n/enca/enca-1.13.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/enca/enca-1.13.ebuild,v 1.1 2010/02/25 18:13:29 arfrever Exp $
+
+EAPI="2"
+
+inherit toolchain-funcs
+
+DESCRIPTION="ENCA detects the character coding of a file and converts it if desired"
+HOMEPAGE="http://gitorious.org/enca"
+SRC_URI="http://dl.cihar.com/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc +recode"
+
+DEPEND="recode? ( >=app-text/recode-3.6_p15 )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ --enable-external \
+ $(use_with recode librecode /usr) \
+ $(use_enable doc gtk-doc)
+}
+
+src_compile() {
+ if tc-is-cross-compiler; then
+ pushd tools > /dev/null
+ $(tc-getBUILD_CC) -o make_hash make_hash.c || die "native make_hash failed"
+ popd > /dev/null
+ fi
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}