summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2010-02-26 20:29:59 +0000
committerPatrick Lauer <patrick@gentoo.org>2010-02-26 20:29:59 +0000
commitaf7109e0fa2540e93e74992d125ad5271ff95337 (patch)
treeb72484118dc0b6bb0e3ff0f4ab5ebdeb9153b0be /app-forensics
parentAutomated update of use.local.desc (diff)
downloadhistorical-af7109e0fa2540e93e74992d125ad5271ff95337.tar.gz
historical-af7109e0fa2540e93e74992d125ad5271ff95337.tar.bz2
historical-af7109e0fa2540e93e74992d125ad5271ff95337.zip
Bump
Package-Manager: portage-2.2_rc63/cvs/Linux x86_64
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/afflib/ChangeLog9
-rw-r--r--app-forensics/afflib/afflib-3.5.8.ebuild43
-rw-r--r--app-forensics/libewf/ChangeLog9
-rw-r--r--app-forensics/libewf/libewf-20100226.ebuild43
4 files changed, 100 insertions, 4 deletions
diff --git a/app-forensics/afflib/ChangeLog b/app-forensics/afflib/ChangeLog
index 2cec045e52d7..e58b5327799e 100644
--- a/app-forensics/afflib/ChangeLog
+++ b/app-forensics/afflib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-forensics/afflib
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/afflib/ChangeLog,v 1.7 2009/11/08 12:01:39 patrick Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/afflib/ChangeLog,v 1.8 2010/02/26 20:25:22 patrick Exp $
+
+*afflib-3.5.8 (26 Feb 2010)
+
+ 26 Feb 2010; Patrick Lauer <patrick@gentoo.org> +afflib-3.5.8.ebuild:
+ Bump
*afflib-3.5.2 (08 Nov 2009)
diff --git a/app-forensics/afflib/afflib-3.5.8.ebuild b/app-forensics/afflib/afflib-3.5.8.ebuild
new file mode 100644
index 000000000000..da7dbe6bc9ab
--- /dev/null
+++ b/app-forensics/afflib/afflib-3.5.8.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/afflib/afflib-3.5.8.ebuild,v 1.1 2010/02/26 20:25:22 patrick Exp $
+
+inherit eutils
+
+DESCRIPTION="Library that implements the AFF image standard"
+HOMEPAGE="http://www.afflib.org/"
+SRC_URI="http://www.afflib.org/downloads/${P}.tar.gz"
+
+LICENSE="BSD-4"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~s390 ~sparc ~x86"
+IUSE="ewf fuse ncurses python qemu readline s3 threads"
+
+DEPEND="
+ ewf? ( app-forensics/libewf )
+ fuse? ( sys-fs/fuse )
+ ncurses? ( sys-libs/ncurses )
+ python? ( dev-lang/python )
+ readline? ( sys-libs/readline )
+ s3? ( net-misc/curl dev-libs/expat )
+ sys-libs/zlib
+ dev-libs/openssl"
+RDEPEND=${DEPEND}
+
+src_compile() {
+ econf \
+ $(use_enable fuse) \
+ $(use_enable ewf libewf) \
+ $(use_enable python) \
+ $(use_enable qemu) \
+ $(use_enable s3) \
+ $(use_enable threads threading)
+ emake || die "build failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "install failed"
+ use s3 || {
+ rm -f "${D}/usr/bin/s3"
+ }
+}
diff --git a/app-forensics/libewf/ChangeLog b/app-forensics/libewf/ChangeLog
index bc0e32547e2c..2589fcf92d9a 100644
--- a/app-forensics/libewf/ChangeLog
+++ b/app-forensics/libewf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-forensics/libewf
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/libewf/ChangeLog,v 1.6 2009/11/08 11:54:19 patrick Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/libewf/ChangeLog,v 1.7 2010/02/26 20:29:59 patrick Exp $
+
+*libewf-20100226 (26 Feb 2010)
+
+ 26 Feb 2010; Patrick Lauer <patrick@gentoo.org> +libewf-20100226.ebuild:
+ Bump
*libewf-20091108 (08 Nov 2009)
diff --git a/app-forensics/libewf/libewf-20100226.ebuild b/app-forensics/libewf/libewf-20100226.ebuild
new file mode 100644
index 000000000000..00ee21c46344
--- /dev/null
+++ b/app-forensics/libewf/libewf-20100226.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/libewf/libewf-20100226.ebuild,v 1.1 2010/02/26 20:29:59 patrick Exp $
+
+inherit eutils autotools
+
+DESCRIPTION="Implementation of the EWF (SMART and EnCase) image format"
+HOMEPAGE="http://libewf.sourceforge.net"
+SRC_URI="mirror://sourceforge/libewf/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~s390 ~sparc ~x86"
+# upstream bug #2597171, pyewf has implicit declarations
+#IUSE="debug python rawio unicode"
+IUSE="debug rawio unicode"
+
+DEPEND="
+ sys-libs/e2fsprogs-libs
+ sys-libs/zlib
+ dev-libs/openssl"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ eautoreconf
+}
+
+src_compile() {
+ econf \
+ $(use_enable unicode wide-character-type) \
+ $(use_enable rawio raw-access) \
+ $(use_enable debug verbose-output) \
+ $(use_enable debug debug-output)
+ emake
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dodoc AUTHORS ChangeLog NEWS README documents/*.txt
+ doman manuals/*.1 manuals/*.3
+}