summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-03-01 01:20:53 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-03-01 01:20:53 +0000
commitd54b9845631071e52330751fe0c44f39b1a5be6a (patch)
tree50a6808b101d02e7722d7026313c3032bf419806 /app-forensics/sleuthkit/sleuthkit-3.0.0-r1.ebuild
parentFix ebuild to use GPE_DOCS from the new gpe eclass. (diff)
downloadhistorical-d54b9845631071e52330751fe0c44f39b1a5be6a.tar.gz
historical-d54b9845631071e52330751fe0c44f39b1a5be6a.tar.bz2
historical-d54b9845631071e52330751fe0c44f39b1a5be6a.zip
Adding ewf and aff useflags as the deps for those have been committed.
Package-Manager: portage-2.2_rc23/cvs/Linux x86_64
Diffstat (limited to 'app-forensics/sleuthkit/sleuthkit-3.0.0-r1.ebuild')
-rw-r--r--app-forensics/sleuthkit/sleuthkit-3.0.0-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-forensics/sleuthkit/sleuthkit-3.0.0-r1.ebuild b/app-forensics/sleuthkit/sleuthkit-3.0.0-r1.ebuild
new file mode 100644
index 000000000000..4f020b98cebf
--- /dev/null
+++ b/app-forensics/sleuthkit/sleuthkit-3.0.0-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/sleuthkit/sleuthkit-3.0.0-r1.ebuild,v 1.1 2009/03/01 01:20:53 patrick Exp $
+
+inherit eutils flag-o-matic autotools
+
+SLOT=0
+
+DESCRIPTION="A collection of file system and media management forensic analysis tools"
+HOMEPAGE="http://www.sleuthkit.org/sleuthkit/"
+SRC_URI="mirror://sourceforge/sleuthkit/${P}.tar.gz"
+
+LICENSE="GPL-2 IBM"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="ewf? ( app-forensics/libewf )
+ aff? ( app-forensics/afflib )"
+RDEPEND="${DEPEND}
+ dev-perl/DateManip"
+
+IUSE="aff ewf"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # AC_FUNC_REALLOC in configure.ac that hasn't been propagated
+ eautoreconf
+}
+
+src_compile() {
+ econf || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc docs/*.txt README.txt CHANGES.txt TODO.txt
+}