summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-10-27 12:45:14 +0000
committerMike Frysinger <vapier@gentoo.org>2004-10-27 12:45:14 +0000
commitb2fbee27e22929b16eb7351cd30717a81e777fd8 (patch)
tree642d310a6b36fcd0687cd1612456798048db58d5 /app-emulation
parentFixing #69115 (diff)
downloadhistorical-b2fbee27e22929b16eb7351cd30717a81e777fd8.tar.gz
historical-b2fbee27e22929b16eb7351cd30717a81e777fd8.tar.bz2
historical-b2fbee27e22929b16eb7351cd30717a81e777fd8.zip
ver bump #68525 and make sure USE flags are respected #35482
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine/ChangeLog7
-rw-r--r--app-emulation/wine/Manifest14
-rw-r--r--app-emulation/wine/files/digest-wine-200410193
-rw-r--r--app-emulation/wine/wine-20041019.ebuild142
4 files changed, 154 insertions, 12 deletions
diff --git a/app-emulation/wine/ChangeLog b/app-emulation/wine/ChangeLog
index a6b6f2611e31..0e72522661ac 100644
--- a/app-emulation/wine/ChangeLog
+++ b/app-emulation/wine/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/wine
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.77 2004/08/03 15:44:30 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.78 2004/10/27 12:45:14 vapier Exp $
+
+*wine-20041019 (27 Oct 2004)
+
+ 27 Oct 2004; Mike Frysinger <vapier@gentoo.org> +wine-20041019.ebuild:
+ Version bump #68525 and others. Make sure USE flags are obeyed #35482.
03 Aug 2004; Martin Holzer <mholzer@gentoo.org> wine-20040121.ebuild,
wine-20040213.ebuild, wine-20040309.ebuild, wine-20040408-r1.ebuild,
diff --git a/app-emulation/wine/Manifest b/app-emulation/wine/Manifest
index b42912122417..674b9c5df112 100644
--- a/app-emulation/wine/Manifest
+++ b/app-emulation/wine/Manifest
@@ -1,16 +1,8 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 6111a85d7f14dd97627c303240caa276 ChangeLog 13502
+MD5 878ccf9a45f17e6b3d0f80894a730588 ChangeLog 13679
MD5 6525c48ba09d08599432ea6c299e52f4 metadata.xml 354
+MD5 e7805af379978fabb615d97b8590eac2 wine-20041019.ebuild 3714
MD5 0b8a40b373bf8ab6c0368dd5a64f5449 wine-20040716.ebuild 3443
+MD5 64c9b939319110b4f44ef6f431262181 files/digest-wine-20041019 212
MD5 1668a758aa2007cb99a773b3c5c844c9 files/winearts-kdecvs-fix.patch 325
MD5 ae28341f05c0916661c1346a28720230 files/QueryActCtxw_Photoshop7.0.diff 686
MD5 b1893ef0ed5c38dabcbea9fcc3d35f59 files/digest-wine-20040716 212
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.9.10 (GNU/Linux)
-
-iD8DBQFBfQrSHTu7gpaalycRAhMPAKDXeTBjbTeOzC4uOCcZMKHy510ScQCfawKD
-EvrNMBaPSlsKtPpNFiM43uU=
-=pXja
------END PGP SIGNATURE-----
diff --git a/app-emulation/wine/files/digest-wine-20041019 b/app-emulation/wine/files/digest-wine-20041019
new file mode 100644
index 000000000000..811223464fc5
--- /dev/null
+++ b/app-emulation/wine/files/digest-wine-20041019
@@ -0,0 +1,3 @@
+MD5 412d0e6f2e364c43d8c77b5904c70da9 Wine-20041019.tar.gz 11058180
+MD5 af8da46a0e51578ff1e18e399141d628 wine-20040716-fake_windows.tar.bz2 500
+MD5 e85afd5661bfc1b6dffc05db480b52a8 wine-20040716-misc.tar.bz2 5300
diff --git a/app-emulation/wine/wine-20041019.ebuild b/app-emulation/wine/wine-20041019.ebuild
new file mode 100644
index 000000000000..efc318f8aa32
--- /dev/null
+++ b/app-emulation/wine/wine-20041019.ebuild
@@ -0,0 +1,142 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20041019.ebuild,v 1.1 2004/10/27 12:45:14 vapier Exp $
+
+inherit eutils flag-o-matic
+
+STAMP=20040716
+DESCRIPTION="free implementation of Windows(tm) on Unix - CVS snapshot"
+HOMEPAGE="http://www.winehq.com/"
+SRC_URI="mirror://sourceforge/${PN}/Wine-${PV}.tar.gz
+ mirror://gentoo/${PN}-${STAMP}-fake_windows.tar.bz2
+ mirror://gentoo/${PN}-${STAMP}-misc.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="-* ~x86"
+IUSE="X jack alsa arts cups debug nas opengl tcltk ncurses"
+
+DEPEND="sys-devel/gcc
+ sys-devel/flex
+ ncurses? ( >=sys-libs/ncurses-5.2 )
+ >=media-libs/freetype-2.0.0
+ jack? ( media-sound/jack )
+ X? ( virtual/x11 )
+ tcltk? ( dev-lang/tcl dev-lang/tk )
+ arts? ( kde-base/arts )
+ alsa? ( media-libs/alsa-lib )
+ nas? ( media-libs/nas )
+ cups? ( net-print/cups )
+ opengl? ( virtual/opengl )
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack Wine-${PV}.tar.gz
+ unpack ${PN}-${STAMP}-fake_windows.tar.bz2
+ mkdir misc ; cd misc
+ unpack ${PN}-${STAMP}-misc.tar.bz2
+
+ cd ${S}
+ epatch ${FILESDIR}/winearts-kdecvs-fix.patch
+ sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
+}
+
+config_cache() {
+ local h ans="no"
+ use ${1} && ans="yes"
+ shift
+ for h in "$@" ; do
+ export ac_cv_header_${h}=${ans}
+ done
+}
+
+src_compile() {
+ export LDCONFIG=/bin/true
+ config_cache jack jack_jack_h
+ config_cache cups cups_cups_h
+ config_cache alsa alsa_asoundlib_h sys_asoundlib_h
+ use arts || export ARTSCCONFIG="/bin/false"
+ config_cache nas audio_audiolib_h
+
+ strip-flags
+
+ ./configure \
+ --prefix=/usr/lib/wine \
+ --sysconfdir=/etc/wine \
+ --build=${CBUILD:-${CHOST}} \
+ --host=${CHOST} \
+ --target=${CTARGET:-${CHOST}} \
+ $(use_enable ncurses curses) \
+ $(use_enable opengl) \
+ $(use_enable debug trace) \
+ $(use_enable debug) \
+ || die "configure failed"
+
+ cd ${S}/programs/winetest
+ sed -i 's:wine.pm:include/wine.pm:' Makefile
+
+ # No parallel make
+ cd ${S}
+ make depend all || die
+ cd programs && emake || die
+}
+
+src_install() {
+ local WINEMAKEOPTS="prefix=${D}/usr/lib/wine"
+
+ ### Install wine to ${D}
+ make ${WINEMAKEOPTS} install || die
+ cd ${S}/programs
+ make ${WINEMAKEOPTS} install || die
+
+ # Needed for later installation
+ dodir /usr/bin
+
+ ### Creation of /usr/lib/wine/.data
+ # Setting up fake_windows
+ dodir /usr/lib/wine/.data
+ cd ${D}/usr/lib/wine/.data
+ cp -r ${WORKDIR}/fake_windows . || die "fake_windows"
+ chown root:root fake_windows/ -R
+
+ # Unpacking the miscellaneous files
+ cp ${WORKDIR}/misc/* . || die "misc"
+ chown root:root config
+
+ # moving the wrappers to bin/
+ insinto /usr/bin
+ dobin regedit-wine wine winedbg wine-pthread
+ rm regedit-wine wine winedbg wine-pthread
+
+ # copying the wine.inf into .data (used to be winedefault.reg)
+ cd ${S}
+ dodir /usr/lib/wine/.data
+ insinto /usr/lib/wine/.data
+ doins tools/wine.inf
+ insinto /usr/lib/wine/.data/fake_windows/Windows/System
+ doins tools/wine.inf
+ insinto /usr/lib/wine/.data/fake_windows/Windows/Inf
+ doins tools/wine.inf
+
+ ### Misc tasks
+ # Take care of the documentation
+ cd ${S}
+ dodoc ANNOUNCE AUTHORS BUGS ChangeLog DEVELOPERS-HINTS README
+
+ # Manpage setup
+
+ newman ${D}/usr/lib/${PN}/man/man1/wine.1 ${PN}.1
+ rm ${D}/usr/lib/${PN}/man/man1/${PN}.1
+ doman ${D}/usr/lib/${PN}/man/man5/wine.conf.5
+ rm ${D}/usr/lib/${PN}/man/man5/wine.conf.5
+}
+
+pkg_postinst() {
+ einfo "Use /usr/bin/wine to start wine. This is a wrapper-script"
+ einfo "which will take care of everything else."
+ einfo
+ einfo "if you have problems with nptl, use wine-pthread to start wine"
+ einfo
+ einfo "Use /usr/bin/regedit-wine to import registry files into the"
+ einfo "wine registry."
+}