summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-11-10 05:28:28 +0000
committerMike Frysinger <vapier@gentoo.org>2004-11-10 05:28:28 +0000
commit7180752a1486a614fff2bcefe6189f544acd5b47 (patch)
tree00ca91adda0f81c390227140c20b6dcff9b89a40 /app-emulation
parentfix patches so they past libtool tests (diff)
downloadhistorical-7180752a1486a614fff2bcefe6189f544acd5b47.tar.gz
historical-7180752a1486a614fff2bcefe6189f544acd5b47.tar.bz2
historical-7180752a1486a614fff2bcefe6189f544acd5b47.zip
Version bump #70605 by Jim Tupper.
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/cedega/ChangeLog7
-rw-r--r--app-emulation/cedega/Manifest14
-rw-r--r--app-emulation/cedega/cedega-4.1.1.ebuild54
-rw-r--r--app-emulation/cedega/files/digest-cedega-4.1.11
4 files changed, 64 insertions, 12 deletions
diff --git a/app-emulation/cedega/ChangeLog b/app-emulation/cedega/ChangeLog
index 2e70693a86cf..b2ac11b33b45 100644
--- a/app-emulation/cedega/ChangeLog
+++ b/app-emulation/cedega/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/cedega
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/cedega/ChangeLog,v 1.6 2004/10/24 05:46:57 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/cedega/ChangeLog,v 1.7 2004/11/10 05:28:28 vapier Exp $
+
+*cedega-4.1.1 (10 Nov 2004)
+
+ 10 Nov 2004; Mike Frysinger <vapier@gentoo.org> +cedega-4.1.1.ebuild:
+ Version bump #70605 by Jim Tupper.
*cedega-4.1 (24 Oct 2004)
diff --git a/app-emulation/cedega/Manifest b/app-emulation/cedega/Manifest
index 3230b10ed2dc..7b1d6e28905d 100644
--- a/app-emulation/cedega/Manifest
+++ b/app-emulation/cedega/Manifest
@@ -1,18 +1,10 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 c4c3178879634b4e5cb0f8adff2c86d3 ChangeLog 775
+MD5 e463b8d11f897701e1b4774bba90d419 ChangeLog 914
MD5 e1fd58d4d29b11247fd8e6fb89a74efc cedega-4.0.ebuild 1903
MD5 6525c48ba09d08599432ea6c299e52f4 metadata.xml 354
MD5 ea9268c54bbecbb484aa6242b4ae9c08 cedega-4.0.1.ebuild 1901
+MD5 9f4f9c998dc3beb0aa1f817df058ad05 cedega-4.1.1.ebuild 1906
MD5 2d9b7f28af5368228c02625ee45dedc1 cedega-4.1.ebuild 1904
MD5 7eccc393a8bb2164b799f66650fc2b54 files/digest-cedega-4.0 67
MD5 0ec2c4d5f2aa15fadf20a22ae70f6188 files/digest-cedega-4.0.1 69
MD5 ffb176a2f0e413c04ab3ea5e50ead483 files/digest-cedega-4.1 67
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.9.10 (GNU/Linux)
-
-iD8DBQFBfcNoHTu7gpaalycRAr1wAJ9IDVHkUT9xis9kcyo9h7jRO951SwCgwQY/
-pQmThs7NSTlrKLnABafxAkQ=
-=UeX/
------END PGP SIGNATURE-----
+MD5 73ddb9d92b6c018acae1f3bd69cc9b39 files/digest-cedega-4.1.1 69
diff --git a/app-emulation/cedega/cedega-4.1.1.ebuild b/app-emulation/cedega/cedega-4.1.1.ebuild
new file mode 100644
index 000000000000..acd06c2d73d2
--- /dev/null
+++ b/app-emulation/cedega/cedega-4.1.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/cedega/cedega-4.1.1.ebuild,v 1.1 2004/11/10 05:28:28 vapier Exp $
+
+MY_P="cedega_${PV}-1.i386"
+DESCRIPTION="Cedega replaces WineX, a distribution of Wine with enhanced DirectX for gaming"
+HOMEPAGE="http://www.transgaming.com/"
+SRC_URI="${MY_P}.tgz"
+
+LICENSE="Aladdin"
+SLOT="3"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="cups opengl"
+RESTRICT="fetch"
+
+RDEPEND="virtual/x11
+ opengl? ( virtual/opengl )
+ >=sys-libs/ncurses-5.2
+ cups? ( net-print/cups )
+ >=media-libs/freetype-2.0.0"
+
+pkg_nofetch() {
+ einfo "Please download the appropriate Cedega archive (${MY_P}.tgz)"
+ einfo "from ${HOMEPAGE} (requires a Transgaming subscription)"
+ einfo
+ einfo "Then put the file in ${DISTDIR}"
+}
+
+src_install() {
+ mv ${WORKDIR}/usr ${D}
+}
+
+pkg_postinst() {
+ einfo "Run /usr/bin/cedega to start cedega as any non-root user."
+ einfo "This is a wrapper-script which will take care of creating"
+ einfo "an initial environment and do everything else."
+ einfo ""
+ einfo "Optionally, if you have binfmt_misc compiled into your kernel,"
+ einfo "you can add the following to /etc/sysctl.conf to allow direct"
+ einfo "excecution of Windows binaries through the cedega wrapper:"
+ einfo ""
+ einfo " fs.binfmt_misc.register = :WINEXE:M::MZ::/usr/bin/cedega:"
+ einfo ""
+ einfo "You will also need to mount the /proc/sys/fs/binfmt_misc"
+ einfo "file system in order for this to work. You can add the following"
+ einfo "line into your /etc/fstab file:"
+ einfo ""
+ einfo " none /proc/sys/fs/binfmt_misc binfmt_misc defaults 0 0"
+ einfo ""
+ einfo "Note: Binaries will still need excecutable permissions to run."
+ einfo "Note: If binfmt_misc is compiled as a module, make sure you"
+ einfo "have it loaded on startup by adding it to"
+ einfo "/etc/modules.autoload.d/<your kernel version>"
+}
diff --git a/app-emulation/cedega/files/digest-cedega-4.1.1 b/app-emulation/cedega/files/digest-cedega-4.1.1
new file mode 100644
index 000000000000..7204f3f61b94
--- /dev/null
+++ b/app-emulation/cedega/files/digest-cedega-4.1.1
@@ -0,0 +1 @@
+MD5 9851d4702c93498b05fd7675c36f37f6 cedega_4.1.1-1.i386.tgz 7463762