summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-03-05 22:42:05 +0000
committerMike Frysinger <vapier@gentoo.org>2011-03-05 22:42:05 +0000
commit7dabd1ad92986a2b7428a1067d549fe9efd09971 (patch)
tree02aa9fa47327b7a4f2c52a4055dda2a7a9d701d9 /app-emulation/wine/wine-9999.ebuild
parentFix dependencies. Restrict Jython ABIs. Add src_test(). (diff)
downloadhistorical-7dabd1ad92986a2b7428a1067d549fe9efd09971.tar.gz
historical-7dabd1ad92986a2b7428a1067d549fe9efd09971.tar.bz2
historical-7dabd1ad92986a2b7428a1067d549fe9efd09971.zip
Add USE=mousewarp patch to auto apply the mouse-warp patch.
Package-Manager: portage-2.2.0_alpha25/cvs/Linux x86_64
Diffstat (limited to 'app-emulation/wine/wine-9999.ebuild')
-rw-r--r--app-emulation/wine/wine-9999.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/app-emulation/wine/wine-9999.ebuild b/app-emulation/wine/wine-9999.ebuild
index 4edb939dcffd..55c48cdb0350 100644
--- a/app-emulation/wine/wine-9999.ebuild
+++ b/app-emulation/wine/wine-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-9999.ebuild,v 1.72 2011/02/05 09:23:15 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-9999.ebuild,v 1.73 2011/03/05 22:42:05 vapier Exp $
EAPI="2"
@@ -33,7 +33,7 @@ SRC_URI="${SRC_URI}
LICENSE="LGPL-2.1"
SLOT="0"
-IUSE="alsa capi cups custom-cflags dbus esd fontconfig +gecko gnutls gphoto2 gsm gstreamer hal jack jpeg lcms ldap mp3 nas ncurses nls openal +opengl +oss +perl png pulseaudio samba scanner ssl test +threads +truetype +win32 +win64 +X xcomposite xinerama xml"
+IUSE="alsa capi cups custom-cflags dbus esd fontconfig +gecko gnutls gphoto2 gsm gstreamer hal jack jpeg lcms ldap mousewarp mp3 nas ncurses nls openal +opengl +oss +perl png pulseaudio samba scanner ssl test +threads +truetype +win32 +win64 +X xcomposite xinerama xml"
RESTRICT="test" #72375
MLIB_DEPS="amd64? (
@@ -113,6 +113,7 @@ src_unpack() {
}
src_prepare() {
+ use mousewarp && epatch "${FILESDIR}"/${PN}-1.3.14-mouse-warp.patch
if use pulseaudio ; then
EPATCH_OPTS=-p1 epatch `pulse_patches "${DISTDIR}"`
eautoreconf