summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-06-17 02:06:09 +0000
committerMike Frysinger <vapier@gentoo.org>2005-06-17 02:06:09 +0000
commit2e009762ded3b53d2fdcf8ac13422d3aaf1d0e6f (patch)
tree60266408ce566cc898175149b963af33f4c2b34f /app-emulation/wine/wine-20050310-r1.ebuild
parentStable on x86 per security bug #91785 (diff)
downloadhistorical-2e009762ded3b53d2fdcf8ac13422d3aaf1d0e6f.tar.gz
historical-2e009762ded3b53d2fdcf8ac13422d3aaf1d0e6f.tar.bz2
historical-2e009762ded3b53d2fdcf8ac13422d3aaf1d0e6f.zip
add -m32 to CFLAGS with 2004.3 amd64 #96132
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'app-emulation/wine/wine-20050310-r1.ebuild')
-rw-r--r--app-emulation/wine/wine-20050310-r1.ebuild26
1 files changed, 14 insertions, 12 deletions
diff --git a/app-emulation/wine/wine-20050310-r1.ebuild b/app-emulation/wine/wine-20050310-r1.ebuild
index 95c1bd74d3f9..ed9ca21e0297 100644
--- a/app-emulation/wine/wine-20050310-r1.ebuild
+++ b/app-emulation/wine/wine-20050310-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050310-r1.ebuild,v 1.3 2005/05/29 03:48:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050310-r1.ebuild,v 1.4 2005/06/17 02:06:08 vapier Exp $
inherit eutils flag-o-matic
@@ -39,16 +39,12 @@ DEPEND="${RDEPEND}
sys-devel/flex"
pkg_setup() {
- if use amd64 ; then
- if ! has_m32; then
- eerror "Your compiler seems to be unable to compile 32bit code."
- eerror "Make sure you compile gcc with:"
- echo
- eerror " USE=multilib FEATURES=-sandbox"
- die "Cannot produce 32bit code"
- else
- export ABI=x86
- fi
+ if use amd64 && ! has_m32 ; then
+ eerror "Your compiler seems to be unable to compile 32bit code."
+ eerror "Make sure you compile gcc with:"
+ echo
+ eerror " USE=multilib FEATURES=-sandbox"
+ die "Cannot produce 32bit code"
fi
}
@@ -86,7 +82,13 @@ src_compile() {
config_cache lcms header_lcms_h
strip-flags
- use lcms && append-flags -I${ROOT}/usr/include/lcms
+ use lcms && append-flags -I"${ROOT}"/usr/include/lcms
+
+ if use amd64 ; then
+ [[ -n $(get_abi_var) ]] \
+ && export ABI=x86 \
+ || append-flags -m32
+ fi
if ! built_with_use app-text/docbook-sgml-utils tetex ; then
export DB2PDF=true