summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Duft <mduft@gentoo.org>2014-04-11 05:16:57 +0000
committerMarkus Duft <mduft@gentoo.org>2014-04-11 05:16:57 +0000
commit53c8970bb0a56da5b41fae46e4874eed36b8caea (patch)
tree916ada4b874606632586ada14443fae84476cd8a /app-emulation/rex-client
parentgo multilib (diff)
downloadhistorical-53c8970bb0a56da5b41fae46e4874eed36b8caea.tar.gz
historical-53c8970bb0a56da5b41fae46e4874eed36b8caea.tar.bz2
historical-53c8970bb0a56da5b41fae46e4874eed36b8caea.zip
initial addition of rex-client
Package-Manager: portage-2.2.8-r1/cvs/Linux x86_64
Diffstat (limited to 'app-emulation/rex-client')
-rw-r--r--app-emulation/rex-client/ChangeLog10
-rw-r--r--app-emulation/rex-client/Manifest3
-rw-r--r--app-emulation/rex-client/metadata.xml12
-rw-r--r--app-emulation/rex-client/rex-client-9999.ebuild40
4 files changed, 65 insertions, 0 deletions
diff --git a/app-emulation/rex-client/ChangeLog b/app-emulation/rex-client/ChangeLog
new file mode 100644
index 000000000000..e2640c0da404
--- /dev/null
+++ b/app-emulation/rex-client/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sys-apps/rex-client
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/rex-client/ChangeLog,v 1.1 2014/04/11 05:16:54 mduft Exp $
+
+*rex-client-9999 (07 Apr 2014)
+
+ 07 Apr 2014; Markus Duft <mduft@gentoo.org> +rex-client-9999.ebuild,
+ +metadata.xml:
+ initial addition of live ebuild
+
diff --git a/app-emulation/rex-client/Manifest b/app-emulation/rex-client/Manifest
new file mode 100644
index 000000000000..d6a032a92186
--- /dev/null
+++ b/app-emulation/rex-client/Manifest
@@ -0,0 +1,3 @@
+EBUILD rex-client-9999.ebuild 933 SHA256 296a87b5c0719e836e6b60cfc9987245857d97dfdf8101fb2793db6e2568dad4 SHA512 4586a879b874afe037a7c742fc2545b505f8a5ef98b849fad9cb228fe83238da280e834f5e8c94cb96c32ac77c9e473a277dd96029d297cfc1d71b144f0d1e76 WHIRLPOOL 53200103100e1a28b5af0ded9b8fe03e1fcf0596e1f5a96ce629475db248fe68de5ab3cf695a80bbcec1c76d884b0aa03fb630213514868761e61f8d0cdb506d
+MISC ChangeLog 370 SHA256 dffe243fe2a13d8869888ab3bf366907da04c46f30f1ca117f28838f61938654 SHA512 ba16fb3cf6ad46456764b45d28c9bc59928907550041c19cca00057e46588e5a4ce3c5bc3fc08d906b4b15d0952274ca4df2cc97aabe9fd01ee3b7c3cec62bc2 WHIRLPOOL 42bd758c5054cbf87515bbda48f25262e53b1164962b2946f703f14e51ea26f3ce2917e515042f78808a633af6e66dda6075723d919093bf062c52fbb92c242e
+MISC metadata.xml 285 SHA256 631a4b0c131ffb44995475a5c34720c7a960fb700a2934f2cb12e7bd833cf720 SHA512 545911899582e4f5b4be5109d4dda638d4a81e294976d5e73f7fbdd73af1a4bd94eeafeae83c02ba1341af8c8927ce41c180b7fa4a27971350c3e21a65f767fc WHIRLPOOL 2093086d835b8968da3eb9205ef38bebeb58e3ed2a219f67fa983e6a661ed85ec700a49d0bd55665a73e6249b91865d11c71462d10c095288fc9e0e2b67ff71a
diff --git a/app-emulation/rex-client/metadata.xml b/app-emulation/rex-client/metadata.xml
new file mode 100644
index 000000000000..2a3134456a2c
--- /dev/null
+++ b/app-emulation/rex-client/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd></herd>
+<maintainer>
+<email>mduft@gentoo.org</email>
+<name>Markus Duft</name>
+</maintainer>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
+
diff --git a/app-emulation/rex-client/rex-client-9999.ebuild b/app-emulation/rex-client/rex-client-9999.ebuild
new file mode 100644
index 000000000000..87787d843a6d
--- /dev/null
+++ b/app-emulation/rex-client/rex-client-9999.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/rex-client/rex-client-9999.ebuild,v 1.1 2014/04/11 05:16:54 mduft Exp $
+
+EAPI="4"
+
+DESCRIPTION="REX - Remote EXexcution agent"
+HOMEPAGE="http://mduft.github.io/rex/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-2
+ EGIT_REPO_URI="https://github.com/mduft/rex.git"
+ EGIT_PROJECT="${PN}"
+else
+ SRC_URI=""
+ KEYWORDS="~x86-linux"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+REX_EXE=( "client/rex-exec.sh" "client/rex-register.sh" "client/rex-paths.sh" "client/rex-remote-pconv.sh" "client/winpath2unix" "client/unixpath2win" )
+
+src_prepare() {
+ for x in ${REX_EXE[@]}; do
+ sed -i -e "s,\. \${HOME}/rex-config.sh,\. ${EPREFIX}/etc/rex.conf,g" "${x}"
+ done
+}
+
+src_install() {
+ cd ${S}
+ for x in ${REX_EXE[@]}; do
+ doexe ${S}/${x}
+ done
+
+ insinto /etc
+ newins client/rex-config.sh rex.conf
+}
+