summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2011-03-27 10:27:46 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2011-03-27 10:27:46 +0000
commit499109839145d83a199060247cfaad95b11bedfe (patch)
treedaa325d2048e09fe4f8859e63628fbd4b35d73c4 /app-emulation/fuse
parentVersion Bump, #360751 (diff)
downloadhistorical-499109839145d83a199060247cfaad95b11bedfe.tar.gz
historical-499109839145d83a199060247cfaad95b11bedfe.tar.bz2
historical-499109839145d83a199060247cfaad95b11bedfe.zip
Fix slot-dep on gtk+/glib
Package-Manager: portage-2.1.9.44/cvs/Linux x86_64
Diffstat (limited to 'app-emulation/fuse')
-rw-r--r--app-emulation/fuse/ChangeLog8
-rw-r--r--app-emulation/fuse/fuse-0.10.0.2-r3.ebuild10
-rw-r--r--app-emulation/fuse/fuse-0.7.0.ebuild10
3 files changed, 18 insertions, 10 deletions
diff --git a/app-emulation/fuse/ChangeLog b/app-emulation/fuse/ChangeLog
index 3b25162d4177..911e1eae6c94 100644
--- a/app-emulation/fuse/ChangeLog
+++ b/app-emulation/fuse/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/fuse
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/fuse/ChangeLog,v 1.31 2010/03/28 03:58:03 darkside Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/fuse/ChangeLog,v 1.32 2011/03/27 10:25:00 nirbheek Exp $
+
+ 27 Mar 2011; Nirbheek Chauhan <nirbheek@gentoo.org> fuse-0.7.0.ebuild,
+ fuse-0.10.0.2-r3.ebuild:
+ Fix slot-dep on gtk+/glib
28 Mar 2010; Jeremy Olexa <darkside@gentoo.org> metadata.xml:
Drop myself from metadata
diff --git a/app-emulation/fuse/fuse-0.10.0.2-r3.ebuild b/app-emulation/fuse/fuse-0.10.0.2-r3.ebuild
index 5f4c98de2132..2c59e252b8a8 100644
--- a/app-emulation/fuse/fuse-0.10.0.2-r3.ebuild
+++ b/app-emulation/fuse/fuse-0.10.0.2-r3.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/fuse/fuse-0.10.0.2-r3.ebuild,v 1.1 2009/12/22 04:38:32 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/fuse/fuse-0.10.0.2-r3.ebuild,v 1.2 2011/03/27 10:25:00 nirbheek Exp $
+
+EAPI="1"
DESCRIPTION="Free Unix Spectrum Emulator by Philip Kendall"
HOMEPAGE="http://fuse-emulator.sourceforge.net"
@@ -15,7 +17,7 @@ IUSE="alsa ao fbcon gpm gtk joystick libsamplerate memlimit sdl svga X xml"
# order of precedence: gtk, sdl, X, svga and fbcon. X version of fuse will
# be built if no valid user interface flag is chosen.
RDEPEND=">=app-emulation/libspectrum-0.5
- gtk? ( >=x11-libs/gtk+-2
+ gtk? ( x11-libs/gtk+:2
alsa? ( media-libs/alsa-lib )
!alsa? ( ao? ( media-libs/libao ) )
joystick? ( media-libs/libjsw ) )
@@ -42,7 +44,7 @@ RDEPEND=">=app-emulation/libspectrum-0.5
alsa? ( media-libs/alsa-lib )
!alsa? ( ao? ( media-libs/libao ) )
joystick? ( media-libs/libjsw ) ) ) ) ) )
- >=dev-libs/glib-2
+ dev-libs/glib:2
media-libs/libpng
libsamplerate? ( >=media-libs/libsamplerate-0.1.0 )
xml? ( dev-libs/libxml2 )"
diff --git a/app-emulation/fuse/fuse-0.7.0.ebuild b/app-emulation/fuse/fuse-0.7.0.ebuild
index b9e6f10008e6..11d2c34f5ef6 100644
--- a/app-emulation/fuse/fuse-0.7.0.ebuild
+++ b/app-emulation/fuse/fuse-0.7.0.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/fuse/fuse-0.7.0.ebuild,v 1.10 2008/05/30 01:37:31 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/fuse/fuse-0.7.0.ebuild,v 1.11 2011/03/27 10:25:00 nirbheek Exp $
+
+EAPI="1"
inherit eutils
@@ -21,7 +23,7 @@ RDEPEND="dev-lang/perl
png? ( media-libs/libpng )
~app-emulation/libspectrum-0.2.2
|| (
- gtk? ( >=x11-libs/gtk+-2 )
+ gtk? ( x11-libs/gtk+:2 )
sdl? ( media-libs/libsdl )
svga? ( media-libs/svgalib )
fbcon? ( virtual/linux-sources )
@@ -29,7 +31,7 @@ RDEPEND="dev-lang/perl
x11-libs/libX11
x11-libs/libXext ) ) )
)
- >=dev-libs/glib-2
+ dev-libs/glib:2
libdsk? ( >=app-emulation/libdsk-1.1.5
app-emulation/lib765 )"