summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Holm <dholm@gentoo.org>2005-07-20 11:16:56 +0000
committerDavid Holm <dholm@gentoo.org>2005-07-20 11:16:56 +0000
commit12c36e8361f26ac2ae7df230643096eadb8093d8 (patch)
treecd01d6b7e59dda4fa6a39ee10a4b2a222f45464c /app-emulation/aranym
parentglibc-2.3.5 with linuxthreads only does not use tls on CHOST=i586 or i686. (diff)
downloadhistorical-12c36e8361f26ac2ae7df230643096eadb8093d8.tar.gz
historical-12c36e8361f26ac2ae7df230643096eadb8093d8.tar.bz2
historical-12c36e8361f26ac2ae7df230643096eadb8093d8.zip
Version bumped
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'app-emulation/aranym')
-rw-r--r--app-emulation/aranym/ChangeLog7
-rw-r--r--app-emulation/aranym/Manifest16
-rw-r--r--app-emulation/aranym/aranym-0.9.0.ebuild56
-rw-r--r--app-emulation/aranym/files/digest-aranym-0.9.02
4 files changed, 68 insertions, 13 deletions
diff --git a/app-emulation/aranym/ChangeLog b/app-emulation/aranym/ChangeLog
index 3932edc0c0ce..5d177b9bbb4d 100644
--- a/app-emulation/aranym/ChangeLog
+++ b/app-emulation/aranym/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/aranym
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/aranym/ChangeLog,v 1.6 2005/03/08 22:21:42 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/aranym/ChangeLog,v 1.7 2005/07/20 11:16:56 dholm Exp $
+
+*aranym-0.9.0 (20 Jul 2005)
+
+ 20 Jul 2005; David Holm <dholm@gentoo.org> +aranym-0.9.0.ebuild:
+ Version bumped
*aranym-0.9.0_beta2 (08 Mar 2005)
diff --git a/app-emulation/aranym/Manifest b/app-emulation/aranym/Manifest
index 727194ad0676..5acd936ed1f0 100644
--- a/app-emulation/aranym/Manifest
+++ b/app-emulation/aranym/Manifest
@@ -1,16 +1,8 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 c5adfd2f910938e12793f487a3790f53 metadata.xml 713
+MD5 11f3d3c00d9285b2b7776f83ecdc2107 ChangeLog 811
MD5 418872645d40a1249a9b457c3ef9352c aranym-0.8.6_beta.ebuild 1530
+MD5 c5adfd2f910938e12793f487a3790f53 metadata.xml 713
MD5 91beb7bc50aa0e857730841503581a48 aranym-0.9.0_beta2.ebuild 1561
-MD5 4b545a12c31f1ddf3fef37ca69ed115e ChangeLog 697
+MD5 11e356e68a215714a6ba720cf2afc98c aranym-0.9.0.ebuild 1538
MD5 31f6327245354bd8a3dd5cb0ef529b5a files/digest-aranym-0.8.6_beta 133
MD5 fb52622d4dbfaece22372902618fbcfd files/digest-aranym-0.9.0_beta2 135
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1 (GNU/Linux)
-
-iD8DBQFCwN+kgIKl8Uu19MoRAobkAJ42juqNqqNqEe0yQ7s06Ouuppv5PACggTOo
-9u8gGU0EMzPH953I3Cm96X4=
-=6TYL
------END PGP SIGNATURE-----
+MD5 07ce892ca12565986423b7399e628a9b files/digest-aranym-0.9.0 129
diff --git a/app-emulation/aranym/aranym-0.9.0.ebuild b/app-emulation/aranym/aranym-0.9.0.ebuild
new file mode 100644
index 000000000000..645ae7b3edce
--- /dev/null
+++ b/app-emulation/aranym/aranym-0.9.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/aranym/aranym-0.9.0.ebuild,v 1.1 2005/07/20 11:16:56 dholm Exp $
+
+inherit flag-o-matic eutils
+
+AFROS="afros-20050424.zip"
+DESCRIPTION="Atari Running on Any Machine, is a virtual machine software for running Atari ST/TT/Falcon operating systems and TOS/GEM applications"
+HOMEPAGE="http://aranym.sourceforge.net/"
+SRC_URI="mirror://sourceforge/aranym/${P}.tar.gz
+ mirror://sourceforge/aranym/${AFROS}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-*" # At the moment it doesn't compile due to our linux-headers
+IUSE="opengl"
+
+RDEPEND="media-libs/libsdl
+ games-emulation/emutos
+ opengl? ( virtual/opengl )"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+}
+
+src_compile() {
+ filter-flags -mpowerpc-gfxopt
+
+ use opengl && myconf="--enable-opengl"
+ if [ "${ARCH}" = "x86" ]; then
+ myconf="${myconf} --enable-jit-compiler"
+ fi
+
+ cd ${S}/src/Unix
+ econf ${myconf} || die "configure failed"
+
+ emake dep || die "failed while building dependencies"
+ emake || die "failed during compilation"
+}
+
+src_install() {
+ cd ${S}/src/Unix
+ emake DESTDIR=${D} install || die "installation failed"
+
+ dosym /usr/games/lib/etos512k.img /usr/share/aranym
+
+ cd ${D}/usr/share/aranym
+ unzip ${DISTDIR}/${AFROS}
+ sed -i -e "s|tmp|usr/share/aranym|g" ${D}/usr/share/aranym/afros/config
+}
+
+pkg_postinst() {
+ einfo "To run ARAnyM with AFROS type: aranym --config /usr/share/aranym/afros/config"
+}
diff --git a/app-emulation/aranym/files/digest-aranym-0.9.0 b/app-emulation/aranym/files/digest-aranym-0.9.0
new file mode 100644
index 000000000000..6c4267b0a538
--- /dev/null
+++ b/app-emulation/aranym/files/digest-aranym-0.9.0
@@ -0,0 +1,2 @@
+MD5 20657ea8187f824ef34663ee7431aaca aranym-0.9.0.tar.gz 1615930
+MD5 949b659a476c508cc58d2fd43c6c54e6 afros-20050424.zip 1776526