summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-11-30 02:52:39 +0000
committerMike Frysinger <vapier@gentoo.org>2002-11-30 02:52:39 +0000
commitd6cf861871432ce21ab151b55bb8cdb8f98be3c7 (patch)
tree6430863c42044a28b185bbb5576cd6e30f387d50 /app-emulation/XWine
parentChanged mkdir ${D} to dodir ${D} (diff)
downloadhistorical-d6cf861871432ce21ab151b55bb8cdb8f98be3c7.tar.gz
historical-d6cf861871432ce21ab151b55bb8cdb8f98be3c7.tar.bz2
historical-d6cf861871432ce21ab151b55bb8cdb8f98be3c7.zip
Changed econf||die to econf
Diffstat (limited to 'app-emulation/XWine')
-rw-r--r--app-emulation/XWine/XWine-0.2.2.ebuild34
1 files changed, 13 insertions, 21 deletions
diff --git a/app-emulation/XWine/XWine-0.2.2.ebuild b/app-emulation/XWine/XWine-0.2.2.ebuild
index 993cd8a620d5..ae489ffdbbb2 100644
--- a/app-emulation/XWine/XWine-0.2.2.ebuild
+++ b/app-emulation/XWine/XWine-0.2.2.ebuild
@@ -1,15 +1,16 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/XWine/XWine-0.2.2.ebuild,v 1.3 2002/10/05 05:39:07 drobbins Exp $
-
-IUSE="nls gnome"
-
-S="${WORKDIR}/${P}_en"
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/XWine/XWine-0.2.2.ebuild,v 1.4 2002/11/30 02:49:47 vapier Exp $
DESCRIPTION="GTK frontend for Wine"
HOMEPAGE="http://darken.tuxfamily.org/pages/xwine_en.html"
SRC_URI="http://darken.tuxfamily.org/projets/${P}_en.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 -ppc -sparc -sparc64"
+IUSE="nls gnome"
+
DEPEND=">=x11-libs/gtk+-1.2.10-r8
>=net-www/mozilla-1.0-r2
>=app-emulation/wine-20020710-r1
@@ -20,12 +21,9 @@ DEPEND=">=x11-libs/gtk+-1.2.10-r8
RDEPEND="${DEPEND}
>=app-emulation/winesetuptk-0.6.0b-r2"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="x86 -ppc -sparc -sparc64"
+S="${WORKDIR}/${P}_en"
src_compile() {
-
local myconf
use gnome && myconf="--with-gnome" \
@@ -34,15 +32,13 @@ src_compile() {
use nls && myconf="${myconf} --enable-nls" \
|| myconf="${myconf} --disable-nls"
- econf ${myconf} || die "configuration failed"
+ econf ${myconf}
make || die
-
}
-src_install () {
-
- einstall || die "install failed"
+src_install() {
+ einstall
# Don't need to install docs twice
rm -rf ${D}/usr/share/doc/xwine
@@ -51,11 +47,7 @@ src_install () {
}
pkg_postinst() {
-
- einfo "!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!"
- einfo "! ${PN} requires a setup Wine to start....It is recommended !"
- einfo "! that you run winesetuptk prior to running ${PN} to setup !"
- einfo "! a base Wine install !"
- einfo "! THXS !"
- einfo "!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!"
+ einfo "${PN} requires a setup Wine to start....It is recommended"
+ einfo "that you run winesetuptk prior to running ${PN} to setup"
+ einfo "a base Wine install"
}