summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2002-11-01 02:52:02 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2002-11-01 02:52:02 +0000
commitce2fa6f6c4951c11ef10627b81603f112c0b62a8 (patch)
tree3f697c6e444c56ff856d2d5e5300c606d2462d12 /app-emacs/uboat
parentmasked app-emacs/monk (incomplete for now) (diff)
downloadhistorical-ce2fa6f6c4951c11ef10627b81603f112c0b62a8.tar.gz
historical-ce2fa6f6c4951c11ef10627b81603f112c0b62a8.tar.bz2
historical-ce2fa6f6c4951c11ef10627b81603f112c0b62a8.zip
looks like an app-emacs/ import to me
Diffstat (limited to 'app-emacs/uboat')
-rw-r--r--app-emacs/uboat/ChangeLog11
-rw-r--r--app-emacs/uboat/files/50uboat-gentoo.el6
-rw-r--r--app-emacs/uboat/files/digest-uboat-1.21
-rw-r--r--app-emacs/uboat/uboat-1.2.ebuild38
4 files changed, 56 insertions, 0 deletions
diff --git a/app-emacs/uboat/ChangeLog b/app-emacs/uboat/ChangeLog
new file mode 100644
index 000000000000..084904480b28
--- /dev/null
+++ b/app-emacs/uboat/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-emacs/uboat
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/uboat/ChangeLog,v 1.1 2002/11/01 02:52:02 mkennedy Exp $
+
+*uboat-1.2 (31 Oct 2002)
+
+ 31 Oct 2002; Matthew Kennedy <mkennedy@gentoo.org> ChangeLog,
+ uboat-1.2.ebuild, files/50uboat-gentoo.el,
+ files/digest-uboat-1.2 :
+
+ Initial import.
diff --git a/app-emacs/uboat/files/50uboat-gentoo.el b/app-emacs/uboat/files/50uboat-gentoo.el
new file mode 100644
index 000000000000..53d8b6614b28
--- /dev/null
+++ b/app-emacs/uboat/files/50uboat-gentoo.el
@@ -0,0 +1,6 @@
+
+;;; uboat site-lisp configuration
+
+(setq load-path (cons "@SITELISP@" load-path))
+(autoload 'uboat-death-message "uboat" nil t)
+
diff --git a/app-emacs/uboat/files/digest-uboat-1.2 b/app-emacs/uboat/files/digest-uboat-1.2
new file mode 100644
index 000000000000..b7ebf8860f0c
--- /dev/null
+++ b/app-emacs/uboat/files/digest-uboat-1.2
@@ -0,0 +1 @@
+MD5 61910cde7baf048605e383117ba05e71 uboat-1.2.tar.bz2 1978
diff --git a/app-emacs/uboat/uboat-1.2.ebuild b/app-emacs/uboat/uboat-1.2.ebuild
new file mode 100644
index 000000000000..4b15cedf41c3
--- /dev/null
+++ b/app-emacs/uboat/uboat-1.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/uboat/uboat-1.2.ebuild,v 1.1 2002/11/01 02:52:02 mkennedy Exp $
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="Generate u-boat-death messages, patterned after Iron Coffins"
+HOMEPAGE="ftp://ftp.splode.com/pub/users/friedman/emacs-lisp/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/emacs"
+
+S="${WORKDIR}/${P}"
+
+SITEFILE=50uboat-gentoo.el
+
+src_compile() {
+ emacs --batch -f batch-byte-compile --no-site-file --no-init-file *.el
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ einfo "Please see ${SITELISP}/${PN}/uboat.el for the complete documentation."
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}