summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2008-03-23 02:21:54 +0000
committerUlrich Müller <ulm@gentoo.org>2008-03-23 02:21:54 +0000
commit5fcc7e32b63f2acfbded35c4dce69a37b46ef616 (patch)
tree4f9d4c0a6018a056ebd2d63e3cbf858d24345298 /app-emacs/emhacks/emhacks-20070920.ebuild
parentAdd local jde USE flag for app-emacs/emhacks. (diff)
downloadhistorical-5fcc7e32b63f2acfbded35c4dce69a37b46ef616.tar.gz
historical-5fcc7e32b63f2acfbded35c4dce69a37b46ef616.tar.bz2
historical-5fcc7e32b63f2acfbded35c4dce69a37b46ef616.zip
Initial import, from Emacs overlay.
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'app-emacs/emhacks/emhacks-20070920.ebuild')
-rw-r--r--app-emacs/emhacks/emhacks-20070920.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-emacs/emhacks/emhacks-20070920.ebuild b/app-emacs/emhacks/emhacks-20070920.ebuild
new file mode 100644
index 000000000000..9f05a93c9620
--- /dev/null
+++ b/app-emacs/emhacks/emhacks-20070920.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/emhacks/emhacks-20070920.ebuild,v 1.1 2008/03/23 02:21:53 ulm Exp $
+
+inherit elisp
+
+DESCRIPTION="Useful Emacs Lisp libraries, including gdiff, jjar, jmaker, swbuff, and tabbar"
+HOMEPAGE="http://emhacks.sourceforge.net/"
+# CVS snapshot
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="jde"
+
+DEPEND="jde? ( app-emacs/jde )"
+RDEPEND="${DEPEND}"
+
+SITEFILE=50${PN}-gentoo.el
+EMACSFLAGS="${EMACSFLAGS} -L ."
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # remove files included in Emacs>=22 or not useful on GNU/Linux
+ rm -r findstr* overlay-fix* recentf* ruler-mode* tree-widget*
+ # this requires jde and cedet, not everyone may want it
+ use jde || rm jsee.el
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc || die "elisp-install failed"
+
+ cp "${FILESDIR}/${SITEFILE}" "${T}"
+ use jde || sed -i -e '/;; jsee/,$d' "${T}/${SITEFILE}"
+ elisp-site-file-install "${T}/${SITEFILE}" \
+ || die "elisp-site-file-install failed"
+
+ dodoc Changelog || die "dodoc failed"
+}