summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2008-11-30 10:43:39 +0000
committerUlrich Müller <ulm@gentoo.org>2008-11-30 10:43:39 +0000
commit6fbf854a6e393e3ca8d3ca49f7cc807a8e4af6f1 (patch)
tree44bf37f8fc4adb3b11693960142adc38be3030d2 /app-emacs/emacs-daemon
parentPackage mask app-emacs/emacs-daemon. (diff)
downloadhistorical-6fbf854a6e393e3ca8d3ca49f7cc807a8e4af6f1.tar.gz
historical-6fbf854a6e393e3ca8d3ca49f7cc807a8e4af6f1.tar.bz2
historical-6fbf854a6e393e3ca8d3ca49f7cc807a8e4af6f1.zip
Initial import.
Package-Manager: portage-2.2_rc16/cvs/Linux 2.6.27-gentoo-r4 i686
Diffstat (limited to 'app-emacs/emacs-daemon')
-rw-r--r--app-emacs/emacs-daemon/ChangeLog10
-rw-r--r--app-emacs/emacs-daemon/Manifest14
-rw-r--r--app-emacs/emacs-daemon/emacs-daemon-0.7.ebuild41
-rw-r--r--app-emacs/emacs-daemon/metadata.xml5
4 files changed, 70 insertions, 0 deletions
diff --git a/app-emacs/emacs-daemon/ChangeLog b/app-emacs/emacs-daemon/ChangeLog
new file mode 100644
index 000000000000..02b5821cf775
--- /dev/null
+++ b/app-emacs/emacs-daemon/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-emacs/emacs-daemon
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/emacs-daemon/ChangeLog,v 1.1 2008/11/30 10:43:39 ulm Exp $
+
+*emacs-daemon-0.7 (30 Nov 2008)
+
+ 30 Nov 2008; Ulrich Mueller <ulm@gentoo.org> +metadata.xml,
+ +emacs-daemon-0.7.ebuild:
+ Initial import. Ebuild contributed by me.
+
diff --git a/app-emacs/emacs-daemon/Manifest b/app-emacs/emacs-daemon/Manifest
new file mode 100644
index 000000000000..6e347640c69f
--- /dev/null
+++ b/app-emacs/emacs-daemon/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+DIST emacs-daemon-0.7.tar.bz2 2336 RMD160 7664890223230d2575473d8d5992143f0d003499 SHA1 9de6d0c040fbec1f7ec1e002ebbe196710454014 SHA256 eb917a4282530cc5176559bf57e358f4f9bfb547898d83fcebd7aee87dd22b35
+EBUILD emacs-daemon-0.7.ebuild 1148 RMD160 2e9dad6e8b21add9bb846c602ca7d9c493952700 SHA1 90ec505f9b8b80be710b79461d52ad472f644a6c SHA256 821fe2402eee088e4e901582efe917c6c73b700cf5eac7dfdbb0e8533b9d3ee0
+MISC ChangeLog 382 RMD160 65cd4f229463d524b3fa12528e6c21bdd1806339 SHA1 82f14035111598cbf5af8b1b730c71980a2f1b41 SHA256 e6f0f25a0c9a4275a1b00b108a42ed1a307325e642ca9a302a13aab6c86a87b9
+MISC metadata.xml 158 RMD160 415d172437ca754d24fc5ab186ba8e77934d96e4 SHA1 61f6eff9729cd87a725c2a70c81aca4270a17fc4 SHA256 1393bdef3a74343fdb40a112c7096a1af16f67e7a43413250de28dfe73810eab
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.9 (GNU/Linux)
+
+iEYEARECAAYFAkkybn8ACgkQOeoy/oIi7uzTSACg5SCO2MMlnfdSsOVdqfdxhJTI
+wcAAoNoYz/ZSGTIIlI5D48weni4ixkv1
+=grjs
+-----END PGP SIGNATURE-----
diff --git a/app-emacs/emacs-daemon/emacs-daemon-0.7.ebuild b/app-emacs/emacs-daemon/emacs-daemon-0.7.ebuild
new file mode 100644
index 000000000000..a7eb87755804
--- /dev/null
+++ b/app-emacs/emacs-daemon/emacs-daemon-0.7.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/emacs-daemon/emacs-daemon-0.7.ebuild,v 1.1 2008/11/30 10:43:39 ulm Exp $
+
+inherit elisp
+
+DESCRIPTION="Gentoo support for Emacs running as a server in the background"
+HOMEPAGE="http://www.gentoo.org/proj/en/lisp/emacs/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=virtual/emacs-23"
+RDEPEND="${DEPEND}
+ >=sys-apps/openrc-0.3.0-r1"
+
+SITEFILE="10${PN}-gentoo.el"
+
+pkg_setup() {
+ local has_daemon=$(${EMACS} ${EMACSFLAGS} \
+ --eval "(princ (fboundp 'daemonp))")
+ if [ "${has_daemon}" != t ]; then
+ ewarn "Your current Emacs version does not support running as a daemon"
+ ewarn "which is required for ${CATEGORY}/${PN}."
+ ewarn "Use \"eselect emacs\" to select an Emacs version >= 23."
+ fi
+}
+
+src_compile() { :; }
+
+src_install() {
+ newinitd emacs.rc emacs || die
+ newconfd emacs.conf emacs || die
+ exeinto /usr/libexec/emacs
+ doexe emacs-wrapper.sh || die
+ elisp-site-file-install "${SITEFILE}" || die
+ keepdir /var/run/emacs || die
+}
diff --git a/app-emacs/emacs-daemon/metadata.xml b/app-emacs/emacs-daemon/metadata.xml
new file mode 100644
index 000000000000..bc306fe58224
--- /dev/null
+++ b/app-emacs/emacs-daemon/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+</pkgmetadata>