summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHerbie Hopkins <herbs@gentoo.org>2005-11-17 19:16:30 +0000
committerHerbie Hopkins <herbs@gentoo.org>2005-11-17 19:16:30 +0000
commitb78788d4c9acdc79a1e86aaf43ce41a6bd75f6b6 (patch)
tree09afc4dd5c28db63022a2c246edea5af2c14c6ca /app-editors
parentFix build with gcc-4.x. Fixes bug #96431. (diff)
downloadhistorical-b78788d4c9acdc79a1e86aaf43ce41a6bd75f6b6.tar.gz
historical-b78788d4c9acdc79a1e86aaf43ce41a6bd75f6b6.tar.bz2
historical-b78788d4c9acdc79a1e86aaf43ce41a6bd75f6b6.zip
Fix multilib-strict issue, bug 104431.
Package-Manager: portage-2.0.53_rc7
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/nvu/ChangeLog5
-rw-r--r--app-editors/nvu/Manifest14
-rw-r--r--app-editors/nvu/nvu-1.0-r1.ebuild16
3 files changed, 26 insertions, 9 deletions
diff --git a/app-editors/nvu/ChangeLog b/app-editors/nvu/ChangeLog
index 7a7ab72e094e..cb0ee04da279 100644
--- a/app-editors/nvu/ChangeLog
+++ b/app-editors/nvu/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-editors/nvu
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nvu/ChangeLog,v 1.12 2005/10/23 01:17:30 anarchy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nvu/ChangeLog,v 1.13 2005/11/17 19:16:30 herbs Exp $
+
+ 17 Nov 2005; Herbie Hopkins <herbs@gentoo.org> nvu-1.0-r1.ebuild:
+ Fix multilib-strict issue, bug 104431.
24 Oct 2005; <anarchy@gentoo.org> -nvu-0.90-r1.ebuild, nvu-0.90-r2.ebuild,
-nvu-1.0.ebuild, nvu-1.0-r1.ebuild:
diff --git a/app-editors/nvu/Manifest b/app-editors/nvu/Manifest
index 9bda43cb1e62..284436d2cba3 100644
--- a/app-editors/nvu/Manifest
+++ b/app-editors/nvu/Manifest
@@ -1,4 +1,7 @@
-MD5 e4a4cd825b8517b3a388f9f661f3e970 ChangeLog 4673
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 eb0f00098a6e1813829e7d89d85c7066 ChangeLog 4781
MD5 565f1133c57a789f0cf51c02510a6f9c files/1.0/mozconfig-1.0 1367
MD5 841f7a0a89c5d8be3841444ce2dd0b85 files/1.0/nvu-0.50-dir.patch 713
MD5 952edf776beb47f9ddeeed1eb3a9407f files/1.0/nvu-0.50-freetype-compile.patch 13641
@@ -10,4 +13,11 @@ MD5 a05fdf2c14ab81e5c9e6827958cc4a2c files/digest-nvu-1.0-r1 70
MD5 91bb5e61f505e2e53aa42345431c8fa7 files/mozconfig2 2160
MD5 2f058933e09a68513c1ca3022b81a441 metadata.xml 433
MD5 c3c4cbc233f87340d78fab34edbc469e nvu-0.90-r2.ebuild 2298
-MD5 c88eb0d711b0b028c95a47b2fe5c8c0c nvu-1.0-r1.ebuild 2871
+MD5 f29d05cbc450c6b22ec68a629f700dcb nvu-1.0-r1.ebuild 2957
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.2 (GNU/Linux)
+
+iD8DBQFDfNcd2G5bA0cA/ScRAkU6AJ49o2l34y4hBUzzIDn0ji23DgnHkgCdFfew
+AkjC1NvX/iLGrnC/NmkD+3A=
+=v3RC
+-----END PGP SIGNATURE-----
diff --git a/app-editors/nvu/nvu-1.0-r1.ebuild b/app-editors/nvu/nvu-1.0-r1.ebuild
index c710c178969e..fd62488380ea 100644
--- a/app-editors/nvu/nvu-1.0-r1.ebuild
+++ b/app-editors/nvu/nvu-1.0-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nvu/nvu-1.0-r1.ebuild,v 1.2 2005/10/23 01:17:30 anarchy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nvu/nvu-1.0-r1.ebuild,v 1.3 2005/11/17 19:16:30 herbs Exp $
-inherit eutils mozconfig flag-o-matic
+inherit eutils mozconfig flag-o-matic multilib
DESCRIPTION="A WYSIWYG web editor for linux similiar to Dreamweaver"
HOMEPAGE="http://www.nvu.com/"
@@ -32,16 +32,20 @@ src_unpack() {
# cp ${FILESDIR}/mozconfig ${S}/.mozconfig
# remove --enable-optimize and let the code below
# add the appropriate one - basic
- grep -v enable-optimize ${FILESDIR}/1.0/mozconfig-1.0 > .mozconfig
+ # Also set mozilla-five-home (and libdir) below - herbs
+ grep -v 'enable-optimize\|mozilla-five-home' \
+ ${FILESDIR}/1.0/mozconfig-1.0 > .mozconfig
+
+ # Set the lib directory
+ echo "ac_add_options --libdir=/usr/$(get_libdir)" >> .mozconfig
+ echo "ac_add_options --with-default-mozilla-five-home=/usr/$(get_libdir)/nvu" \
+ >> .mozconfig
# copied from mozilla.eclass (modified slightly),
# otherwise it defaults to -O which crashes on startup for me - basic
# Set optimization level based on CFLAGS
if is-flag -O0; then
echo 'ac_add_options --enable-optimize=-O0' >> .mozconfig
- elif [[ ${ARCH} == alpha || ${ARCH} == amd64 || ${ARCH} == ia64 ]]; then
- # more than -O1 causes segfaults on 64-bit (bug 33767)
- echo 'ac_add_options --enable-optimize=-O1' >> .mozconfig
elif is-flag -O1; then
echo 'ac_add_options --enable-optimize=-O1' >> .mozconfig
else