summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-06 03:45:14 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-06 03:45:14 +0000
commita79454b8fc48653f8b097cccc43c0082148dfe01 (patch)
treed3630ae7b611b7d4b5d150d5000355298fcfb277 /app-editors/vile
parent(no commit message) (diff)
downloadhistorical-a79454b8fc48653f8b097cccc43c0082148dfe01.tar.gz
historical-a79454b8fc48653f8b097cccc43c0082148dfe01.tar.bz2
historical-a79454b8fc48653f8b097cccc43c0082148dfe01.zip
add inherit eutils
Diffstat (limited to 'app-editors/vile')
-rw-r--r--app-editors/vile/vile-9.4d.ebuild34
1 files changed, 16 insertions, 18 deletions
diff --git a/app-editors/vile/vile-9.4d.ebuild b/app-editors/vile/vile-9.4d.ebuild
index 7f9781bf7ac5..5ff6ded67478 100644
--- a/app-editors/vile/vile-9.4d.ebuild
+++ b/app-editors/vile/vile-9.4d.ebuild
@@ -1,50 +1,48 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/vile/vile-9.4d.ebuild,v 1.3 2004/03/03 17:40:50 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vile/vile-9.4d.ebuild,v 1.4 2004/04/06 03:43:03 vapier Exp $
-IUSE="perl"
+inherit eutils
S=${WORKDIR}/vile-9.4
DESCRIPTION="VI Like Emacs -- yet another full-featured vi clone"
+HOMEPAGE="http://www.clark.net/pub/dickey/vile/vile.html"
SRC_URI="ftp://ftp.phred.org/pub/vile/vile-9.4.tgz
ftp://ftp.phred.org/pub/vile/patches/vile-9.4a.patch.gz
ftp://ftp.phred.org/pub/vile/patches/vile-9.4b.patch.gz
ftp://ftp.phred.org/pub/vile/patches/vile-9.4c.patch.gz
ftp://ftp.phred.org/pub/vile/patches/vile-9.4d.patch.gz"
-HOMEPAGE="http://www.clark.net/pub/dickey/vile/vile.html"
-
-DEPEND="${RDEPEND}
- sys-devel/flex"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ~ppc sparc alpha ia64"
+IUSE="perl"
RDEPEND=">=sys-libs/ncurses-5.2
perl? ( dev-lang/perl )"
-
+DEPEND="${RDEPEND}
+ sys-devel/flex"
PROVIDE="virtual/editor"
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="x86 ~ppc sparc alpha ia64"
-
src_unpack() {
- local p
-
unpack vile-9.4.tgz
cd ${S}
+ local p
for p in ${DISTDIR}/${P%[a-z]}[a-${P##*[0-9]}].patch.gz; do
epatch ${p} || die "epatch failed"
done
}
src_compile() {
- econf --with-ncurses \
- `use_with perl` || die "configure failed"
+ econf \
+ --with-ncurses \
+ `use_with perl` \
+ || die "configure failed"
emake || die "emake failed"
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die "install failed"
- dodoc CHANGES* COPYING MANIFEST INSTALL README* doc/*
+ dodoc CHANGES* INSTALL README* doc/*
}
-