summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2005-03-28 22:41:06 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2005-03-28 22:41:06 +0000
commit4fd9efd7d85e9118964724a4b48f4f80b0eb2968 (patch)
tree3ab66d15f03cb528b4a70305597ca8b72b230f2e /app-editors/ted
parentInitial import, ebuild based on the contributions by Vibhav Garg and Saleem A... (diff)
downloadhistorical-4fd9efd7d85e9118964724a4b48f4f80b0eb2968.tar.gz
historical-4fd9efd7d85e9118964724a4b48f4f80b0eb2968.tar.bz2
historical-4fd9efd7d85e9118964724a4b48f4f80b0eb2968.zip
Small bump for a buildfix with userpriv. Need this to compare functionality with the newer version
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'app-editors/ted')
-rw-r--r--app-editors/ted/ChangeLog10
-rw-r--r--app-editors/ted/Manifest4
-rw-r--r--app-editors/ted/files/digest-ted-2.12-r11
-rw-r--r--app-editors/ted/ted-2.12-r1.ebuild66
4 files changed, 79 insertions, 2 deletions
diff --git a/app-editors/ted/ChangeLog b/app-editors/ted/ChangeLog
index c5f75b90250a..8910af4aa10c 100644
--- a/app-editors/ted/ChangeLog
+++ b/app-editors/ted/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-editors/ted
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/ted/ChangeLog,v 1.18 2005/01/01 13:34:41 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/ted/ChangeLog,v 1.19 2005/03/28 22:41:06 spider Exp $
+
+*ted-2.12-r1 (28 Mar 2005)
+
+ 28 Mar 2005; Spider <spider@gentoo.org> +ted-2.12-r1.ebuild:
+ Added a small build-fix to get around userpriv. The buildscript has a test
+ for RPM_BUILD_ROOT, so I'm just using that.
+ The package appears to have issues with missing fonts, not too sure if I have
+ 100% functionality here.
07 Jun 2004; Daniel Black <dragonheart@gentoo.org> metadata.xml,
ted-2.11.ebuild, ted-2.12.ebuild:
diff --git a/app-editors/ted/Manifest b/app-editors/ted/Manifest
index 5d954446cdaa..0616ed786d6f 100644
--- a/app-editors/ted/Manifest
+++ b/app-editors/ted/Manifest
@@ -1,6 +1,8 @@
-MD5 e4f7314a7bcfc623e2bce8658ca9ed28 ChangeLog 1756
+MD5 02efb1f38af771a7bed9acdd3a0b39ec ChangeLog 2075
MD5 1652522405f5936eb29776ef8d5ffa5b metadata.xml 310
MD5 759c203489234752d44e9bdb890517c8 ted-2.11.ebuild 1724
+MD5 ff83c5ff7851497ea71e58748e6f8545 ted-2.12-r1.ebuild 1870
MD5 3f9f2018ec9753bb15ef8059446a7e4a ted-2.12.ebuild 1715
MD5 34f40502bd7df66aadeaf82cb57b35ee files/digest-ted-2.11 65
+MD5 e64c90ec5da6d8dc9931b280c540204b files/digest-ted-2.12-r1 65
MD5 e64c90ec5da6d8dc9931b280c540204b files/digest-ted-2.12 65
diff --git a/app-editors/ted/files/digest-ted-2.12-r1 b/app-editors/ted/files/digest-ted-2.12-r1
new file mode 100644
index 000000000000..56e0df89a9b0
--- /dev/null
+++ b/app-editors/ted/files/digest-ted-2.12-r1
@@ -0,0 +1 @@
+MD5 4587e3218dd8aa1b1bae8a97b3b9eef6 ted-2.12.src.tar.gz 2560159
diff --git a/app-editors/ted/ted-2.12-r1.ebuild b/app-editors/ted/ted-2.12-r1.ebuild
new file mode 100644
index 000000000000..f62cfc2a87ef
--- /dev/null
+++ b/app-editors/ted/ted-2.12-r1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/ted/ted-2.12-r1.ebuild,v 1.1 2005/03/28 22:41:06 spider Exp $
+
+DESCRIPTION="X-based rich text editor."
+HOMEPAGE="http://www.nllgg.nl/Ted"
+SRC_URI="ftp://ftp.nluug.nl/pub/editors/ted/${P}.src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+KEYWORDS="~x86 ~ppc ~sparc"
+
+DEPEND="x11-libs/openmotif
+ >=media-libs/tiff-3.5.7
+ >=media-libs/jpeg-6b
+ >=media-libs/libpng-1.2.3"
+
+S="${WORKDIR}/Ted-${PV}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/Ted
+ mv makefile.in makefile.in.orig
+ sed 's@^CFLAGS=@CFLAGS= -DDOCUMENT_DIR=\\"/usr/share/doc/${PF}/Ted/\\"@' makefile.in.orig > makefile.in
+}
+
+src_compile() {
+ # This is a fix for userpriv &| usersandbox.
+ export RPM_BUILD_ROOT="${S}"
+ for dir in Ted tedPackage appFrame appUtil ind bitmap libreg; do
+ cd ${S}/${dir}
+ econf --cache-file=../config.cache || die "econf failed"
+ done
+
+ # The makefile doesn't really allow parallel make, but it does
+ # no harm either.
+ cd ${S}
+ emake DEF_AFMDIR=-DAFMDIR=\\\"/usr/share/Ted/afm\\\" \
+ DEF_INDDIR=-DINDDIR=\\\"/usr/share/Ted/ind\\\" \
+ package.shared || die "couldnt emake"
+}
+
+src_install() {
+ # This is a fix for userpriv &| usersandbox.
+ export RPM_BUILD_ROOT="${S}"
+ cd ${BUILDDIR}
+
+ mkdir ${T}/pkg
+ cd ${T}/pkg || die "Couldn't cd to package"
+ tar --use=gzip -xvf ${S}/tedPackage/Ted*.tar.gz || die "couldnt unpack tedPackage/Ted*.tar.gz"
+
+ cd ${BUILDDIR}
+
+ dodir /usr/share/Ted
+ cp -R ${T}/pkg/afm ${D}/usr/share/Ted/afm || die "couldnt cp temp/pkg/afm"
+ cp -R ${T}/pkg/ind ${D}/usr/share/Ted/ind || die "couldnt cp temp/pkg/ind"
+
+ exeinto /usr/bin
+ doexe ${T}/pkg/bin/* || die "couldnt doexe temp/pkg/bin/*"
+
+ dodir /usr/share/doc/${P}
+ cp -R ${T}/pkg/Ted ${D}/usr/share/doc/${P} || die "couldnt cp temp/pkg/Ted"
+
+ rm -rf ${T}
+}