summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2009-06-09 23:29:28 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2009-06-09 23:29:28 +0000
commit17b68f984e80cbbe5ee96c03543232ca3cd94e8f (patch)
tree0e35c6bad81a1e40c59e3193400ac4c4f92c4bcf /app-editors/qxmledit
parentInitial commit of minitube application (diff)
downloadhistorical-17b68f984e80cbbe5ee96c03543232ca3cd94e8f.tar.gz
historical-17b68f984e80cbbe5ee96c03543232ca3cd94e8f.tar.bz2
historical-17b68f984e80cbbe5ee96c03543232ca3cd94e8f.zip
Initial commit of qxmledit application
Package-Manager: portage-2.2_rc33/cvs/Linux x86_64
Diffstat (limited to 'app-editors/qxmledit')
-rw-r--r--app-editors/qxmledit/ChangeLog10
-rw-r--r--app-editors/qxmledit/Manifest4
-rw-r--r--app-editors/qxmledit/metadata.xml12
-rw-r--r--app-editors/qxmledit/qxmledit-0.3.0.ebuild44
4 files changed, 70 insertions, 0 deletions
diff --git a/app-editors/qxmledit/ChangeLog b/app-editors/qxmledit/ChangeLog
new file mode 100644
index 000000000000..d0b60473f7cf
--- /dev/null
+++ b/app-editors/qxmledit/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-editors/qxmledit
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/qxmledit/ChangeLog,v 1.1 2009/06/09 23:29:28 hwoarang Exp $
+
+*qxmledit-0.3.0 (09 Jun 2009)
+
+ 09 Jun 2009; Markos Chandras <hwoarang@gentoo.org> +qxmledit-0.3.0.ebuild,
+ +metadata.xml:
+ Initial commit of qxmledit application
+
diff --git a/app-editors/qxmledit/Manifest b/app-editors/qxmledit/Manifest
new file mode 100644
index 000000000000..1b7d831b09e5
--- /dev/null
+++ b/app-editors/qxmledit/Manifest
@@ -0,0 +1,4 @@
+DIST qxmledit-src-0.3.0.tgz 51763 RMD160 4147ab797a749940d40d08390adf5306f643aa93 SHA1 746a7efde407935da7a0dce26f9dde17c4a9b31d SHA256 1fb0933e4bc92edbd92ac9710b5cbe575edf46d79eb188bb6e17e43e6006d756
+EBUILD qxmledit-0.3.0.ebuild 1041 RMD160 3119ef57a18a517957b41d64edba28bc267d7764 SHA1 b21c41ce9c0b5c4e10f9b942c57933087d136678 SHA256 c47345685cb76d243398617c9c4d8a92ac7d2d00d70d8fae997c271e1528b0e2
+MISC ChangeLog 382 RMD160 3cacdcf647f65ccfe4e029a72682edd1a5991464 SHA1 a917b0d76ae65b39277ed0fc2ac2579486a97473 SHA256 a9a03114a9b880fc8e01021ead5a025a7bd288cab1a385e8ddfb6fe4a1a5e3cc
+MISC metadata.xml 294 RMD160 ac4e1baa0a1839ae0a807a9d4b915134788d6aa1 SHA1 82865de14486cb30dc9ebfe6f1aecc9c86c0075b SHA256 209af586ae032f00659b69da17d4186854660be14b244d31aa0bea2005c2c5ba
diff --git a/app-editors/qxmledit/metadata.xml b/app-editors/qxmledit/metadata.xml
new file mode 100644
index 000000000000..d5f9562e2df2
--- /dev/null
+++ b/app-editors/qxmledit/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>qt</herd>
+<maintainer>
+<email>hwoarang@gentoo.org</email>
+<name>Markos Chandras</name>
+</maintainer>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
+
diff --git a/app-editors/qxmledit/qxmledit-0.3.0.ebuild b/app-editors/qxmledit/qxmledit-0.3.0.ebuild
new file mode 100644
index 000000000000..ac941409831c
--- /dev/null
+++ b/app-editors/qxmledit/qxmledit-0.3.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/qxmledit/qxmledit-0.3.0.ebuild,v 1.1 2009/06/09 23:29:28 hwoarang Exp $
+
+EAPI="2"
+
+inherit qt4
+
+MY_PN="${PN}-src"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Qt4 XML Editor"
+HOMEPAGE="http://code.google.com/p/qxmledit/"
+SRC_URI="http://${PN}.googlecode.com/files/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="x11-libs/qt-gui:4"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${P}/src/"
+
+src_prepare(){
+ # fix installation path
+ sed -i "/^target.path/ s/\/opt\/${PN}/\/usr\/bin/" QXmlEdit.pro || \
+ die "failed to fix installation path"
+ # fix translations
+ sed -i "/^translations.path/ s/\/opt/\/usr\/share/" QXmlEdit.pro || \
+ die "failed to fix translations"
+ qt4_src_prepare
+}
+
+src_configure(){
+ eqmake4 QXmlEdit.pro
+}
+
+src_install(){
+ emake INSTALL_ROOT="${D}" install || die "emake install failed"
+ cd ../
+ dodoc AUTHORS NEWS README TODO || die "dodoc failed"
+}