summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2002-04-22 01:52:55 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2002-04-22 01:52:55 +0000
commit32cc7fffe8f3be6f3ac69f3d04e0a1e4918c7926 (patch)
tree1219ae64c86cb594d1a70f14b968c361c529214d /app-editors/mp/mp-3.1.9.ebuild
parentAdding Sparc support (diff)
downloadhistorical-32cc7fffe8f3be6f3ac69f3d04e0a1e4918c7926.tar.gz
historical-32cc7fffe8f3be6f3ac69f3d04e0a1e4918c7926.tar.bz2
historical-32cc7fffe8f3be6f3ac69f3d04e0a1e4918c7926.zip
New ebuild. Rsolves bug #1885.
Diffstat (limited to 'app-editors/mp/mp-3.1.9.ebuild')
-rw-r--r--app-editors/mp/mp-3.1.9.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-editors/mp/mp-3.1.9.ebuild b/app-editors/mp/mp-3.1.9.ebuild
new file mode 100644
index 000000000000..f1928e29a533
--- /dev/null
+++ b/app-editors/mp/mp-3.1.9.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Matthew Kennedy <mkennedy@gentoo.org>
+# Maintainer: Matthew Kennedy <mkennedy@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-editors/mp/mp-3.1.9.ebuild,v 1.1 2002/04/22 01:52:55 mkennedy Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="mp, the definitive text editor"
+SRC_URI="http://triptico.dhis.org/download/${P}.tar.gz"
+HOMEPAGE="http://www.triptico.com/software/mp.html"
+
+DEPEND="virtual/glibc
+ sys-libs/ncurses"
+
+RDEPEND="${DEPEND}
+ sys-devel/perl"
+
+src_compile() {
+ emake || die
+}
+
+src_install () {
+ dodir /usr/bin
+ make install PREFIX=${D}/usr || die
+ dodoc AUTHORS ChangeLog COPYING README
+ dohtml README.html doc/mp_api.html
+}