summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2001-09-18 09:40:22 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2001-09-18 09:40:22 +0000
commit2db06c7a7982191c58f0a743cba8b6b233693439 (patch)
tree7f4cb5b2cfad895281ddf7119c6b683fd9d3d373 /app-editors/fte
parenttrimmed the extra stuff that isnt really needed in the new rc6 inits. ex. the... (diff)
downloadhistorical-2db06c7a7982191c58f0a743cba8b6b233693439.tar.gz
historical-2db06c7a7982191c58f0a743cba8b6b233693439.tar.bz2
historical-2db06c7a7982191c58f0a743cba8b6b233693439.zip
Initial import, needs second-level testing
Diffstat (limited to 'app-editors/fte')
-rw-r--r--app-editors/fte/files/digest-fte-200108192
-rw-r--r--app-editors/fte/fte-20010819.ebuild84
2 files changed, 86 insertions, 0 deletions
diff --git a/app-editors/fte/files/digest-fte-20010819 b/app-editors/fte/files/digest-fte-20010819
new file mode 100644
index 000000000000..a00b0273cb6d
--- /dev/null
+++ b/app-editors/fte/files/digest-fte-20010819
@@ -0,0 +1,2 @@
+MD5 a3af219f8a6b59ce308b04d0846ea72d fte-20010819-common.zip
+MD5 2dec08301d39c9d914c7bcdcb0323ed1 fte-20010819-src.zip
diff --git a/app-editors/fte/fte-20010819.ebuild b/app-editors/fte/fte-20010819.ebuild
new file mode 100644
index 000000000000..401c971f7390
--- /dev/null
+++ b/app-editors/fte/fte-20010819.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Karl Trygve Kalleberg <karltk@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-editors/fte/fte-20010819.ebuild,v 1.1 2001/09/18 09:40:22 karltk Exp $
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="Lightweight text-mode editor"
+
+SRC_URI="http://prdownloads.sourceforge.net/fte/fte-20010819-src.zip
+ http://prdownloads.sourceforge.net/fte/fte-20010819-common.zip"
+
+HOMEPAGE="http://fte.sourceforge.net"
+
+DEPEND="virtual/glibc"
+
+TARGETS=""
+
+if [ "`use slang`" ] ; then
+ TARGETS="$TARGETS sfte"
+fi
+
+if [ "`use X`" ] ; then
+ TARGETS="$TARGETS xfte"
+fi
+
+if [ "`use gpm`" ] ; then
+ TARGETS="$TARGETS vfte"
+fi
+
+src_unpack() {
+
+ cd ${WORKDIR}
+ unpack fte-20010819-src.zip
+ unpack fte-20010819-common.zip
+
+ mv fte fte-20010819
+
+ cd ${S}; patch -p0 < ${FILESDIR}/${PF}-gentoo.diff
+
+ cp src/fte-unix.mak src/fte-unix.mak.orig
+
+ cat src/fte-unix.mak.orig | \
+ sed "s/@targets@/${TARGETS}/" | \
+ sed "s/@cflags@/${CFLAGS}/" \
+ > src/fte-unix.mak
+}
+
+src_compile() {
+ emake all || die
+
+ cd config
+ ../src/cfte main.fte ../src/system.fterc
+}
+
+src_install () {
+ local files
+ into /usr
+
+ files="${TARGETS} cfte compkeys"
+
+ for i in ${files} ; do
+ dobin src/$i ;
+ done
+
+ dodoc Artistic CHANGES BUGS COPYING HISTORY README TODO
+
+ dodir etc/fte
+ cp src/system.fterc ${D}/etc/fte/system.fterc
+
+ dodir usr/share/doc/${P}/html
+ cp doc/INDEX doc/*.html ${D}/usr/share/doc/${P}/html
+
+ if [ -a ${D}/usr/bin/xfte ] ; then
+ into /usr/X11R6 ;
+ dobin src/xfte ;
+ rm ${D}/usr/bin/xfte ;
+ fi
+
+ dodir usr/share/fte
+ cp -R config/* ${D}/usr/share/fte
+ rm -rf ${D}/usr/share/fte/CVS
+}
+