summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Maitin-Shepard <jbms@gentoo.org>2004-01-04 14:50:00 +0000
committerJeremy Maitin-Shepard <jbms@gentoo.org>2004-01-04 14:50:00 +0000
commitda133b7a5630ae97615b37a580f003e5cc650e6b (patch)
tree20bb9ef67dd6f797b786ef998b5882a997481b38 /app-editors/emacs-cvs
parentChanged ebuild to do CVS SSH host key checking, made minor changes to USE-fla... (diff)
downloadhistorical-da133b7a5630ae97615b37a580f003e5cc650e6b.tar.gz
historical-da133b7a5630ae97615b37a580f003e5cc650e6b.tar.bz2
historical-da133b7a5630ae97615b37a580f003e5cc650e6b.zip
Changed ebuild to do CVS SSH host key checking, made minor changes to USE-flag-handling code.
Diffstat (limited to 'app-editors/emacs-cvs')
-rw-r--r--app-editors/emacs-cvs/Manifest4
-rw-r--r--app-editors/emacs-cvs/emacs-cvs-21.3.50.ebuild69
2 files changed, 30 insertions, 43 deletions
diff --git a/app-editors/emacs-cvs/Manifest b/app-editors/emacs-cvs/Manifest
index cfada9c31eb8..87a2f6be1d6f 100644
--- a/app-editors/emacs-cvs/Manifest
+++ b/app-editors/emacs-cvs/Manifest
@@ -1,5 +1,5 @@
-MD5 bf47dbd0efe506d0df5c6933dde67f01 emacs-cvs-21.3.50.ebuild 3054
-MD5 63793751ed4ecd3f48a47888089433ae ChangeLog 2378
+MD5 15a80c5f839cd933037cbc8a6c077c0f emacs-cvs-21.3.50.ebuild 3052
+MD5 bdb61ed41c67681952b6d4d5b63be002 ChangeLog 2581
MD5 fcd33d07e4ee719b01157946734f4fe8 metadata.xml 158
MD5 0e5a4a35651f5365c6191636a2c26eb7 files/emacs.desktop 190
MD5 04a64867694a98538309b433c80aaa62 files/40aspell-gentoo.el 80
diff --git a/app-editors/emacs-cvs/emacs-cvs-21.3.50.ebuild b/app-editors/emacs-cvs/emacs-cvs-21.3.50.ebuild
index a229d7d049f3..79927f8e0be0 100644
--- a/app-editors/emacs-cvs/emacs-cvs-21.3.50.ebuild
+++ b/app-editors/emacs-cvs/emacs-cvs-21.3.50.ebuild
@@ -1,12 +1,15 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/emacs-cvs-21.3.50.ebuild,v 1.18 2003/12/31 16:57:55 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/emacs-cvs-21.3.50.ebuild,v 1.19 2004/01/04 14:49:52 jbms Exp $
ECVS_AUTH="ext"
+export CVS_RSH="ssh"
ECVS_SERVER="savannah.gnu.org:/cvsroot/emacs"
ECVS_MODULE="emacs"
ECVS_USER="anoncvs"
+ECVS_PASS=""
ECVS_CVS_OPTIONS="-dP"
+ECVS_SSH_HOST_KEY="savannah.gnu.org,199.232.41.3 ssh-rsa AAAAB3NzaC1yc2EAAAABIwAAAIEAzFQovi+67xa+wymRz9u3plx0ntQnELBoNU4SCl3RkwSFZkrZsRTC0fTpOKatQNs1r/BLFoVt21oVFwIXVevGQwB+Lf0Z+5w9qwVAQNu/YUAFHBPTqBze4wYK/gSWqQOLoj7rOhZk0xtAS6USqcfKdzMdRWgeuZ550P6gSzEHfv0="
inherit elisp-common cvs
@@ -23,19 +26,15 @@ RESTRICT="$RESTRICT nostrip"
DEPEND=">=sys-libs/ncurses-5.3
sys-libs/gdbm
- dev-util/cvs
dev-python/pexpect
- spell? ( || ( app-text/ispell
- app-text/aspell ) )
+ spell? ( || ( app-text/ispell app-text/aspell ) )
X? ( virtual/x11
- >=media-libs/libungif-4.1.0.1b
- >=media-libs/jpeg-6b
- >=media-libs/tiff-3.5.7
- >=media-libs/libpng-1.2.5 )
- gtk? ( =x11-libs/gtk+-2* )
- gtk2? ( =x11-libs/gtk+-2* )
- Xaw3d? ( x11-libs/Xaw3d )
- gnome? ( gnome-base/gnome-desktop )
+ gif? ( >=media-libs/libungif-4.1.0.1b )
+ jpeg? ( >=media-libs/jpeg-6b )
+ tiff? ( >=media-libs/tiff-3.5.7 )
+ png? ( >=media-libs/libpng-1.2.5 )
+ gtk? ( =x11-libs/gtk+-2* ) : ( Xaw3d? ( x11-libs/Xaw3d ) )
+ gnome? ( gnome-base/gnome-desktop ) )
nls? ( >=sys-devel/gettext-0.11.5 )"
PROVIDE="virtual/emacs virtual/editor"
@@ -51,27 +50,26 @@ src_compile() {
use nls || myconf="${myconf} --disable-nls"
- if use X ;
- then
- myconf="${myconf}
- --with-x
- --with-xpm
- --with-jpeg
- --with-tiff
- --with-gif
- --with-png"
- if use gtk || use gtk2
- then
+ myconf="${myconf} $(use_with X x)"
+
+ if use X; then
+ myconf="${myconf} --with-xpm"
+ myconf="${myconf} $(use_with jpeg) $(use_with tiff)"
+ myconf="${myconf} $(use_with gif) $(use_with png)"
+ if use gtk; then
+ einfo "Configuring to build with GTK support"
myconf="${myconf} --with-x-toolkit=gtk
- --with-gtk
--with-toolkit-scroll-bars"
- elif use Xaw3d
- then
+ elif use Xaw3d; then
+ einfo "Configuring to build with Xaw3d support"
myconf="${myconf} --with-x-toolkit=athena
--with-toolkit-scroll-bars"
+ else
+ einfo "Configuring to build without X toolkit support"
+ myconf="${myconf} --without-gtk"
+ myconf="${myconf} --with-x-toolkit=no"
+ myconf="${myconf} --without-toolkit-scroll-bars"
fi
- else
- myconf="${myconf} --without-x"
fi
unset CFLAGS CPPFLAGS
@@ -104,19 +102,8 @@ src_install () {
dodoc BUGS ChangeLog README
- if use gnome
- then
+ if use gnome; then
insinto /usr/share/gnome/apps/Application
doins ${FILESDIR}/${DFILE}
fi
}
-
-pkg_postinst() {
-
- elisp-site-regen
-}
-
-pkg_postrm() {
-
- elisp-site-regen
-}