summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Boeck <hanno@gentoo.org>2005-12-20 22:34:51 +0000
committerHanno Boeck <hanno@gentoo.org>2005-12-20 22:34:51 +0000
commitc653612edc8265d05e0887b8fea86614bcbf6514 (patch)
tree68cdfe4b2254d3b61a943fff83977109f634924f /app-editors/bluefish
parentFix potential buffer overflow in dynamic blacklist support and closing bug #1... (diff)
downloadhistorical-c653612edc8265d05e0887b8fea86614bcbf6514.tar.gz
historical-c653612edc8265d05e0887b8fea86614bcbf6514.tar.bz2
historical-c653612edc8265d05e0887b8fea86614bcbf6514.zip
add gnome useflag to bluefish
Package-Manager: portage-2.1_pre1
Diffstat (limited to 'app-editors/bluefish')
-rw-r--r--app-editors/bluefish/ChangeLog7
-rw-r--r--app-editors/bluefish/Manifest14
-rw-r--r--app-editors/bluefish/bluefish-1.0.4-r1.ebuild39
-rw-r--r--app-editors/bluefish/files/digest-bluefish-1.0.4-r11
4 files changed, 54 insertions, 7 deletions
diff --git a/app-editors/bluefish/ChangeLog b/app-editors/bluefish/ChangeLog
index 6317af24cbc7..75326f89287c 100644
--- a/app-editors/bluefish/ChangeLog
+++ b/app-editors/bluefish/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/bluefish
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/bluefish/ChangeLog,v 1.51 2005/09/22 18:21:06 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/bluefish/ChangeLog,v 1.52 2005/12/20 22:34:51 hanno Exp $
+
+*bluefish-1.0.4-r1 (20 Dec 2005)
+
+ 20 Dec 2005; Hanno Boeck <hanno@gentoo.org> +bluefish-1.0.4-r1.ebuild:
+ Add gnome USE-flag.
*bluefish-1.0.4 (22 Sep 2005)
diff --git a/app-editors/bluefish/Manifest b/app-editors/bluefish/Manifest
index 79ab1b6cb8b8..31d380a26d69 100644
--- a/app-editors/bluefish/Manifest
+++ b/app-editors/bluefish/Manifest
@@ -1,18 +1,20 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 248ee88f13a0b15906b81c0e5258857e ChangeLog 6201
-MD5 1b7fcc5c167d3fd3b689b7784866d6a0 bluefish-1.0.ebuild 888
-MD5 a72a06a37ca4e5905085ebff07fe9e9e metadata.xml 217
+MD5 285e94990d44c5edfe923e25ad0bbbcb ChangeLog 6331
MD5 387355913ede91692759147273543555 bluefish-1.0.2.ebuild 897
+MD5 10ceb3c1ebbf34eadf7dee32362c01ef bluefish-1.0.4-r1.ebuild 966
MD5 3b33bd2a0b115ccaff09247d69d72991 bluefish-1.0.4.ebuild 897
+MD5 1b7fcc5c167d3fd3b689b7784866d6a0 bluefish-1.0.ebuild 888
MD5 4f4082139d50854cf37bf254207ad1b1 files/digest-bluefish-1.0 66
MD5 52bca1b5248301ce7359f135e824a98f files/digest-bluefish-1.0.2 68
MD5 c150fdac29f2c1bcf452e3102c045dd5 files/digest-bluefish-1.0.4 68
+MD5 c150fdac29f2c1bcf452e3102c045dd5 files/digest-bluefish-1.0.4-r1 68
+MD5 a72a06a37ca4e5905085ebff07fe9e9e metadata.xml 217
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
-iD8DBQFDMvaQr2QksT29OyARAszHAJ0WQYRL9/1y0bi0PHXfApOWxs46qACfTo6V
-Q35H+CeXCP3DFztPgkY+994=
-=Lci2
+iD8DBQFDqIeJr2QksT29OyARAsxDAJ9F9kkE5mZFcRG8JHNATXJJAGay0ACfRdZ9
+y5+CBmwE8sP7fWR1cO2ZTxk=
+=4cMm
-----END PGP SIGNATURE-----
diff --git a/app-editors/bluefish/bluefish-1.0.4-r1.ebuild b/app-editors/bluefish/bluefish-1.0.4-r1.ebuild
new file mode 100644
index 000000000000..4c643b6fe436
--- /dev/null
+++ b/app-editors/bluefish/bluefish-1.0.4-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/bluefish/bluefish-1.0.4-r1.ebuild,v 1.1 2005/12/20 22:34:51 hanno Exp $
+
+inherit eutils fdo-mime
+
+IUSE="nls spell gnome"
+
+DESCRIPTION="A GTK HTML editor for the experienced web designer or programmer."
+SRC_URI="http://pkedu.fbt.eitn.wau.nl/~olivier/downloads/${P}.tar.bz2"
+HOMEPAGE="http://bluefish.openoffice.nl/"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+
+RDEPEND=">=x11-libs/gtk+-2
+ dev-libs/libpcre
+ spell? ( app-text/aspell )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )
+ gnome? ( gnome-base/libgnomeui )"
+
+src_compile() {
+ econf --disable-update-databases \
+ `use_enable nls` \
+ `use_with gnome libgnomeui` || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+}
+
+pkg_postinst() {
+ update-mime-database /usr/share/mime
+}
diff --git a/app-editors/bluefish/files/digest-bluefish-1.0.4-r1 b/app-editors/bluefish/files/digest-bluefish-1.0.4-r1
new file mode 100644
index 000000000000..15e4b6fdd5ea
--- /dev/null
+++ b/app-editors/bluefish/files/digest-bluefish-1.0.4-r1
@@ -0,0 +1 @@
+MD5 8d5c1b7315cdc935aa024954093d2b32 bluefish-1.0.4.tar.bz2 1469951