summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2007-08-09 09:43:12 +0000
committerAkinori Hattori <hattya@gentoo.org>2007-08-09 09:43:12 +0000
commite10da27ce0dffbc25b555cc1f3c3cb9e54fd3134 (patch)
tree77bd9b2e1093e1a20cca9332a96e1da4ccd22e8c /app-dicts/mecab-ipadic/mecab-ipadic-2.7.0.20070801.ebuild
parentVersion bump, also fixing bug 188176. (diff)
downloadhistorical-e10da27ce0dffbc25b555cc1f3c3cb9e54fd3134.tar.gz
historical-e10da27ce0dffbc25b555cc1f3c3cb9e54fd3134.tar.bz2
historical-e10da27ce0dffbc25b555cc1f3c3cb9e54fd3134.zip
new upstream release.
Package-Manager: portage-2.1.2.11
Diffstat (limited to 'app-dicts/mecab-ipadic/mecab-ipadic-2.7.0.20070801.ebuild')
-rw-r--r--app-dicts/mecab-ipadic/mecab-ipadic-2.7.0.20070801.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-dicts/mecab-ipadic/mecab-ipadic-2.7.0.20070801.ebuild b/app-dicts/mecab-ipadic/mecab-ipadic-2.7.0.20070801.ebuild
new file mode 100644
index 000000000000..5aa6ee72bebb
--- /dev/null
+++ b/app-dicts/mecab-ipadic/mecab-ipadic-2.7.0.20070801.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/mecab-ipadic/mecab-ipadic-2.7.0.20070801.ebuild,v 1.1 2007/08/09 09:43:12 hattya Exp $
+
+IUSE="unicode"
+
+MY_P="${PN}-${PV%.*}-${PV/*.}"
+
+DESCRIPTION="IPA dictionary for MeCab"
+HOMEPAGE="http://mecab.sourceforge.net/"
+SRC_URI="mirror://sourceforge/mecab/${MY_P}.tar.gz"
+
+LICENSE="ipadic"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+S="${WORKDIR}/${MY_P}"
+
+DEPEND=">=app-text/mecab-0.90"
+
+src_compile() {
+
+ local myconf
+
+ use unicode && myconf="${myconf} --with-charset=utf8"
+
+ econf ${myconf} || die
+ emake || die
+
+}
+
+src_install() {
+
+ emake DESTDIR="${D}" install || die
+
+}