summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2008-02-13 18:14:50 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2008-02-13 18:14:50 +0000
commit45e9f219ae3cfd6803d968f4f1ddbddea31e3d72 (patch)
tree554c6d4c5111d58d1d7197c9e90a0311e079625e /app-crypt/truecrypt/files
parentAdded missing include to 8.0.8, version bump. (diff)
downloadhistorical-45e9f219ae3cfd6803d968f4f1ddbddea31e3d72.tar.gz
historical-45e9f219ae3cfd6803d968f4f1ddbddea31e3d72.tar.bz2
historical-45e9f219ae3cfd6803d968f4f1ddbddea31e3d72.zip
Version bump bug#210024, more 64bit fixups
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'app-crypt/truecrypt/files')
-rw-r--r--app-crypt/truecrypt/files/truecrypt-5.0-64bit.patch15
-rw-r--r--app-crypt/truecrypt/files/truecrypt-5.0-bool.patch12
2 files changed, 21 insertions, 6 deletions
diff --git a/app-crypt/truecrypt/files/truecrypt-5.0-64bit.patch b/app-crypt/truecrypt/files/truecrypt-5.0-64bit.patch
index 69d13839a8bf..3c69844cf7b5 100644
--- a/app-crypt/truecrypt/files/truecrypt-5.0-64bit.patch
+++ b/app-crypt/truecrypt/files/truecrypt-5.0-64bit.patch
@@ -93,3 +93,18 @@ diff -urNP truecrypt-5.0-source.org/Platform/StringConverter.h truecrypt-5.0-sou
uint64 val = StringConverter::ToUInt64 (wstring (VolumeSizeTextCtrl->GetValue()));
if (val <= 0x7fffFFFFffffFFFFull / prefixMult)
+--- truecrypt-5.0a-source.org/Makefile 2008-02-04 20:19:02.000000000 +0200
++++ truecrypt-5.0a-source/Makefile 2008-02-13 19:47:58.000000000 +0200
+@@ -42,8 +42,12 @@ export CFLAGS := -W
+ export CXXFLAGS := -Wall
+
+ C_CXX_FLAGS := -MMD -I$(BASE_DIR) -I$(BASE_DIR)/Crypto
+ C_CXX_FLAGS += -DBOOL=int -DFALSE=0 -DTRUE=1
++ifeq "$(origin USE64BIT)" "command line"
++C_CXX_FLAGS += -D__int8=char -D__int16=short -D__int32=int '-D__int64=long' # Tested in PlatformTest
++else
+ C_CXX_FLAGS += -D__int8=char -D__int16=short -D__int32=int '-D__int64=long long' # Tested in PlatformTest
++endif
+
+ export LFLAGS :=
+ export PKG_CONFIG_PATH ?= /usr/local/lib/pkgconfig
diff --git a/app-crypt/truecrypt/files/truecrypt-5.0-bool.patch b/app-crypt/truecrypt/files/truecrypt-5.0-bool.patch
index 2cfd8df11714..ac381c6e8bdf 100644
--- a/app-crypt/truecrypt/files/truecrypt-5.0-bool.patch
+++ b/app-crypt/truecrypt/files/truecrypt-5.0-bool.patch
@@ -21,12 +21,12 @@ diff -urNp truecrypt-5.0-source/Common/Crypto.h truecrypt-5.0-source.new/Common/
diff -urNp truecrypt-5.0-source/Makefile truecrypt-5.0-source.new/Makefile
--- truecrypt-5.0-source/Makefile 2008-02-04 20:19:02.000000000 +0200
+++ truecrypt-5.0-source.new/Makefile 2008-02-10 22:40:34.000000000 +0200
-@@ -42,7 +42,7 @@ export CFLAGS := -W
+@@ -42,7 +42,8 @@ export CFLAGS := -W
export CXXFLAGS := -Wall
C_CXX_FLAGS := -MMD -I$(BASE_DIR) -I$(BASE_DIR)/Crypto
--C_CXX_FLAGS += -DBOOL=int -DFALSE=0 -DTRUE=1
-+C_CXX_FLAGS += -DBOOL=int -DBOOL1=int -DFALSE=0 -DTRUE=1
- C_CXX_FLAGS += -D__int8=char -D__int16=short -D__int32=int '-D__int64=long long' # Tested in PlatformTest
-
- export LFLAGS :=
+ C_CXX_FLAGS += -DBOOL=int -DFALSE=0 -DTRUE=1
++C_CXX_FLAGS += -DBOOL1=int
+ ifeq "$(origin USE64BIT)" "command line"
+ C_CXX_FLAGS += -D__int8=char -D__int16=short -D__int32=int '-D__int64=long' # Tested in PlatformTest
+ else