summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2003-02-03 00:18:46 +0000
committerArcady Genkin <agenkin@gentoo.org>2003-02-03 00:18:46 +0000
commitc07d1a044cca09352152440b24dd8931a568b987 (patch)
treefbd0de1f52c4ff54d726be8dceee06e9a82fd9f6 /app-cdr/gcombust
parentversion bump (diff)
downloadhistorical-c07d1a044cca09352152440b24dd8931a568b987.tar.gz
historical-c07d1a044cca09352152440b24dd8931a568b987.tar.bz2
historical-c07d1a044cca09352152440b24dd8931a568b987.zip
Version bump.
Diffstat (limited to 'app-cdr/gcombust')
-rw-r--r--app-cdr/gcombust/ChangeLog11
-rw-r--r--app-cdr/gcombust/files/digest-gcombust-0.1.541
-rw-r--r--app-cdr/gcombust/gcombust-0.1.54.ebuild46
3 files changed, 54 insertions, 4 deletions
diff --git a/app-cdr/gcombust/ChangeLog b/app-cdr/gcombust/ChangeLog
index e33364b30430..64240a08bff1 100644
--- a/app-cdr/gcombust/ChangeLog
+++ b/app-cdr/gcombust/ChangeLog
@@ -1,13 +1,16 @@
# ChangeLog for app-cdr/gcombust
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/gcombust/ChangeLog,v 1.11 2002/12/13 10:55:59 blizzy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/gcombust/ChangeLog,v 1.12 2003/02/03 00:18:46 agenkin Exp $
+
+*gcombust-0.1.54 (02 Feb 2003)
+
+ 02 Feb 2003; Arcady Genkin <agenkin@gentoo.org> :
+ Version bump.
+ Fixed RDEPEND to also include stuff from DEPEND.
- 06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
-
*gcombust-0.1.53 (27 Oct 2002)
27 Oct 2002; Arcady Genkin <agenkin@gentoo.org> gcombust-0.1.53.ebuild :
-
Version bump.
*gcombust-0.1.52 (08 Jul 2002)
diff --git a/app-cdr/gcombust/files/digest-gcombust-0.1.54 b/app-cdr/gcombust/files/digest-gcombust-0.1.54
new file mode 100644
index 000000000000..ab9aec231fe9
--- /dev/null
+++ b/app-cdr/gcombust/files/digest-gcombust-0.1.54
@@ -0,0 +1 @@
+MD5 a6fbb8a6ddf9dbfcd6e78b54e0d1bd00 gcombust-0.1.54.tar.gz 786628
diff --git a/app-cdr/gcombust/gcombust-0.1.54.ebuild b/app-cdr/gcombust/gcombust-0.1.54.ebuild
new file mode 100644
index 000000000000..ac5445a730d2
--- /dev/null
+++ b/app-cdr/gcombust/gcombust-0.1.54.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/gcombust/gcombust-0.1.54.ebuild,v 1.1 2003/02/03 00:18:46 agenkin Exp $
+
+DESCRIPTION="A GUI for mkisofs/mkhybrid/cdda2wav/cdrecord/cdlabelgen."
+HOMEPAGE="http://www.abo.fi/~jmunsin/gcombust/"
+LICENSE="GPL-2"
+
+IUSE="nls"
+KEYWORDS="~x86"
+
+DEPEND="=x11-libs/gtk+-1.2*
+ nls? ( sys-devel/gettext )"
+
+RDEPEND="${DEPEND}
+ app-cdr/cdrtools"
+
+SRC_URI="http://www.abo.fi/~jmunsin/gcombust/${P}.tar.gz"
+S=${WORKDIR}/${P}
+
+SLOT="0"
+
+src_compile() {
+ local myconf
+
+ if [ -z "`use nls`" ]
+ then
+ myconf="${myconf} --disable-nls"
+ touch intl/libintl.h
+ else
+ myconf="${myconf} --enable-nls"
+ fi
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ ${myconf} \
+ || die
+ emake || die
+}
+
+src_install() {
+ make prefix=${D}/usr install || die
+ dodoc ABOUT-NLS AUTHORS ChangeLog COPYING INSTALL NEWS README THANKS TODO
+ dohtml -a shtml FAQ.shtml
+}