summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-06-25 20:52:05 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-06-25 20:52:05 +0000
commit69538eb85d712774ca1963aed882a49e49ff3047 (patch)
tree6415d49011e2873797794ff2333e9f080a261758 /app-benchmarks/bonnie++/bonnie++-1.02c-r1.ebuild
parentMoved app-misc/bonnie++ to app-benchmarks/bonnie++ (diff)
downloadhistorical-69538eb85d712774ca1963aed882a49e49ff3047.tar.gz
historical-69538eb85d712774ca1963aed882a49e49ff3047.tar.bz2
historical-69538eb85d712774ca1963aed882a49e49ff3047.zip
Moved app-misc/bonnie++ to app-benchmarks/bonnie++
Diffstat (limited to 'app-benchmarks/bonnie++/bonnie++-1.02c-r1.ebuild')
-rw-r--r--app-benchmarks/bonnie++/bonnie++-1.02c-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-benchmarks/bonnie++/bonnie++-1.02c-r1.ebuild b/app-benchmarks/bonnie++/bonnie++-1.02c-r1.ebuild
new file mode 100644
index 000000000000..3ffb08fcc4f0
--- /dev/null
+++ b/app-benchmarks/bonnie++/bonnie++-1.02c-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/bonnie++/bonnie++-1.02c-r1.ebuild,v 1.1 2003/06/25 20:51:56 mholzer Exp $
+
+DESCRIPTION="Hard drive bottleneck testing benchmark suite."
+SRC_URI="http://www.coker.com.au/bonnie++/${P}.tgz"
+HOMEPAGE="http://www.coker.com.au/bonnie++/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+src_compile() {
+ local myconf=""
+ [ "$DEBUG" == "true" ] && myconf="--with-debug --disable-stripping"
+
+ econf ${myconf}
+ emake || die "emake failed"
+ emake zcav || die "emake zcav failed" # see #9073
+}
+
+src_install() {
+ dosbin bonnie++ zcav
+ dobin bon_csv2html bon_csv2txt
+ doman bon_csv2html.1 bon_csv2txt.1 bonnie++.8 zcav.8
+ dohtml readme.html
+ dodoc changelog.txt copyright.txt credits.txt
+}