summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2001-09-29 15:13:36 +0000
committerAron Griffis <agriffis@gentoo.org>2001-09-29 15:13:36 +0000
commitc19df21dc8228f4b7f92c8d8070ff46893df5657 (patch)
treec2a3754c7ba76a119966b9fbdef1556c3c77ff6d /app-arch
parentwelcome the new awesome kdevelop (diff)
downloadhistorical-c19df21dc8228f4b7f92c8d8070ff46893df5657.tar.gz
historical-c19df21dc8228f4b7f92c8d8070ff46893df5657.tar.bz2
historical-c19df21dc8228f4b7f92c8d8070ff46893df5657.zip
Updated dump that builds with linux-headers-2.4.10
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/dump/dump-0.4.24.ebuild51
-rw-r--r--app-arch/dump/files/digest-dump-0.4.241
2 files changed, 52 insertions, 0 deletions
diff --git a/app-arch/dump/dump-0.4.24.ebuild b/app-arch/dump/dump-0.4.24.ebuild
new file mode 100644
index 000000000000..8eca0d19ddb7
--- /dev/null
+++ b/app-arch/dump/dump-0.4.24.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-arch/dump/dump-0.4.24.ebuild,v 1.1 2001/09/29 15:13:36 agriffis Exp $
+
+P=dump-0.4b24
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Dump/restore ext2fs backup utilities"
+SRC_URI="http://download.sourceforge.net/dump/${A}"
+HOMEPAGE="http://dump.sourceforge.net"
+
+DEPEND=">=sys-apps/e2fsprogs-1.19
+ readline? ( >=sys-libs/readline-4.1-r2 >=sys-libs/ncurses-5.2 )
+ >=sys-kernel/linux-headers-2.4.10"
+
+RDEPEND=">=sys-apps/e2fsprogs-1.19
+ readline? ( >=sys-libs/readline-4.1-r2 >=sys-libs/ncurses-5.2 )
+ sys-apps/star"
+
+src_compile() {
+ local myconf
+ if use readline; then
+ myconf=--enable-readline
+ ln -s /lib/libncurses.so libtermcap.so
+ export LDFLAGS="-L${S}"
+ export CFLAGS="$CFLAGS -L${S}"
+ fi
+
+ ./configure --prefix=/usr --host=${CHOST} --enable-largefile ${myconf}
+ assert "./configure failed (myconf=$myconf)"
+
+ emake
+ assert "emake failed (myconf=$myconf)"
+}
+
+src_install () {
+ dodir /sbin
+ dodir /usr/share/man/man8
+ dodir /etc/dumpdates
+ make BINDIR=${D}/sbin MANDIR=${D}/usr/share/man/man8 \
+ DUMPDATESPATH=${D}/etc/dumpdates install || die "make install failed"
+
+ dodoc CHANGES COPYRIGHT KNOWNBUGS MAINTAINERS
+ dodoc README REPORTING-BUGS THANKS TODO
+
+ cd ${D}/sbin
+ rm -f rdump rrestore
+ ln -s dump rdump
+ ln -s restore rrestore
+}
diff --git a/app-arch/dump/files/digest-dump-0.4.24 b/app-arch/dump/files/digest-dump-0.4.24
new file mode 100644
index 000000000000..c10d9509a67f
--- /dev/null
+++ b/app-arch/dump/files/digest-dump-0.4.24
@@ -0,0 +1 @@
+MD5 621a7cee1c7ebadbe8f9df617ba3ff5c dump-0.4b24.tar.gz