summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2000-09-15 20:08:45 +0000
committerDaniel Robbins <drobbins@gentoo.org>2000-09-15 20:08:45 +0000
commit1fd69a5291a83f7b60b306f8f2a94b40c6d40627 (patch)
tree5da0b2137af3e09a1be41fc9a9aeaf2ef7f65428 /app-arch
parentadded try syntax (diff)
downloadhistorical-1fd69a5291a83f7b60b306f8f2a94b40c6d40627.tar.gz
historical-1fd69a5291a83f7b60b306f8f2a94b40c6d40627.tar.bz2
historical-1fd69a5291a83f7b60b306f8f2a94b40c6d40627.zip
added try syntax
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/rpm/rpm-3.0.4-r1.ebuild10
-rw-r--r--app-arch/rpm/rpm-3.0.5.ebuild8
-rw-r--r--app-arch/unzip/unzip-5.41-r1.ebuild4
3 files changed, 11 insertions, 11 deletions
diff --git a/app-arch/rpm/rpm-3.0.4-r1.ebuild b/app-arch/rpm/rpm-3.0.4-r1.ebuild
index b7753fa5f2c2..25afcb55662b 100644
--- a/app-arch/rpm/rpm-3.0.4-r1.ebuild
+++ b/app-arch/rpm/rpm-3.0.4-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-arch/rpm/rpm-3.0.4-r1.ebuild,v 1.3 2000/08/23 07:00:07 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/rpm/rpm-3.0.4-r1.ebuild,v 1.4 2000/09/15 20:08:45 drobbins Exp $
P=rpm-3.0.4
A="${P}.tar.gz bzip2-0.9.5d.tar.gz"
@@ -21,16 +21,16 @@ src_unpack () {
src_compile() {
cd ${WORKDIR}/bzip2-0.9.5d
- make $MAKEOPTS "MAKE = make $MAKEOPTS" all
+ try make $MAKEOPTS "MAKE = try make $MAKEOPTS" all
cd ${S}
export CFLAGS="-I ${WORKDIR}/bzip2-0.9.5d ${CFLAGS} -L ${WORKDIR}/bzip2-0.9.5d -lbz2"
# there is no shared Version of bzlib so we can only build the static version :-(
- ./configure --prefix=/usr --with-catgets
- make
+ try ./configure --prefix=/usr --with-catgets
+ try make
}
src_install() {
- make DESTDIR=${D} install
+ try make DESTDIR=${D} install
mv ${D}/bin/rpm ${D}/usr/bin
rm -rf ${D}/bin
if [ -z "$DBUG" ]
diff --git a/app-arch/rpm/rpm-3.0.5.ebuild b/app-arch/rpm/rpm-3.0.5.ebuild
index 8be1d3c6ffb0..30a88454d0b5 100644
--- a/app-arch/rpm/rpm-3.0.5.ebuild
+++ b/app-arch/rpm/rpm-3.0.5.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-arch/rpm/rpm-3.0.5.ebuild,v 1.2 2000/09/14 00:34:54 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/rpm/rpm-3.0.5.ebuild,v 1.3 2000/09/15 20:08:45 drobbins Exp $
P=rpm-3.0.5
A="${P}.tar.gz"
@@ -13,12 +13,12 @@ HOMEPAGE="http://www.rpm.org/"
src_compile() {
cd ${S}
- ./configure --prefix=/usr --with-catgets
- make
+ try ./configure --prefix=/usr --with-catgets
+ try make
}
src_install() {
- make DESTDIR=${D} install
+ try make DESTDIR=${D} install
mv ${D}/bin/rpm ${D}/usr/bin
rm -rf ${D}/bin
if [ -z "$DBUG" ]
diff --git a/app-arch/unzip/unzip-5.41-r1.ebuild b/app-arch/unzip/unzip-5.41-r1.ebuild
index 2003a45fee67..ab186d22c694 100644
--- a/app-arch/unzip/unzip-5.41-r1.ebuild
+++ b/app-arch/unzip/unzip-5.41-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-arch/unzip/unzip-5.41-r1.ebuild,v 1.2 2000/08/16 04:37:53 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/unzip/unzip-5.41-r1.ebuild,v 1.3 2000/09/15 20:08:45 drobbins Exp $
P=unzip-5.41
A=unzip541.tar.gz
@@ -18,7 +18,7 @@ src_compile() {
cd ${S}
cp unix/Makefile unix/Makefile.orig
sed -e "s:-O3:${CFLAGS}:" unix/Makefile.orig > unix/Makefile
- make -f unix/Makefile linux
+ try make -f unix/Makefile linux
}
src_install() {