summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny van Dyk <kugelfang@gentoo.org>2005-06-21 20:42:12 +0000
committerDanny van Dyk <kugelfang@gentoo.org>2005-06-21 20:42:12 +0000
commit134c8086391e439b34e109f03e3c1c1b6d65fe48 (patch)
treeecdacb1e82d3fb508c447f15cee308749510f4ba /app-arch
parentstable on alpha, wrt bug #96618 (diff)
downloadhistorical-134c8086391e439b34e109f03e3c1c1b6d65fe48.tar.gz
historical-134c8086391e439b34e109f03e3c1c1b6d65fe48.tar.bz2
historical-134c8086391e439b34e109f03e3c1c1b6d65fe48.zip
Fixed BUG #95110. Patch written by Juan J. García de Soria.
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/unace/ChangeLog6
-rw-r--r--app-arch/unace/Manifest15
-rw-r--r--app-arch/unace/files/unace-1.2b-64bit.patch56
-rw-r--r--app-arch/unace/unace-1.2b-r1.ebuild3
4 files changed, 76 insertions, 4 deletions
diff --git a/app-arch/unace/ChangeLog b/app-arch/unace/ChangeLog
index 6f05980add1b..5c5d1cc890f2 100644
--- a/app-arch/unace/ChangeLog
+++ b/app-arch/unace/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-arch/unace
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/unace/ChangeLog,v 1.22 2005/04/24 10:44:19 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/unace/ChangeLog,v 1.23 2005/06/21 20:42:12 kugelfang Exp $
+
+ 21 Jun 2005; Danny van Dyk <kugelfang@gentoo.org>
+ +files/unace-1.2b-64bit.patch, unace-1.2b-r1.ebuild:
+ Fixed BUG #95110. Thanks to Juan J. García de Soria for the patch.
24 Apr 2005; Michael Hanselmann <hansmi@gentoo.org> unace-1.2b-r1.ebuild:
Stable on ppc.
diff --git a/app-arch/unace/Manifest b/app-arch/unace/Manifest
index 301ecf415750..76c3d263c90a 100644
--- a/app-arch/unace/Manifest
+++ b/app-arch/unace/Manifest
@@ -1,4 +1,15 @@
-MD5 f8b2fa3792541ada970a2aad2a8f7913 ChangeLog 2586
-MD5 c032c96e73b35eba486d9b6d3e5ec2b7 unace-1.2b-r1.ebuild 815
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 a78db37c104932ff0370f27e111fae7a ChangeLog 2767
+MD5 e0a8bf7f84cd7b168a65f404d047c8b0 unace-1.2b-r1.ebuild 863
MD5 34628d3f6507592703856c82761becf0 files/digest-unace-1.2b-r1 61
MD5 5ec540a4e79c388d1b3e270f2c7083f8 files/unace-1.2b-CAN-2005-0160-CAN-2005-0161.patch 4618
+MD5 dd6ae2184aa3e8f4767d5298880afee6 files/unace-1.2b-64bit.patch 1604
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.1 (GNU/Linux)
+
+iD8DBQFCuHzc5mJXAu5GbtIRAiLkAJ4rB8mvI6bzd/QxwBrP+R4lNsPAqgCeKFH1
+2ttsroV18ulAi2Eq3b++Qaw=
+=5JFp
+-----END PGP SIGNATURE-----
diff --git a/app-arch/unace/files/unace-1.2b-64bit.patch b/app-arch/unace/files/unace-1.2b-64bit.patch
new file mode 100644
index 000000000000..a90fc2752134
--- /dev/null
+++ b/app-arch/unace/files/unace-1.2b-64bit.patch
@@ -0,0 +1,56 @@
+diff -ur unace/declare.h unace-fixed/declare.h
+--- unace/declare.h 2002-08-24 01:17:19.000000000 +0200
++++ unace-fixed/declare.h 2005-06-05 12:23:11.000000000 +0200
+@@ -7,6 +7,23 @@
+ #ifndef __declare_h
+ #define __declare_h
+
++#ifdef UNIX
++
++#include <inttypes.h>
++
++typedef uint16_t USHORT;
++typedef int16_t SHORT ;
++typedef uint16_t UWORD ;
++typedef int16_t WORD ;
++typedef uint32_t ULONG ;
++typedef int32_t LONG ;
++typedef uint8_t UCHAR ;
++typedef int8_t CHAR ;
++typedef unsigned UINT ;
++typedef int INT ;
++
++#else /* UNIX */
++
+ #ifdef AMIGA
+
+ #include <exec/types.h>
+@@ -27,6 +44,7 @@
+ typedef unsigned UINT ;
+ typedef int INT ;
+
++#endif /* UNIX */
+
+ #endif /* __declare_h */
+
+diff -ur unace/unace.c unace-fixed/unace.c
+--- unace/unace.c 2005-06-05 12:21:43.000000000 +0200
++++ unace-fixed/unace.c 2005-06-05 12:24:39.000000000 +0200
+@@ -516,7 +516,7 @@
+ tpsize+= fhead.PSIZE;
+ }
+ if (!f_err)
+- printf("%02u.%02u.%02u|%02u:%02u|%c%c%9lu|%9lu|%4u%%|%c%s\n",
++ printf("%02u.%02u.%02u|%02u:%02u|%c%c%9u|%9u|%4u%%|%c%s\n",
+ ts_day (ti), ts_month(ti), ts_year(ti)%100,
+ ts_hour(ti), ts_min (ti),
+ fhead.HEAD_FLAGS & ACE_SP_BEF ? '<' : ' ',
+@@ -529,7 +529,7 @@
+ }
+ if (!f_err)
+ {
+- printf("\n %9lu|%9lu|%4u%%| %u file%s",
++ printf("\n %9u|%9u|%4u%%| %u file%s",
+ psize,
+ size,
+ percentage(psize, size),
diff --git a/app-arch/unace/unace-1.2b-r1.ebuild b/app-arch/unace/unace-1.2b-r1.ebuild
index 91b03736d423..b1142ea50d2e 100644
--- a/app-arch/unace/unace-1.2b-r1.ebuild
+++ b/app-arch/unace/unace-1.2b-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/unace/unace-1.2b-r1.ebuild,v 1.6 2005/05/17 22:08:02 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/unace/unace-1.2b-r1.ebuild,v 1.7 2005/06/21 20:42:12 kugelfang Exp $
inherit eutils
@@ -23,6 +23,7 @@ src_unpack() {
cp unix/makefile .
cp unix/gccmaked .
epatch "${FILESDIR}"/unace-1.2b-CAN-2005-0160-CAN-2005-0161.patch
+ epatch "${FILESDIR}"/unace-1.2b-64bit.patch
}
src_compile() {