summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-04-03 18:22:19 +0000
committerMike Frysinger <vapier@gentoo.org>2014-04-03 18:22:19 +0000
commite0847914c3624a376a1f9d0839867e4d14a183dc (patch)
tree6a26cb54784baa88cd860aa9043870de914cf57a /app-arch/snappy/snappy-1.1.2-r1.ebuild
parentVersion bump (diff)
downloadhistorical-e0847914c3624a376a1f9d0839867e4d14a183dc.tar.gz
historical-e0847914c3624a376a1f9d0839867e4d14a183dc.tar.bz2
historical-e0847914c3624a376a1f9d0839867e4d14a183dc.zip
Convert to autotools-multilib #504756 by David Heidelberger.
Package-Manager: portage-2.2.10/cvs/Linux x86_64 Manifest-Sign-Key: 0xD2E96200
Diffstat (limited to 'app-arch/snappy/snappy-1.1.2-r1.ebuild')
-rw-r--r--app-arch/snappy/snappy-1.1.2-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-arch/snappy/snappy-1.1.2-r1.ebuild b/app-arch/snappy/snappy-1.1.2-r1.ebuild
new file mode 100644
index 000000000000..f77c483c89a2
--- /dev/null
+++ b/app-arch/snappy/snappy-1.1.2-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/snappy/snappy-1.1.2-r1.ebuild,v 1.1 2014/04/03 18:22:16 vapier Exp $
+
+EAPI="5"
+
+inherit eutils autotools-multilib
+
+DESCRIPTION="A high-speed compression/decompression library by Google"
+HOMEPAGE="https://code.google.com/p/snappy/"
+# upstream uses google drive which has hash-based URLS
+SRC_URI="http://dev.gentoo.org/~radhermit/dist/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+src_prepare() {
+ default
+
+ # Avoid automagic lzo and gzip by not checking for it
+ sed -i '/^CHECK_EXT_COMPRESSION_LIB/d' configure.ac || die
+
+ # don't install unwanted files
+ sed -i 's/COPYING INSTALL//' Makefile.am || die
+
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf \
+ --docdir='$(datarootdir)'/doc/${PF} \
+ --without-gflags \
+ --disable-gtest \
+ $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+ prune_libtool_files
+}