summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Farina <zerochaos@gentoo.org>2012-11-25 02:10:12 +0000
committerRichard Farina <zerochaos@gentoo.org>2012-11-25 02:10:12 +0000
commit9e94385f761607245fc0f496519695ae90aebf9e (patch)
tree9fec940f8a5aacf4ce5af6d5d0b901d64884a660 /app-arch/pixz/pixz-1.0.ebuild
parentremove anarchy as maintainer per his wishes (diff)
downloadhistorical-9e94385f761607245fc0f496519695ae90aebf9e.tar.gz
historical-9e94385f761607245fc0f496519695ae90aebf9e.tar.bz2
historical-9e94385f761607245fc0f496519695ae90aebf9e.zip
suggested changes and stable version added from bug #444530
Package-Manager: portage-2.1.11.31/cvs/Linux x86_64 Manifest-Sign-Key: 0xDD11F94A
Diffstat (limited to 'app-arch/pixz/pixz-1.0.ebuild')
-rw-r--r--app-arch/pixz/pixz-1.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-arch/pixz/pixz-1.0.ebuild b/app-arch/pixz/pixz-1.0.ebuild
new file mode 100644
index 000000000000..47b343bda7ca
--- /dev/null
+++ b/app-arch/pixz/pixz-1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/pixz/pixz-1.0.ebuild,v 1.1 2012/11/25 02:10:01 zerochaos Exp $
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="Parallel Indexed XZ compressor"
+HOMEPAGE="https://github.com/vasi/pixz"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-2
+ EGIT_REPO_URI="https://github.com/vasi/pixz.git"
+ KEYWORDS=""
+else
+ SRC_URI="mirror://github/vasi/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=app-arch/libarchive-2.8
+ >=app-arch/xz-utils-5"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ emake CC="$(tc-getCC)" OPT=""
+}
+
+src_install() {
+ dobin pixz
+ dodoc README TODO
+}