summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDylan Carlson <absinthe@gentoo.org>2003-04-16 20:13:55 +0000
committerDylan Carlson <absinthe@gentoo.org>2003-04-16 20:13:55 +0000
commit3633dfe661cc1e7eb9cc585e65b2aa7637256df9 (patch)
tree2b131ca550dd8dfb74c7c067b91cd1d956937a6b /app-arch/bsdsfv
parentdisable razor tests bug 17988 (diff)
downloadhistorical-3633dfe661cc1e7eb9cc585e65b2aa7637256df9.tar.gz
historical-3633dfe661cc1e7eb9cc585e65b2aa7637256df9.tar.bz2
historical-3633dfe661cc1e7eb9cc585e65b2aa7637256df9.zip
Fixed the patch.
Diffstat (limited to 'app-arch/bsdsfv')
-rw-r--r--app-arch/bsdsfv/ChangeLog6
-rw-r--r--app-arch/bsdsfv/bsdsfv-1.14.ebuild6
-rw-r--r--app-arch/bsdsfv/files/bsdsfv-1.14-gentoo.diff25
-rw-r--r--app-arch/bsdsfv/files/digest-bsdsfv-1.144
4 files changed, 24 insertions, 17 deletions
diff --git a/app-arch/bsdsfv/ChangeLog b/app-arch/bsdsfv/ChangeLog
index cd6e2e8eeb84..274c05163f19 100644
--- a/app-arch/bsdsfv/ChangeLog
+++ b/app-arch/bsdsfv/ChangeLog
@@ -1,9 +1,13 @@
# ChangeLog for app-arch/bsdsfv
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/bsdsfv/ChangeLog,v 1.7 2003/04/15 22:25:56 absinthe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/bsdsfv/ChangeLog,v 1.8 2003/04/16 20:13:55 absinthe Exp $
*bsdsfv-1.14 (15 Apr 2003)
+ 16 Apr 2003; Dylan Carlson <absinthe@gentoo.org> bsdsfv-1.14.ebuild,
+ files/bsdsfv-1.14-gentoo.diff:
+ Fixed the patch (thanks to dragon for pointing this out).
+
15 Apr 2003; Dylan Carlson <absinthe@gentoo.org>
bsdsfv-1.14.ebuild, files/bsdsfv-1.14-gentoo.diff:
Version bump, masked for testing. The authors changed the versioning scheme.
diff --git a/app-arch/bsdsfv/bsdsfv-1.14.ebuild b/app-arch/bsdsfv/bsdsfv-1.14.ebuild
index 1e18c3fa706f..a3addaa2f90b 100644
--- a/app-arch/bsdsfv/bsdsfv-1.14.ebuild
+++ b/app-arch/bsdsfv/bsdsfv-1.14.ebuild
@@ -1,11 +1,10 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/bsdsfv/bsdsfv-1.14.ebuild,v 1.1 2003/04/15 22:25:56 absinthe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/bsdsfv/bsdsfv-1.14.ebuild,v 1.2 2003/04/16 20:13:55 absinthe Exp $
S="${WORKDIR}/bsdsfv"
-P="${PN}.${PV}"
DESCRIPTION="BSDSFV: All-in-one SFV checksum utility"
-SRC_URI="mirror://sourceforge/bsdsfv/${P}.tar.gz"
+SRC_URI="mirror://sourceforge/bsdsfv/${PN}.${PV}.tar.gz"
HOMEPAGE="http://bsdsfv.sourceforge.net/"
SLOT="0"
@@ -15,6 +14,7 @@ KEYWORDS="~x86 ~ppc ~sparc "
DEPEND="virtual/glibc"
src_compile() {
+ cd ${S}
epatch ${FILESDIR}/${PN}-${PV}-gentoo.diff
emake || die
}
diff --git a/app-arch/bsdsfv/files/bsdsfv-1.14-gentoo.diff b/app-arch/bsdsfv/files/bsdsfv-1.14-gentoo.diff
index d09b0dc6472c..b9c395dc594f 100644
--- a/app-arch/bsdsfv/files/bsdsfv-1.14-gentoo.diff
+++ b/app-arch/bsdsfv/files/bsdsfv-1.14-gentoo.diff
@@ -1,11 +1,14 @@
---- bsdsfv.c 2003-03-17 00:26:16.000000000 -0800
-+++ bsdsfv.c.pj 2003-03-26 04:41:44.000000000 -0800
-@@ -37,9 +37,18 @@
+--- bsdsfv.c.orig 2003-04-16 16:05:16.000000000 -0400
++++ bsdsfv.c 2003-04-16 16:09:50.000000000 -0400
+@@ -34,12 +34,20 @@
+ *************************************************************************/
+
+-
#define FNAMELEN 250
#define MAXSFVFILE 1024
--#define BSDSFV_VERSION "BSDSFV for UNiX, $Revision: 1.1 $"
-+#define BSDSFV_VERSION "BSDSFV for UNiX, $Revision: 1.1 $"
+-#define BSDSFV_VERSION "BSDSFV for UNiX, $Revision: 1.2 $"
++#define BSDSFV_VERSION "BSDSFV for UNiX, Revision: 1.14"
#define MISSINGTAG ".missing"
#define BADTAG ".bad"
+#define OPENBRACKET "\e[34;01m[\e[0m"
@@ -20,7 +23,7 @@
typedef struct sfvtable
{
-@@ -523,7 +532,7 @@
+@@ -523,7 +531,7 @@
if (listedcrc == mycrc)
{
@@ -29,7 +32,7 @@
if (glftpdmode)
{
sprintf (crap, "%s%s", sfvTable[0].filename,
-@@ -535,7 +544,7 @@
+@@ -535,7 +543,7 @@
}
else
{
@@ -38,7 +41,7 @@
badfiles++;
if (glftpdmode)
{
-@@ -549,16 +558,18 @@
+@@ -549,16 +557,18 @@
}
else
{
@@ -61,7 +64,7 @@
if (badfiles || missingfiles)
return 1;
-@@ -635,18 +646,18 @@
+@@ -635,18 +645,18 @@
if (mycrc == sfvTable[cnt].crc)
{
@@ -83,7 +86,7 @@
badfiles++;
}
}
-@@ -668,8 +679,9 @@
+@@ -668,8 +678,9 @@
}
else
{
@@ -95,7 +98,7 @@
missingfiles++;
if (glftpdmode)
{
-@@ -714,10 +726,12 @@
+@@ -714,10 +725,12 @@
}
printf ("Completion Status: %s\n", NEWTAG);
}
diff --git a/app-arch/bsdsfv/files/digest-bsdsfv-1.14 b/app-arch/bsdsfv/files/digest-bsdsfv-1.14
index 348c5abe1f66..1adb30e50254 100644
--- a/app-arch/bsdsfv/files/digest-bsdsfv-1.14
+++ b/app-arch/bsdsfv/files/digest-bsdsfv-1.14
@@ -1,3 +1,3 @@
-MD5 2d74a9d0f80bc60b3c30bfdb89df6b09 /files/bsdsfv-1.14-gentoo.diff 3512
-MD5 578ccfc91c0aa4abce68e890aaff7e91 /bsdsfv-1.14.ebuild 620
+MD5 3d92ff95b6d078f2d3dd727fdae1a95f /files/bsdsfv-1.14-gentoo.diff 3595
+MD5 27521e04e04ae5064d47135f6509eef8 /bsdsfv-1.14.ebuild 620
MD5 67caa8503a2506b68aaf53aa655a9f04 bsdsfv.1.14.tar.gz 13327