summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTavis Ormandy <taviso@gentoo.org>2005-04-29 22:28:55 +0000
committerTavis Ormandy <taviso@gentoo.org>2005-04-29 22:28:55 +0000
commitf546ce5fa1ae826c75138fd3ebe4b76842f56760 (patch)
tree7fe1babbc64225ec3d308c0a339126ac32954973 /app-admin
parentRetouches retouches retouches (diff)
downloadhistorical-f546ce5fa1ae826c75138fd3ebe4b76842f56760.tar.gz
historical-f546ce5fa1ae826c75138fd3ebe4b76842f56760.tar.bz2
historical-f546ce5fa1ae826c75138fd3ebe4b76842f56760.zip
bump, & fix 90900
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/otpcalc/Manifest5
-rw-r--r--app-admin/otpcalc/files/digest-otpcalc-0.971
-rw-r--r--app-admin/otpcalc/files/otpcalc-man-table-format.diff33
-rw-r--r--app-admin/otpcalc/otpcalc-0.97.ebuild33
4 files changed, 71 insertions, 1 deletions
diff --git a/app-admin/otpcalc/Manifest b/app-admin/otpcalc/Manifest
index 9919b0810c7f..dd1f2a4f6648 100644
--- a/app-admin/otpcalc/Manifest
+++ b/app-admin/otpcalc/Manifest
@@ -1,4 +1,7 @@
+MD5 9b967abe9ebc9a808b2ca0cec4e335cc otpcalc-0.97.ebuild 805
+MD5 6ea30414bc821c3393f352c655906d4c otpcalc-0.96.ebuild 729
MD5 acc558063d09e1963951e5e36d634bed ChangeLog 718
MD5 78714bd1cdeb6709df0a6dcc4c5347ce metadata.xml 410
-MD5 6ea30414bc821c3393f352c655906d4c otpcalc-0.96.ebuild 729
MD5 1ce297d1a90353ea4e3ee49a9d21be6d files/digest-otpcalc-0.96 64
+MD5 fb4ade24812b14dd5fc4c2d89dc6a9a5 files/digest-otpcalc-0.97 64
+MD5 79ac858c43e67fdc670c1092b51a03ad files/otpcalc-man-table-format.diff 507
diff --git a/app-admin/otpcalc/files/digest-otpcalc-0.97 b/app-admin/otpcalc/files/digest-otpcalc-0.97
new file mode 100644
index 000000000000..334e98f1b5cf
--- /dev/null
+++ b/app-admin/otpcalc/files/digest-otpcalc-0.97
@@ -0,0 +1 @@
+MD5 73c9a9e95462afda725fdf17a301f0b0 otpCalc-0.97.tar.gz 123704
diff --git a/app-admin/otpcalc/files/otpcalc-man-table-format.diff b/app-admin/otpcalc/files/otpcalc-man-table-format.diff
new file mode 100644
index 000000000000..062cce7f4b5f
--- /dev/null
+++ b/app-admin/otpcalc/files/otpcalc-man-table-format.diff
@@ -0,0 +1,33 @@
+--- otpCalc.man.orig 2005-04-29 23:17:06.000000000 +0100
++++ otpCalc.man 2005-04-29 23:19:03.000000000 +0100
+@@ -24,18 +24,20 @@
+ the Challenge input:
+ .IP
+ .TS
+-s/key MD4
+-.br
+-otp-md4 MD4
+-.br
+-otp-md5 MD5
+-.br
+-otp-rmd160 RIPEMD-160
+-.br
+-otp-sha1 SHA1
+-.br
++allbox tab(#);
++cb l
++cb l
++cb l
++cb l
++cb l.
++s/key#MD4
++otp-md4#MD4
++otp-md5#MD5
++otp-rmd160#RIPEMD-160
++otp-sha1#SHA1
+ .TE
+ .LP
++.LP
+ In the absence of a prefix, the default hash, specified in the Settings menu,
+ is used.
+ .SH "SEE ALSO"
diff --git a/app-admin/otpcalc/otpcalc-0.97.ebuild b/app-admin/otpcalc/otpcalc-0.97.ebuild
new file mode 100644
index 000000000000..c668b7a47078
--- /dev/null
+++ b/app-admin/otpcalc/otpcalc-0.97.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/otpcalc/otpcalc-0.97.ebuild,v 1.1 2005/04/29 22:28:55 taviso Exp $
+
+inherit eutils
+
+DESCRIPTION="A One Time Password and S/Key calculator for X"
+HOMEPAGE="http://killa.net/infosec/otpCalc/"
+SRC_URI="http://killa.net/infosec/otpCalc/otpCalc-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~alpha ~ppc"
+IUSE=""
+
+DEPEND="=x11-libs/gtk+-1.2*
+ virtual/x11
+ virtual/libc"
+
+S=${WORKDIR}/${P/c/C}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/otpcalc-man-table-format.diff
+ sed -i -e "s/VERSION/${PV}/g" ${S}/otpCalc.man
+ sed -i "s#-s -O3#${CFLAGS}#g" ${S}/Makefile.in
+}
+
+src_install() {
+ newman otpCalc.man otpCalc.1
+ dobin otpCalc || die
+}