summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-07-21 19:28:44 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-07-21 19:28:44 +0000
commit0d150889cdf642d6af3bfd6942de3e224152f631 (patch)
tree4b0c18e049e0d6c6d4b0e201d82a3d895dbac409 /app-admin
parentAdded depend section. Closes #24818 (diff)
downloadhistorical-0d150889cdf642d6af3bfd6942de3e224152f631.tar.gz
historical-0d150889cdf642d6af3bfd6942de3e224152f631.tar.bz2
historical-0d150889cdf642d6af3bfd6942de3e224152f631.zip
Added depend section. Closes #24818
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/webmin/Manifest4
-rw-r--r--app-admin/webmin/files/digest-webmin-1.100-r11
-rw-r--r--app-admin/webmin/files/webmin-gentoo-init19
-rw-r--r--app-admin/webmin/webmin-1.100-r1.ebuild74
4 files changed, 96 insertions, 2 deletions
diff --git a/app-admin/webmin/Manifest b/app-admin/webmin/Manifest
index 0c5944554aad..ea2b1b6d72c0 100644
--- a/app-admin/webmin/Manifest
+++ b/app-admin/webmin/Manifest
@@ -1,7 +1,7 @@
-MD5 8da272547d823ad06bd4d4e28d2f454b ChangeLog 3814
+MD5 c37a1b7ccc10be645fe30b4f7d84d61e ChangeLog 3987
MD5 35394441f81a8321971fa6056d0737ea webmin-1.080.ebuild 1763
MD5 d6c2044e40ed6ff8fdd8bdb88e9608c5 webmin-1.100.ebuild 1764
-MD5 76da3b78cc603d6b2fe844d221775674 webmin-1.100-r1.ebuild 1811
+MD5 0a81e415921873484db6d59f81745bf7 webmin-1.100-r1.ebuild 1889
MD5 c2e70e10958f50cd84c377b5963a8ced files/digest-webmin-1.080 65
MD5 31d430597ce4bb6b1d249fbc827688fc files/webmin-gentoo-init 306
MD5 bc8eb1c9de103599fc00b140b0ed1f9f files/uninstall.sh 260
diff --git a/app-admin/webmin/files/digest-webmin-1.100-r1 b/app-admin/webmin/files/digest-webmin-1.100-r1
new file mode 100644
index 000000000000..721077f278ae
--- /dev/null
+++ b/app-admin/webmin/files/digest-webmin-1.100-r1
@@ -0,0 +1 @@
+MD5 9b426bc40b51f70182d0e5bf41f82078 webmin-1.100.tar.gz 6682855
diff --git a/app-admin/webmin/files/webmin-gentoo-init b/app-admin/webmin/files/webmin-gentoo-init
new file mode 100644
index 000000000000..a6fd9b354a0c
--- /dev/null
+++ b/app-admin/webmin/files/webmin-gentoo-init
@@ -0,0 +1,19 @@
+#!/sbin/runscript
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+
+depend() {
+ need net logger
+}
+
+start() {
+ ebegin "Starting webmin"
+ /etc/webmin/start
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping webmin"
+ /etc/webmin/stop
+ eend $?
+}
diff --git a/app-admin/webmin/webmin-1.100-r1.ebuild b/app-admin/webmin/webmin-1.100-r1.ebuild
new file mode 100644
index 000000000000..5efe39f8b639
--- /dev/null
+++ b/app-admin/webmin/webmin-1.100-r1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webmin/webmin-1.100-r1.ebuild,v 1.1 2003/07/21 19:28:32 mholzer Exp $
+
+IUSE="ssl"
+
+DESCRIPTION="Webmin, a web-based system administration interface"
+SRC_URI="mirror://sourceforge/webadmin/${P}.tar.gz"
+HOMEPAGE="http://www.webmin.com/"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="x86 ~ppc ~sparc"
+
+DEPEND="dev-lang/perl
+ ssl? ( dev-perl/Net-SSLeay )"
+
+RDEPEND=""
+
+src_install() {
+ rm -f mount/freebsd-mounts*
+ rm -f mount/openbsd-mounts*
+ rm -f mount/macos-mounts*
+ (find . -name '*.cgi' ; find . -name '*.pl') | perl perlpath.pl /usr/bin/perl -
+ dodir /usr/libexec/webmin
+ dodir /etc/init.d
+ dodir /var
+ dodir /etc/pam.d
+ cp -rp * ${D}/usr/libexec/webmin
+ mv ${D}/usr/libexec/webmin/openslp/config \
+ ${D}/usr/libexec/webmin/openslp/config-gentoo-linux
+
+ exeinto /etc/init.d
+ #newexe webmin-gentoo-init webmin
+ #Bug submitted to webmin-maintainer.
+ #Check in next Version if corrected
+ newexe ${FILESDIR}/webmin-gentoo-init webmin
+
+ insinto /etc/pam.d/
+ newins webmin-pam webmin
+ echo gentoo > ${D}/usr/libexec/webmin/install-type
+
+ exeinto /etc/webmin
+ doexe ${FILESDIR}/uninstall.sh
+}
+
+pkg_postinst() {
+ /etc/init.d/webmin stop >/dev/null 2>&1
+ stopstatus=$?
+ cd /usr/libexec/webmin
+ config_dir=/etc/webmin
+ var_dir=/var/webmin
+ perl=/usr/bin/perl
+ autoos=1
+ port=10000
+ login=root
+ crypt=`grep "^root:" /etc/shadow | cut -f 2 -d :`
+ host=`hostname`
+ ssl=0
+ atboot=0
+ nostart=1
+ nochown=1
+ autothird=1
+ nouninstall=1
+ noperlpath=1
+ export config_dir var_dir perl autoos port login crypt host ssl nochown autothird nouninstall nostart noperlpath
+ perl /usr/libexec/webmin/maketemp.pl
+ ./setup.sh >/tmp/.webmin/webmin-setup.out 2>&1
+
+ if [ "$stopstatus" = "0" ]; then
+ # Start if it was running before
+ /etc/init.d/webmin start
+ fi
+}