summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2014-03-26 16:02:04 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2014-03-26 16:02:04 +0000
commitde5584c706478b0c62edaf55aee9492b9e5765d4 (patch)
tree6dacfd175b4dfc38a99c9788a7ef4344ffbf664f /app-admin/xstow/xstow-1.0.1.ebuild
parentStable for HPPA (bug #502608). (diff)
downloadhistorical-de5584c706478b0c62edaf55aee9492b9e5765d4.tar.gz
historical-de5584c706478b0c62edaf55aee9492b9e5765d4.tar.bz2
historical-de5584c706478b0c62edaf55aee9492b9e5765d4.zip
Add MANPATH to /etc/env.d/99xstow, bug #505322. Thanks to Erik Falor.
Package-Manager: portage-2.2.8-r1/cvs/Linux x86_64 Manifest-Sign-Key: 0xF8DBDADE
Diffstat (limited to 'app-admin/xstow/xstow-1.0.1.ebuild')
-rw-r--r--app-admin/xstow/xstow-1.0.1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/app-admin/xstow/xstow-1.0.1.ebuild b/app-admin/xstow/xstow-1.0.1.ebuild
new file mode 100644
index 000000000000..0355059f462e
--- /dev/null
+++ b/app-admin/xstow/xstow-1.0.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/xstow/xstow-1.0.1.ebuild,v 1.1 2014/03/26 16:01:56 maksbotan Exp $
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="replacement for GNU stow with extensions"
+HOMEPAGE="http://xstow.sourceforge.net/"
+SRC_URI="mirror://sourceforge/xstow/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="ncurses static"
+
+DEPEND="ncurses? ( sys-libs/ncurses )"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ econf --disable-dependency-tracking\
+ $(use_with ncurses curses)\
+ $(use_enable static)
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" docdir="/usr/share/doc/${PF}/html" \
+ install || die "emake install failed."
+ dodoc AUTHORS ChangeLog NEWS README TODO
+
+ # create new STOWDIR
+ dodir /var/lib/xstow
+
+ # install env.d file to add STOWDIR to PATH and LDPATH
+ doenvd "${FILESDIR}/99xstow" || die "doenvd failed"
+}
+
+pkg_postinst() {
+ elog "We now recommend that you use /var/lib/xstow as your STOWDIR"
+ elog "instead of /usr/local in order to avoid conflicts with the"
+ elog "symlink from /usr/lib64 -> /usr/lib. See Bug 246264"
+ elog "(regarding app-admin/stow, equally applicable to XStow) for"
+ elog "more details on this change."
+ elog "For your convenience, PATH has been updated to include"
+ elog "/var/lib/bin."
+}