summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Heim <phreak@gentoo.org>2006-09-16 15:46:45 +0000
committerChristian Heim <phreak@gentoo.org>2006-09-16 15:46:45 +0000
commit6bbc1608d566fa63ea0119b4285febb3ff8e6140 (patch)
treeb9064ae9cebaa96c011e4d20b5c87632e8772c0b /app-admin/whowatch/whowatch-1.5.2-r1.ebuild
parentppc stable (diff)
downloadhistorical-6bbc1608d566fa63ea0119b4285febb3ff8e6140.tar.gz
historical-6bbc1608d566fa63ea0119b4285febb3ff8e6140.tar.bz2
historical-6bbc1608d566fa63ea0119b4285febb3ff8e6140.zip
Revision bump, fixing compilation with gcc-4 (#146138, thanks to Janne Pikkarainen for the inital patch), fixing usage with gcc-3.4 (#102339, WORKSFORME with gcc-3.4.6). Also updating the ChangeLog (ChrisWhite didn't on 2005/11/06). Taking maintainership of the package.
Package-Manager: portage-2.1.2_pre1
Diffstat (limited to 'app-admin/whowatch/whowatch-1.5.2-r1.ebuild')
-rw-r--r--app-admin/whowatch/whowatch-1.5.2-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-admin/whowatch/whowatch-1.5.2-r1.ebuild b/app-admin/whowatch/whowatch-1.5.2-r1.ebuild
new file mode 100644
index 000000000000..31ab9675352a
--- /dev/null
+++ b/app-admin/whowatch/whowatch-1.5.2-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/whowatch/whowatch-1.5.2-r1.ebuild,v 1.1 2006/09/16 15:46:45 phreak Exp $
+
+inherit eutils
+
+DESCRIPTION="interactive who-like program that displays information about users currently logged on in real time"
+HOMEPAGE="http://wizard.ae.krakow.pl/~mike/"
+SRC_URI="http://wizard.ae.krakow.pl/~mike/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="sys-libs/ncurses"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-Makefile.in.patch
+ epatch "${FILESDIR}"/${P}-gcc4.patch
+}
+
+src_compile() {
+ econf || die "econf failed"
+ make || die
+}
+
+src_install() {
+ einstall || die
+ dodoc AUTHORS ChangeLog KEYS NEWS README TODO VERSION
+}