summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Imhof <tantive@gentoo.org>2002-11-18 18:59:09 +0000
committerMichael Imhof <tantive@gentoo.org>2002-11-18 18:59:09 +0000
commit6fdbcf21409b9f2304288c01eb0cc2b7d4acaf24 (patch)
tree99f755b7a2d00a1a3d368f29586dd17b3311d3e0 /app-admin/openmosixtest
parentFixes #10061 (diff)
downloadhistorical-6fdbcf21409b9f2304288c01eb0cc2b7d4acaf24.tar.gz
historical-6fdbcf21409b9f2304288c01eb0cc2b7d4acaf24.tar.bz2
historical-6fdbcf21409b9f2304288c01eb0cc2b7d4acaf24.zip
Minor update to make these ebuilds non-interactive
Diffstat (limited to 'app-admin/openmosixtest')
-rw-r--r--app-admin/openmosixtest/openmosixtest-0.1-r1.ebuild15
-rw-r--r--app-admin/openmosixtest/openmosixtest-0.1-r2.ebuild15
-rw-r--r--app-admin/openmosixtest/openmosixtest-0.1-r3.ebuild3
3 files changed, 27 insertions, 6 deletions
diff --git a/app-admin/openmosixtest/openmosixtest-0.1-r1.ebuild b/app-admin/openmosixtest/openmosixtest-0.1-r1.ebuild
index 527a65ab431f..0f546a55fb0d 100644
--- a/app-admin/openmosixtest/openmosixtest-0.1-r1.ebuild
+++ b/app-admin/openmosixtest/openmosixtest-0.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/openmosixtest/openmosixtest-0.1-r1.ebuild,v 1.6 2002/11/07 16:01:52 tantive Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/openmosixtest/openmosixtest-0.1-r1.ebuild,v 1.7 2002/11/18 18:59:09 tantive Exp $
S=${WORKDIR}/omtest
DESCRIPTION="openMosix stress test"
@@ -17,12 +17,23 @@ SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 -ppc -sparc -sparc64 -alpha"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ #Make compile_tests.sh non-interactive
+ mv compile_tests.sh compile_tests.sh.orig
+ sed -e 's:read::' compile_tests.sh.orig >compile_tests.sh
+ rm compile_tests.sh.orig
+ chmod +x compile_tests.sh
+}
+
src_install() {
dodir /opt/omtest
cp -r * ${WORKDIR}/../image/opt/omtest
}
-
pkg_postinst() {
cd /opt/omtest
einfo
diff --git a/app-admin/openmosixtest/openmosixtest-0.1-r2.ebuild b/app-admin/openmosixtest/openmosixtest-0.1-r2.ebuild
index 75f9b7528bea..c53b31fd36d6 100644
--- a/app-admin/openmosixtest/openmosixtest-0.1-r2.ebuild
+++ b/app-admin/openmosixtest/openmosixtest-0.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/openmosixtest/openmosixtest-0.1-r2.ebuild,v 1.1 2002/11/07 16:01:52 tantive Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/openmosixtest/openmosixtest-0.1-r2.ebuild,v 1.2 2002/11/18 18:59:09 tantive Exp $
S=${WORKDIR}/omtest
DESCRIPTION="openMosix stress test"
@@ -17,12 +17,23 @@ SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~x86 -ppc -sparc -sparc64 -alpha"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ #Make compile_tests.sh non-interactive
+ mv compile_tests.sh compile_tests.sh.orig
+ sed -e 's:read::' compile_tests.sh.orig >compile_tests.sh
+ rm compile_tests.sh.orig
+ chmod +x compile_tests.sh
+}
+
src_install() {
dodir /opt/omtest
cp -r * ${WORKDIR}/../image/opt/omtest
}
-
pkg_postinst() {
cd /opt/omtest
einfo
diff --git a/app-admin/openmosixtest/openmosixtest-0.1-r3.ebuild b/app-admin/openmosixtest/openmosixtest-0.1-r3.ebuild
index 18e9296abdd3..d85cdc56161e 100644
--- a/app-admin/openmosixtest/openmosixtest-0.1-r3.ebuild
+++ b/app-admin/openmosixtest/openmosixtest-0.1-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/openmosixtest/openmosixtest-0.1-r3.ebuild,v 1.2 2002/11/15 19:06:55 tantive Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/openmosixtest/openmosixtest-0.1-r3.ebuild,v 1.3 2002/11/18 18:59:09 tantive Exp $
S=${WORKDIR}/omtest
DESCRIPTION="openMosix stress test"
@@ -34,7 +34,6 @@ src_install() {
cp -r * ${WORKDIR}/../image/opt/omtest
}
-
pkg_postinst() {
cd /opt/omtest
einfo