summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Boshell <leonardop@gentoo.org>2006-11-01 04:29:17 +0000
committerLeonardo Boshell <leonardop@gentoo.org>2006-11-01 04:29:17 +0000
commit3843ebb6e6152a95ccfb1cf7a867c7d696330883 (patch)
tree76a7e26f322e6ff75c208d431764d41f30ad4666 /app-accessibility
parentcleanup (diff)
downloadhistorical-3843ebb6e6152a95ccfb1cf7a867c7d696330883.tar.gz
historical-3843ebb6e6152a95ccfb1cf7a867c7d696330883.tar.bz2
historical-3843ebb6e6152a95ccfb1cf7a867c7d696330883.zip
Added libke dependencies to configure.in (bug #150120). Pruning old ebuild.
Package-Manager: portage-2.1.2_rc1
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/gnopernicus/ChangeLog8
-rw-r--r--app-accessibility/gnopernicus/files/gnopernicus-1.0.4-libke_deps.patch13
-rw-r--r--app-accessibility/gnopernicus/gnopernicus-1.0.4.ebuild16
3 files changed, 34 insertions, 3 deletions
diff --git a/app-accessibility/gnopernicus/ChangeLog b/app-accessibility/gnopernicus/ChangeLog
index d2ede837feed..a062f19dc434 100644
--- a/app-accessibility/gnopernicus/ChangeLog
+++ b/app-accessibility/gnopernicus/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-accessibility/gnopernicus
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/gnopernicus/ChangeLog,v 1.89 2006/10/19 14:48:11 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/gnopernicus/ChangeLog,v 1.90 2006/11/01 04:29:17 leonardop Exp $
+
+ 01 Nov 2006; Leonardo Boshell <leonardop@gentoo.org>
+ +files/gnopernicus-1.0.4-libke_deps.patch, -gnopernicus-0.12.0.ebuild,
+ gnopernicus-1.0.4.ebuild:
+ Added libke dependencies to configure.in to fix compilation problem (bug
+ #150120).
19 Oct 2006; Bryan Østergaard <kloeri@gentoo.org>
gnopernicus-1.0.4.ebuild:
diff --git a/app-accessibility/gnopernicus/files/gnopernicus-1.0.4-libke_deps.patch b/app-accessibility/gnopernicus/files/gnopernicus-1.0.4-libke_deps.patch
new file mode 100644
index 000000000000..e0590224806a
--- /dev/null
+++ b/app-accessibility/gnopernicus/files/gnopernicus-1.0.4-libke_deps.patch
@@ -0,0 +1,13 @@
+diff -NurdB gnopernicus-1.0.4/configure.in gnopernicus-1.0.4-patched/configure.in
+--- gnopernicus-1.0.4/configure.in 2006-04-10 11:06:00.000000000 -0500
++++ gnopernicus-1.0.4-patched/configure.in 2006-10-31 22:44:59.000000000 -0500
+@@ -555,7 +555,8 @@
+ PKG_CHECK_MODULES(LIBKE, \
+ cspi-1.0 >= $CSPI_REQUIRED \
+ gconf-2.0 >= $GCONF_REQUIRED \
+- glib-2.0 >= $GLIB_REQUIRED )
++ glib-2.0 >= $GLIB_REQUIRED
++ gdk-2.0 >= $GTK_REQUIRED )
+ AC_SUBST(LIBKE_LIBS)
+ AC_SUBST(LIBKE_CFLAGS)
+
diff --git a/app-accessibility/gnopernicus/gnopernicus-1.0.4.ebuild b/app-accessibility/gnopernicus/gnopernicus-1.0.4.ebuild
index 17f1c958d2e3..9f7ba548bcb0 100644
--- a/app-accessibility/gnopernicus/gnopernicus-1.0.4.ebuild
+++ b/app-accessibility/gnopernicus/gnopernicus-1.0.4.ebuild
@@ -1,8 +1,10 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/gnopernicus/gnopernicus-1.0.4.ebuild,v 1.10 2006/10/19 14:48:11 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/gnopernicus/gnopernicus-1.0.4.ebuild,v 1.11 2006/11/01 04:29:17 leonardop Exp $
-inherit gnome2
+WANT_AUTOMAKE=1.8
+
+inherit autotools gnome2
DESCRIPTION="Software tools for blind and visually impaired"
HOMEPAGE="http://www.baum.ro/gnopernicus.html"
@@ -34,6 +36,16 @@ DEPEND="${RDEPEND}
DOCS="AUTHORS ChangeLog NEWS README"
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # Add gdk-2.0 to the list of dependencies for libke (bug #150120)
+ epatch "${FILESDIR}"/${P}-libke_deps.patch
+
+ eautoreconf
+}
+
pkg_setup() {
G2CONF="$(use_enable ipv6) \
$(use_enable brltty)"