summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2012-01-12 16:34:10 +0000
committerMichał Górny <mgorny@gentoo.org>2012-01-12 16:34:10 +0000
commit468938c2d92c2d99f50b6e11ac9b9ab84253e2d8 (patch)
tree6a25cfddab5b1b901a871302ddfe80b9256cc951 /app-accessibility/sphinxbase
parentVersion bump. (diff)
downloadhistorical-468938c2d92c2d99f50b6e11ac9b9ab84253e2d8.tar.gz
historical-468938c2d92c2d99f50b6e11ac9b9ab84253e2d8.tar.bz2
historical-468938c2d92c2d99f50b6e11ac9b9ab84253e2d8.zip
Fix invalid use of autotools-utils.eclass.
Package-Manager: portage-2.2.0_alpha84/cvs/Linux x86_64
Diffstat (limited to 'app-accessibility/sphinxbase')
-rw-r--r--app-accessibility/sphinxbase/ChangeLog7
-rw-r--r--app-accessibility/sphinxbase/sphinxbase-0.7.ebuild25
2 files changed, 20 insertions, 12 deletions
diff --git a/app-accessibility/sphinxbase/ChangeLog b/app-accessibility/sphinxbase/ChangeLog
index 9f422183eeb1..619737915f7c 100644
--- a/app-accessibility/sphinxbase/ChangeLog
+++ b/app-accessibility/sphinxbase/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-accessibility/sphinxbase
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/sphinxbase/ChangeLog,v 1.1 2011/11/17 17:35:05 neurogeek Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/sphinxbase/ChangeLog,v 1.2 2012/01/12 16:33:37 mgorny Exp $
+
+ 12 Jan 2012; Michał Górny <mgorny@gentoo.org> sphinxbase-0.7.ebuild:
+ Fix invalid use of autotools-utils.eclass.
*sphinxbase-0.7 (17 Nov 2011)
diff --git a/app-accessibility/sphinxbase/sphinxbase-0.7.ebuild b/app-accessibility/sphinxbase/sphinxbase-0.7.ebuild
index 5262b6dc5ebd..90da48e0a88d 100644
--- a/app-accessibility/sphinxbase/sphinxbase-0.7.ebuild
+++ b/app-accessibility/sphinxbase/sphinxbase-0.7.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/sphinxbase/sphinxbase-0.7.ebuild,v 1.1 2011/11/17 17:35:05 neurogeek Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/sphinxbase/sphinxbase-0.7.ebuild,v 1.2 2012/01/12 16:33:37 mgorny Exp $
EAPI=3
PYTHON_DEPEND="python? 2:2.6"
@@ -23,15 +23,22 @@ DEPEND="${RDEPEND}
RESTRICT_PYTHON_ABIS="3*"
+# Due to generated Python setup.py.
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
src_configure() {
- econf \
- $( use_with lapack ) \
- $( use_with python ) \
- $( use_enable static-libs static )
+ local myeconfargs=(
+ $( use_with lapack )
+ # python modules are built through distutils
+ # so disable the ugly wrapper
+ --without-python
+ )
+
+ autotools-utils_src_configure
}
src_compile() {
- default
+ autotools-utils_src_compile
if use python; then
python_copy_sources python
@@ -45,7 +52,7 @@ src_compile() {
}
src_install() {
- emake DESTDIR="${D}" install || die
+ autotools-utils_src_install
if use python; then
python_execute_function -s --source-dir python -d
@@ -54,6 +61,4 @@ src_install() {
if use doc; then
dohtml doc/html/*
fi
-
- remove_libtool_files
}