summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2012-10-28 10:51:38 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2012-10-28 10:51:38 +0000
commit0824b8fe4f6cde96408f750b6677d79d0cf99767 (patch)
tree0b4d26cbace7317b487869ef0aa6a81ecda92b14 /app-accessibility/at-spi2-atk/at-spi2-atk-2.6.1.ebuild
parentVersion bump. (diff)
downloadhistorical-0824b8fe4f6cde96408f750b6677d79d0cf99767.tar.gz
historical-0824b8fe4f6cde96408f750b6677d79d0cf99767.tar.bz2
historical-0824b8fe4f6cde96408f750b6677d79d0cf99767.zip
Version bump.
Package-Manager: portage-2.2.0_alpha141/cvs/Linux x86_64 Manifest-Sign-Key: 0xC6085806
Diffstat (limited to 'app-accessibility/at-spi2-atk/at-spi2-atk-2.6.1.ebuild')
-rw-r--r--app-accessibility/at-spi2-atk/at-spi2-atk-2.6.1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-accessibility/at-spi2-atk/at-spi2-atk-2.6.1.ebuild b/app-accessibility/at-spi2-atk/at-spi2-atk-2.6.1.ebuild
new file mode 100644
index 000000000000..b72b9f07cdcf
--- /dev/null
+++ b/app-accessibility/at-spi2-atk/at-spi2-atk-2.6.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/at-spi2-atk/at-spi2-atk-2.6.1.ebuild,v 1.1 2012/10/28 10:51:34 eva Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2 virtualx
+
+DESCRIPTION="Gtk module for bridging AT-SPI to Atk"
+HOMEPAGE="http://live.gnome.org/Accessibility"
+
+LICENSE="LGPL-2+"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~x86"
+IUSE=""
+
+COMMON_DEPEND="
+ >=app-accessibility/at-spi2-core-2.6
+ >=dev-libs/atk-2.1.0
+ dev-libs/glib:2
+ >=sys-apps/dbus-1
+"
+RDEPEND="${COMMON_DEPEND}
+ !<gnome-extra/at-spi-1.32.0-r1
+"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ DOCS="AUTHORS NEWS README"
+ # xevie is deprecated/broken since xorg-1.6/1.7
+ G2CONF="${G2CONF} --enable-p2p"
+
+ # disable teamspaces test since that requires Novell.ICEDesktop.Daemon
+ epatch "${FILESDIR}/${PN}-2.0.2-disable-teamspaces-test.patch"
+
+ gnome2_src_prepare
+}
+
+src_test() {
+ Xemake check
+}