summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-11-30 21:48:04 +0000
committerMike Frysinger <vapier@gentoo.org>2002-11-30 21:48:04 +0000
commite958475af0e95a3d337f27d5a870c393255b49a3 (patch)
treec9ea1b13a3a5d6783301e1fda2f1ec50a004577f
parentChanged econf||die to econf (diff)
downloadhistorical-e958475af0e95a3d337f27d5a870c393255b49a3.tar.gz
historical-e958475af0e95a3d337f27d5a870c393255b49a3.tar.bz2
historical-e958475af0e95a3d337f27d5a870c393255b49a3.zip
Changed mkdir ${D} to dodir ${D}
-rw-r--r--sys-apps/hfsplusutils/hfsplusutils-1.0.4.ebuild24
-rw-r--r--sys-apps/nbd/nbd-14.ebuild9
-rw-r--r--sys-apps/sparc-utils/sparc-utils-1.9.ebuild13
-rw-r--r--sys-apps/tic98/tic98-1.01-r1.ebuild109
-rw-r--r--sys-apps/tic98/tic98-1.01.ebuild107
5 files changed, 27 insertions, 235 deletions
diff --git a/sys-apps/hfsplusutils/hfsplusutils-1.0.4.ebuild b/sys-apps/hfsplusutils/hfsplusutils-1.0.4.ebuild
index ab5fb254c030..f60151e2d580 100644
--- a/sys-apps/hfsplusutils/hfsplusutils-1.0.4.ebuild
+++ b/sys-apps/hfsplusutils/hfsplusutils-1.0.4.ebuild
@@ -1,40 +1,35 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hfsplusutils/hfsplusutils-1.0.4.ebuild,v 1.10 2002/10/19 01:52:44 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hfsplusutils/hfsplusutils-1.0.4.ebuild,v 1.11 2002/11/30 21:40:34 vapier Exp $
-S=${WORKDIR}/hfsplus-1.0.4
+S=${WORKDIR}/hfsplus-${PV}
MY_P="hfsplus_${PV}"
DESCRIPTION="HFS+ Filesystem Access Utilities (PPC Only)"
SRC_URI="http://ftp.penguinppc.org/users/hasi/${MY_P}.src.tar.bz2"
HOMEPAGE="http://ftp.penguinppc.org/users/hasi/"
+
KEYWORDS="ppc -x86 -sparc -sparc64 -alpha"
+LICENSE="GPL-2"
+SLOT="0"
+
DEPEND="sys-devel/autoconf
sys-devel/automake
sys-apps/bzip2"
RDEPEND=""
-LICENSE="GPL-2"
-SLOT="0"
-IUSE=""
MAKEOPTS='PREFIX=/usr MANDIR=/usr/share/man'
src_compile() {
-
# This does a autoconf, automake, etc.
emake -f Makefile.cvs all || die
patch -p0 < ${FILESDIR}/hfsplusutils-1.0.4-glob.patch || die "Patch failed"
- ./configure \
- --host=${CHOST} \
- --prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man || die "./configure failed"
-
+ econf
emake || die
}
-src_install () {
+src_install() {
dodir /usr/bin
dodir /usr/lib
dodir /usr/share/man
@@ -43,7 +38,6 @@ src_install () {
mandir=${D}/usr/share/man \
infodir=${D}/usr/share/info \
install || die
- mkdir ${D}/usr/share/man/man1
+ dodir /usr/share/man/man1
cp doc/man/hfsp.man ${D}/usr/share/man/man1/hfsp.1
}
-
diff --git a/sys-apps/nbd/nbd-14.ebuild b/sys-apps/nbd/nbd-14.ebuild
index be38f6457a9c..514fe08ea981 100644
--- a/sys-apps/nbd/nbd-14.ebuild
+++ b/sys-apps/nbd/nbd-14.ebuild
@@ -1,12 +1,13 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/nbd/nbd-14.ebuild,v 1.9 2002/10/20 18:54:50 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/nbd/nbd-14.ebuild,v 1.10 2002/11/30 21:41:39 vapier Exp $
MY_P=${P//-/.}
S=${WORKDIR}/${PN}
DESCRIPTION="Userland client/server for kernel network block device"
SRC_URI="http://atrey.karlin.mff.cuni.cz/~pavel/nbd/${MY_P}.tar.gz"
HOMEPAGE="http://atrey.karlin.mff.cuni.cz/~pavel/nbd/nbd.html"
+
KEYWORDS="x86 -ppc"
SLOT="0"
LICENSE="GPL-2"
@@ -15,14 +16,12 @@ DEPEND=">=sys-devel/gcc-2.95.3
>=sys-devel/make-3.79.1"
src_compile() {
- ./configure \
- --host=${CHOST} \
- --prefix=/usr || die "./configure failed"
+ econf
emake || die "emake failed"
}
src_install() {
- mkdir -p ${D}/usr/bin
+ dodir /usr/bin
make \
prefix=${D}/usr \
install || die "make install failed"
diff --git a/sys-apps/sparc-utils/sparc-utils-1.9.ebuild b/sys-apps/sparc-utils/sparc-utils-1.9.ebuild
index 3ed17e54e105..4e58d1e313d5 100644
--- a/sys-apps/sparc-utils/sparc-utils-1.9.ebuild
+++ b/sys-apps/sparc-utils/sparc-utils-1.9.ebuild
@@ -1,14 +1,16 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sparc-utils/sparc-utils-1.9.ebuild,v 1.9 2002/11/18 06:49:54 blizzy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sparc-utils/sparc-utils-1.9.ebuild,v 1.10 2002/11/30 21:44:14 vapier Exp $
S=${WORKDIR}/${P}.orig
DESCRIPTION="SPARC/UltraSPARC Improved Loader, a boot loader for sparc"
SRC_URI=" http://http.us.debian.org/debian/pool/main/s/${PN}/${PN}_${PV}.orig.tar.gz"
HOMEPAGE="http://www.debian.org/"
+
KEYWORDS="sparc sparc64 -x86 -ppc"
SLOT="0"
LICENSE="GPL-2"
+
DEPEND="sys-kernel/linux-headers"
RDEPEND="virtual/glibc"
@@ -19,7 +21,6 @@ src_unpack() {
src_compile() {
CFLAGS="-O3"
- cd ${S}
emake -C elftoaout-2.3 CFLAGS="$CFLAGS" || die
emake -C src piggyback piggyback64 CFLAGS="$CFLAGS" || die
emake -C prtconf-1.3 all || die
@@ -27,16 +28,14 @@ src_compile() {
# Not compiling at this time, commented out
#emake -C sparc32-1.1
emake -C audioctl-1.3 || die
-
}
src_install() {
- mkdir -p ${D}/usr/bin ${D}/usr/sbin ${D}/etc/init.d ${D}/etc/default
- dodir /usr/bin
+ dodir /usr/bin /usr/sbin /etc/init.d /etc/default
install -s elftoaout-2.3/elftoaout ${D}/usr/bin
install -s src/piggyback src/piggyback64 ${D}/usr/bin
#install -s sparc32-1.1/sparc32 ${D}/usr/bin
- dodir /usr/sbin
+
install -s prtconf-1.3/prtconf ${D}/usr/sbin/prtconf
install -s prtconf-1.3/eeprom ${D}/usr/sbin/eeprom
#ln -sf sparc32 ${D}/usr/bin/sparc64
@@ -45,7 +44,9 @@ src_install() {
install -d -m 755 ${D}/etc ${D}/etc/init.d ${D}/etc/default
#install -m 755 debian/audioctl ${D}/etc/init.d
install -m 755 debian/audioctl.def ${D}/etc/default/audioctl
+}
+pkg_postinst() {
# Todo: Somehow set this automatically
ewarn "Make sure /dev/openprom exists. If you're not using devfs and"
ewarn "/dev/openprom does not exist, run"
diff --git a/sys-apps/tic98/tic98-1.01-r1.ebuild b/sys-apps/tic98/tic98-1.01-r1.ebuild
index ac3ebc04c6d7..373e65f366f0 100644
--- a/sys-apps/tic98/tic98-1.01-r1.ebuild
+++ b/sys-apps/tic98/tic98-1.01-r1.ebuild
@@ -1,129 +1,28 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/tic98/tic98-1.01-r1.ebuild,v 1.1 2002/10/19 22:48:52 mjc Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/tic98/tic98-1.01-r1.ebuild,v 1.2 2002/11/30 21:47:17 vapier Exp $
-# NOTE: The comments in this file are for instruction and documentation.
-# They're not meant to appear with your final, production ebuild. Please
-# remember to remove them before submitting or committing your ebuild. That
-# doesn't mean you can't add your own comments though.
-
-# The 'Header' on the third line should just be left alone. When your ebuild
-# will be commited to cvs, the details on that line will be automatically
-# generated to contain the correct data.
-
-# Short one-line description of this package.
DESCRIPTION="tic98 is a compressor for black-and-white images, in particular scanned documents. It gets very good compression, better than AT&T's DjVu system. tic98 also includes ppmd text compression (ppmd) and number compression (b_gamma_enc)"
-
-# Homepage, not used by Portage directly but handy for developer reference
HOMEPAGE="http://www.cs.waikato.ac.nz/~singlis/"
-
-# Point to any required sources; these will be automatically downloaded by
-# Portage.
SRC_URI="http://www.cs.waikato.ac.nz/~singlis/${P}.tar.gz"
-# License of the package. This must match the name of file(s) in
-# /usr/portage/licenses/. For complex license combination see the developer
-# docs on gentoo.org for details.
-LICENSE="GPL"
-
-# The SLOT variable is used to tell Portage if it's OK to keep multiple
-# versions of the same package installed at the same time. For example,
-# if we have a libfoo-1.2.2 and libfoo-1.3.2 (which is not compatible
-# with 1.2.2), it would be optimal to instruct Portage to not remove
-# libfoo-1.2.2 if we decide to upgrade to libfoo-1.3.2. To do this,
-# we specify SLOT="1.2" in libfoo-1.2.2 and SLOT="1.3" in libfoo-1.3.2.
-# emerge clean understands SLOTs, and will keep the most recent version
-# of each SLOT and remove everything else.
-# Note that normal applications should use SLOT="0" if possible, since
-# there should only be exactly one version installed at a time.
-# DO NOT USE SLOT=""! This tells Portage to disable SLOTs for this package.
+LICENSE="GPL-2"
SLOT="0"
-
-# Using KEYWORDS, we can record masking information *inside* an ebuild
-# instead of relying on an external package.mask file. Right now, you
-# should set the KEYWORDS variable for every ebuild so that it contains
-# the names of all the architectures with which the ebuild works. We have
-# 4 official architecture names right now: "x86", "ppc", "sparc" and
-# "sparc64". So, if you've confirmed that your ebuild works on x86 and ppc,
-# you'd specify: KEYWORDS="x86 ppc"
-# For packages that are platform-independant (like Java, PHP or Perl
-# applications) specify all keywords.
-# DO NOT USE KEYWORDS="*". This is deprecated and only for backward
-# compatibility reasons.
KEYWORDS="x86"
-# Comprehensive list of any and all USE flags leveraged in the ebuild,
-# with the exception of any ARCH specific flags, i.e. "ppc", "sparc",
-# "sparc64", "x86" and "alpha". This is a required variable. If the
-# ebuild doesn't use any USE flags, set to "".
-IUSE=""
-
-# Build-time dependencies, such as
-# ssl? ( >=openssl-0.9.6b )
-# >=perl-5.6.1-r1
-# It is advisable to use the >= syntax show above, to reflect what you
-# had installed on your system when you tested the package. Then
-# other users hopefully won't be caught without the right version of
-# a dependency.
DEPEND=""
-# Run-time dependencies, same as DEPEND if RDEPEND isn't defined:
-#RDEPEND=""
-
-# Source directory; the dir where the sources can be found (automatically
-# unpacked) inside ${WORKDIR}. S will get a default setting of ${WORKDIR}/${P}
-# if you omit this line.
-
S="${WORKDIR}/${PN}"
src_compile() {
- # Most open-source packages use GNU autoconf for configuration.
- # You should use something similar to the following lines to
- # configure your package before compilation. The "|| die" portion
- # at the end will stop the build process if the command fails.
- # You should use this at the end of critical commands in the build
- # process. (Hint: Most commands are critical, that is, the build
- # process should abort if they aren't successful.)
-# ./configure \
-# --host=${CHOST} \
-# --prefix=/usr \
-# --infodir=/usr/share/info \
-# --mandir=/usr/share/man || die "./configure failed"
- # Note the use of --infodir and --mandir, above. This is to make
- # this package FHS 2.2-compliant. For more information, see
- # http://www.pathname.com/fhs/
-
- # emake (previously known as pmake) is a script that calls the
- # standard GNU make with parallel building options for speedier
- # builds (especially on SMP systems). Try emake first. It might
- # not work for some packages, in which case you'll have to resort
- # to normal "make".
- cd ${S}
patch -p1 < ${FILESDIR}/${P}-gentoo.diff
patch -p1 < $FILESDIR/${PN}.diff
emake all || die
emake all2 || die
- #emake test || die
- #make || die
}
src_install() {
- # You must *personally verify* that this trick doesn't install
- # anything outside of DESTDIR; do this by reading and
- # understanding the install part of the Makefiles.
- mkdir ${D}usr
- mkdir ${D}usr/bin
+ dodir /usr
+ dodir /usr/bin
make BIN=${D}usr/bin install || die
- # For Makefiles that don't make proper use of DESTDIR, setting
- # prefix is often an alternative. However if you do this, then
- # you also need to specify mandir and infodir, since they were
- # passed to ./configure as absolute paths (overriding the prefix
- # setting).
- #make \
- # prefix=${D}/usr \
- # mandir=${D}/usr/share/man \
- # infodir=${D}/usr/share/info \
- # install || die
- # Again, verify the Makefiles! We don't want anything falling
- # outside of ${D}.
}
diff --git a/sys-apps/tic98/tic98-1.01.ebuild b/sys-apps/tic98/tic98-1.01.ebuild
index d03e0687979b..3c8513353457 100644
--- a/sys-apps/tic98/tic98-1.01.ebuild
+++ b/sys-apps/tic98/tic98-1.01.ebuild
@@ -1,129 +1,28 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/tic98/tic98-1.01.ebuild,v 1.2 2002/10/19 23:17:09 mjc Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/tic98/tic98-1.01.ebuild,v 1.3 2002/11/30 21:48:04 vapier Exp $
-# NOTE: The comments in this file are for instruction and documentation.
-# They're not meant to appear with your final, production ebuild. Please
-# remember to remove them before submitting or committing your ebuild. That
-# doesn't mean you can't add your own comments though.
-
-# The 'Header' on the third line should just be left alone. When your ebuild
-# will be commited to cvs, the details on that line will be automatically
-# generated to contain the correct data.
-
-# Short one-line description of this package.
DESCRIPTION="tic98 is a compressor for black-and-white images, in particular scanned documents. It gets very good compression, better than AT&T's DjVu system. tic98 also includes ppmd text compression (ppmd) and number compression (b_gamma_enc)"
-
-# Homepage, not used by Portage directly but handy for developer reference
HOMEPAGE="http://www.cs.waikato.ac.nz/~singlis/"
-
-# Point to any required sources; these will be automatically downloaded by
-# Portage.
SRC_URI="http://www.cs.waikato.ac.nz/~singlis/${P}.tar.gz"
-# License of the package. This must match the name of file(s) in
-# /usr/portage/licenses/. For complex license combination see the developer
-# docs on gentoo.org for details.
LICENSE="GPL"
-
-# The SLOT variable is used to tell Portage if it's OK to keep multiple
-# versions of the same package installed at the same time. For example,
-# if we have a libfoo-1.2.2 and libfoo-1.3.2 (which is not compatible
-# with 1.2.2), it would be optimal to instruct Portage to not remove
-# libfoo-1.2.2 if we decide to upgrade to libfoo-1.3.2. To do this,
-# we specify SLOT="1.2" in libfoo-1.2.2 and SLOT="1.3" in libfoo-1.3.2.
-# emerge clean understands SLOTs, and will keep the most recent version
-# of each SLOT and remove everything else.
-# Note that normal applications should use SLOT="0" if possible, since
-# there should only be exactly one version installed at a time.
-# DO NOT USE SLOT=""! This tells Portage to disable SLOTs for this package.
SLOT="0"
-
-# Using KEYWORDS, we can record masking information *inside* an ebuild
-# instead of relying on an external package.mask file. Right now, you
-# should set the KEYWORDS variable for every ebuild so that it contains
-# the names of all the architectures with which the ebuild works. We have
-# 4 official architecture names right now: "x86", "ppc", "sparc" and
-# "sparc64". So, if you've confirmed that your ebuild works on x86 and ppc,
-# you'd specify: KEYWORDS="x86 ppc"
-# For packages that are platform-independant (like Java, PHP or Perl
-# applications) specify all keywords.
-# DO NOT USE KEYWORDS="*". This is deprecated and only for backward
-# compatibility reasons.
KEYWORDS="x86"
-# Comprehensive list of any and all USE flags leveraged in the ebuild,
-# with the exception of any ARCH specific flags, i.e. "ppc", "sparc",
-# "sparc64", "x86" and "alpha". This is a required variable. If the
-# ebuild doesn't use any USE flags, set to "".
-IUSE=""
-
-# Build-time dependencies, such as
-# ssl? ( >=openssl-0.9.6b )
-# >=perl-5.6.1-r1
-# It is advisable to use the >= syntax show above, to reflect what you
-# had installed on your system when you tested the package. Then
-# other users hopefully won't be caught without the right version of
-# a dependency.
DEPEND=""
-# Run-time dependencies, same as DEPEND if RDEPEND isn't defined:
-#RDEPEND=""
-
-# Source directory; the dir where the sources can be found (automatically
-# unpacked) inside ${WORKDIR}. S will get a default setting of ${WORKDIR}/${P}
-# if you omit this line.
-
S="${WORKDIR}/${PN}"
src_compile() {
- # Most open-source packages use GNU autoconf for configuration.
- # You should use something similar to the following lines to
- # configure your package before compilation. The "|| die" portion
- # at the end will stop the build process if the command fails.
- # You should use this at the end of critical commands in the build
- # process. (Hint: Most commands are critical, that is, the build
- # process should abort if they aren't successful.)
-# ./configure \
-# --host=${CHOST} \
-# --prefix=/usr \
-# --infodir=/usr/share/info \
-# --mandir=/usr/share/man || die "./configure failed"
- # Note the use of --infodir and --mandir, above. This is to make
- # this package FHS 2.2-compliant. For more information, see
- # http://www.pathname.com/fhs/
-
- # emake (previously known as pmake) is a script that calls the
- # standard GNU make with parallel building options for speedier
- # builds (especially on SMP systems). Try emake first. It might
- # not work for some packages, in which case you'll have to resort
- # to normal "make".
- cd ${S}
patch -p1 < ${FILESDIR}/${P}-gentoo.diff
patch -p1 < $FILESDIR/${PN}.diff
emake all || die
emake all2 || die
- #emake test || die
- #make || die
}
src_install() {
- # You must *personally verify* that this trick doesn't install
- # anything outside of DESTDIR; do this by reading and
- # understanding the install part of the Makefiles.
- mkdir ${D}usr
- mkdir ${D}usr/bin
+ dodir /usr
+ dodir /usr/bin
make BIN=${D}usr/bin install || die
- # For Makefiles that don't make proper use of DESTDIR, setting
- # prefix is often an alternative. However if you do this, then
- # you also need to specify mandir and infodir, since they were
- # passed to ./configure as absolute paths (overriding the prefix
- # setting).
- #make \
- # prefix=${D}/usr \
- # mandir=${D}/usr/share/man \
- # infodir=${D}/usr/share/info \
- # install || die
- # Again, verify the Makefiles! We don't want anything falling
- # outside of ${D}.
}