summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-06-25 18:57:51 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-06-25 18:57:51 +0000
commitdd252d26ea5794aaa29067fad2986a72c4f126df (patch)
tree45c498f935d72cabd9322405e519acdb01d25f4b
parentStable on ppc wrt bug 228965 (diff)
downloadhistorical-dd252d26ea5794aaa29067fad2986a72c4f126df.tar.gz
historical-dd252d26ea5794aaa29067fad2986a72c4f126df.tar.bz2
historical-dd252d26ea5794aaa29067fad2986a72c4f126df.zip
old
Package-Manager: portage-2.1.4.4
-rw-r--r--games-arcade/holotz-castle/files/holotz-castle-1.3.8-build.patch53
-rw-r--r--games-arcade/holotz-castle/holotz-castle-1.3.8.ebuild42
-rw-r--r--games-arcade/rocksndiamonds/rocksndiamonds-3.2.3.ebuild98
-rw-r--r--games-arcade/smc/files/smc-1.4-link-libpng.patch15
-rw-r--r--games-arcade/smc/smc-1.4.ebuild63
5 files changed, 0 insertions, 271 deletions
diff --git a/games-arcade/holotz-castle/files/holotz-castle-1.3.8-build.patch b/games-arcade/holotz-castle/files/holotz-castle-1.3.8-build.patch
deleted file mode 100644
index e556d76193e9..000000000000
--- a/games-arcade/holotz-castle/files/holotz-castle-1.3.8-build.patch
+++ /dev/null
@@ -1,53 +0,0 @@
---- JLib/Makefile.orig 2006-03-26 23:38:39.000000000 -0500
-+++ JLib/Makefile 2006-03-27 01:16:36.000000000 -0500
-@@ -19,7 +19,7 @@
- endif
-
- # Define -D_JLIB_DEBUG to debug JLib. Compile the app to debug also with this flag
--CFLAGS=-I. -O3 -ffast-math -fPIC -Wall -Wshadow `$(SDL_CONFIG) --cflags`
-+CXXFLAGS=-I. $(CPU_OPTS) `$(SDL_CONFIG) --cflags`
-
- # Sample LDFLAGS for applications
- # LDFLAGS=-L. -ffast-math -lSDL_image -lSDL_ttf -lSDL_mixer `$(SDL_CONFIG) --libs`
-@@ -28,15 +28,14 @@
-
- # JLib
- libJLib: $(JLIB_OBJS)
-- g++ -shared -fPIC -o $@.so $? \
-- && ar rvus $@.a $? \
-+ ar rvus $@.a $?
-
- $(GRAPHICS)/%.o: $(GRAPHICS)/%.cpp
-- g++ $(CFLAGS) -c -o $@ $<
-+ $(CXX) $(CXXFLAGS) -c -o $@ $<
- $(UTIL)/%.o: $(UTIL)/%.cpp
-- g++ $(CFLAGS) -c -o $@ $<
-+ $(CXX) $(CXXFLAGS) -c -o $@ $<
- $(MATH)/%.o: $(MATH)/%.cpp
-- g++ $(CFLAGS) -c -o $@ $<
-+ $(CXX) $(CXXFLAGS) -c -o $@ $<
-
- .PHONY: install
- install:
---- src/Makefile.orig 2006-03-27 01:26:18.000000000 -0500
-+++ src/Makefile 2006-03-27 01:27:31.000000000 -0500
-@@ -30,7 +30,7 @@
-
- DEFINES = -DHC_DATA_DIR=\"$(HC_DATA)\" -DHCED_DATA_DIR=\"$(HCED_DATA)\"
-
--all: JLib HC HCed
-+all: HC HCed
-
- HC_OBJ_MAIN=HolotzCastle.o
- HC_OBJS=HCUtil.o HCTimer.o HCLoadSaveSlot.o HCPlaylist.o HCPreferences.o HCTheme.o HCText.o \
-@@ -42,8 +42,8 @@
-
- # Definir -D_JLIB_DEBUG para debug con JLib. Ponerlo también en el Makefile de JLib.
- # Define -D_JLIB_DEBUG for JLib debug mode. Put it also in JLib's Makefile.
--CFLAGS=-I. -I../JLib -O3 -Wall -Werror -Wshadow $(CPU_OPTS) -ffast-math -c `$(SDL_CONFIG) --cflags`
--LDFLAGS=-L. -ffast-math -lSDL_image -lSDL_ttf -lSDL_mixer `$(SDL_CONFIG) --libs`
-+CFLAGS=-I. -I../JLib $(CPU_OPTS) -c `$(SDL_CONFIG) --cflags`
-+LDFLAGS=-L. -lSDL_image -lSDL_ttf -lSDL_mixer `$(SDL_CONFIG) --libs`
-
-
- JLib:
diff --git a/games-arcade/holotz-castle/holotz-castle-1.3.8.ebuild b/games-arcade/holotz-castle/holotz-castle-1.3.8.ebuild
deleted file mode 100644
index ebf22f805421..000000000000
--- a/games-arcade/holotz-castle/holotz-castle-1.3.8.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/holotz-castle/holotz-castle-1.3.8.ebuild,v 1.3 2006/10/03 15:17:46 wolf31o2 Exp $
-
-inherit eutils games
-
-DESCRIPTION="2d platform jump'n'run game"
-HOMEPAGE="http://www.mainreactor.net/holotzcastle/en/index_en.html"
-SRC_URI="http://www.mainreactor.net/holotzcastle/download/${P}-src.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-
-DEPEND="virtual/opengl
- media-libs/sdl-mixer
- media-libs/libsdl
- media-libs/sdl-ttf
- media-libs/sdl-image"
-
-S=${WORKDIR}/${P}-src
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-build.patch
-}
-
-src_compile() {
- emake -C JLib CPU_OPTS="${CXXFLAGS}" || die "emake failed"
- emake -C src CPU_OPTS="${CXXFLAGS}" || die "emake failed"
-}
-
-src_install() {
- dogamesbin holotz-castle holotz-castle-editor || die "dogamesbin failed"
- insinto "${GAMES_DATADIR}"/${PN}/game
- doins -r HCedHome/* res/* || die "doins failed"
- dodoc MANUAL*.txt
- doman doc/*.6
- prepgamesdirs
-}
diff --git a/games-arcade/rocksndiamonds/rocksndiamonds-3.2.3.ebuild b/games-arcade/rocksndiamonds/rocksndiamonds-3.2.3.ebuild
deleted file mode 100644
index 4e56ff950e6f..000000000000
--- a/games-arcade/rocksndiamonds/rocksndiamonds-3.2.3.ebuild
+++ /dev/null
@@ -1,98 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/rocksndiamonds/rocksndiamonds-3.2.3.ebuild,v 1.2 2007/01/29 03:17:50 mr_bones_ Exp $
-
-inherit flag-o-matic eutils games
-
-DESCRIPTION="A Boulderdash clone"
-HOMEPAGE="http://www.artsoft.org/rocksndiamonds/"
-SRC_URI="http://www.artsoft.org/RELEASES/unix/rocksndiamonds/${P}.tar.gz
- http://www.artsoft.org/RELEASES/rocksndiamonds/levels/Contributions-1.2.0.zip
- http://www.artsoft.org/RELEASES/rocksndiamonds/levels/BD2K3-1.0.0.zip
- http://www.artsoft.org/RELEASES/rocksndiamonds/levels/Boulder_Dash_Dream-1.0.0.zip
- http://www.artsoft.org/RELEASES/rocksndiamonds/levels/rnd-contrib-1.0.0.tar.gz
- http://www.artsoft.org/RELEASES/unix/rocksndiamonds/levels/rockslevels-emc-1.0.tar.gz
- http://www.artsoft.org/RELEASES/unix/rocksndiamonds/levels/rockslevels-sp-1.0.tar.gz
- http://www.artsoft.org/RELEASES/unix/rocksndiamonds/levels/rockslevels-dx-1.0.tar.gz
- http://www.artsoft.org/RELEASES/rocksndiamonds/levels/Snake_Bite-1.0.0.zip
- http://www.artsoft.org/RELEASES/rocksndiamonds/levels/Sokoban-1.0.0.zip
- http://www.jb-line.de/rnd_jue-v7.zip"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE="X sdl"
-
-DEPEND="app-arch/unzip
- X? ( x11-libs/libX11 )
- !sdl? ( x11-libs/libX11 )
- sdl? (
- >=media-libs/libsdl-1.2.3
- >=media-libs/sdl-mixer-1.2.4
- media-libs/sdl-net
- >=media-libs/sdl-image-1.2.2
- )"
-
-src_unpack() {
- unpack ${P}.tar.gz
- cd "${S}"
- unpack \
- rockslevels-emc-1.0.tar.gz \
- rockslevels-sp-1.0.tar.gz \
- rockslevels-dx-1.0.tar.gz
-
- # make it parallel-friendly.
- epatch "${FILESDIR}"/${P}-parallel-build.patch
- sed -i \
- -e 's:\$(MAKE_CMD):$(MAKE) -C $(SRC_DIR):' \
- -e '/^MAKE/d' \
- Makefile \
- || die "sed failed"
-
- cd levels
- unpack \
- rnd_jue-v7.zip \
- BD2K3-1.0.0.zip \
- rnd-contrib-1.0.0.tar.gz \
- Snake_Bite-1.0.0.zip \
- Contributions-1.2.0.zip \
- Boulder_Dash_Dream-1.0.0.zip \
- Sokoban-1.0.0.zip
-}
-
-src_compile() {
- replace-cpu-flags k6 k6-1 k6-2 i586
-
- local makeopts="RO_GAME_DIR=${GAMES_DATADIR}/${PN} RW_GAME_DIR=${GAMES_STATEDIR}/${PN}"
- if use X || { ! use X && ! use sdl; } ; then
- make clean || die
- emake ${makeopts} OPTIONS="${CFLAGS}" x11 || die
- mv rocksndiamonds{,.x11}
- fi
- if use sdl ; then
- make clean || die
- emake ${makeopts} OPTIONS="${CFLAGS}" sdl || die
- mv rocksndiamonds{,.sdl}
- fi
-}
-
-src_install() {
- if use X || { ! use X && ! use sdl; } ; then
- dogamesbin rocksndiamonds.x11 || die "dogamesbin failed"
- fi
- if use sdl ; then
- dogamesbin rocksndiamonds.sdl || die "dogamesbin failed"
- dosym rocksndiamonds.sdl "${GAMES_BINDIR}/rocksndiamonds"
- else
- dosym rocksndiamonds.x11 "${GAMES_BINDIR}/rocksndiamonds"
- fi
- insinto "${GAMES_DATADIR}/${PN}"
- doins -r graphics levels music sounds || die "doins failed"
-
- newman rocksndiamonds.{1,6}
- dodoc CHANGES CREDITS HARDWARE README TODO docs/elements/*.txt
- newicon graphics/gfx_classic/rocks_icon_32x32.pcx ${PN}.pcx
- make_desktop_entry rocksndiamonds "Rocks 'N' Diamonds" /usr/share/pixmaps/${PN}.pcx
-
- prepgamesdirs
-}
diff --git a/games-arcade/smc/files/smc-1.4-link-libpng.patch b/games-arcade/smc/files/smc-1.4-link-libpng.patch
deleted file mode 100644
index cf576b0c57de..000000000000
--- a/games-arcade/smc/files/smc-1.4-link-libpng.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-Index: configure.ac
-===================================================================
---- configure.ac (revision 907)
-+++ configure.ac (working copy)
-@@ -26,6 +26,10 @@
- CPPFLAGS="$CPPFLAGS $SDL_CFLAGS"
- LIBS="$LIBS $SDL_LIBS"
-
-+# Check for libpng
-+AC_CHECK_LIB(png, png_init_io, ,
-+ AC_MSG_ERROR([Unable to find libpng]))
-+
- # Check for SDL_image library
- AC_CHECK_LIB(SDL_image, IMG_LoadPNG_RW, ,
- AC_MSG_ERROR([Unable to find the SDL_image library with PNG support]))
diff --git a/games-arcade/smc/smc-1.4.ebuild b/games-arcade/smc/smc-1.4.ebuild
deleted file mode 100644
index 90d600aa7d37..000000000000
--- a/games-arcade/smc/smc-1.4.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/smc/smc-1.4.ebuild,v 1.4 2008/02/04 18:46:17 nyhm Exp $
-
-inherit autotools eutils games
-
-MY_P=${P}_no_music
-MUSIC_P=SMC_music_4.0_high
-DESCRIPTION="Secret Maryo Chronicles"
-HOMEPAGE="http://www.secretmaryo.org/"
-SRC_URI="mirror://sourceforge/smclone/${MY_P}.tar.bz2
- mirror://sourceforge/smclone/${MUSIC_P}.zip"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE=""
-
-RDEPEND=">=dev-games/cegui-0.5
- dev-libs/boost
- virtual/opengl
- virtual/glu
- media-libs/libpng
- media-libs/libsdl
- media-libs/sdl-image
- media-libs/sdl-mixer
- media-libs/sdl-ttf"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig
- app-arch/unzip"
-
-pkg_setup() {
- games_pkg_setup
- if ! built_with_use media-libs/sdl-image png ; then
- die "Please emerge sdl-image with USE=png"
- fi
- if ! built_with_use dev-games/cegui opengl ; then
- die "Please emerge cegui with USE=opengl"
- fi
- if ! built_with_use dev-games/cegui devil ; then
- die "Please emerge cegui with USE=devil"
- fi
- if ! built_with_use dev-libs/libpcre unicode ; then
- die "Please emerge dev-libs/libpcre with USE=unicode"
- fi
-}
-
-src_unpack() {
- unpack ${MY_P}.tar.bz2
- cd "${S}"
- unpack ${MUSIC_P}.zip
- epatch "${FILESDIR}"/${P}-link-libpng.patch
- eautoreconf
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- newicon data/icon/window_32.png ${PN}.png
- make_desktop_entry ${PN} "Secret Maryo Chronicles"
- dodoc docs/*.txt
- dohtml docs/{*.css,*.html}
- prepgamesdirs
-}