summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2006-09-23 06:53:52 +0000
committerDaniel Black <dragonheart@gentoo.org>2006-09-23 06:53:52 +0000
commitcc9f3e96650cbdf69fd97535f5251b5dbec306cf (patch)
tree8d8fe392cc9ca20aff852edecf7b40bd0b611f91
parentadd openct + pcsc-lite USE flags for gnupg (diff)
downloadhistorical-cc9f3e96650cbdf69fd97535f5251b5dbec306cf.tar.gz
historical-cc9f3e96650cbdf69fd97535f5251b5dbec306cf.tar.bz2
historical-cc9f3e96650cbdf69fd97535f5251b5dbec306cf.zip
smartcard improvments as per bug #147361. cleaned out a few versions too
Package-Manager: portage-2.1.2_pre1
-rw-r--r--app-crypt/gnupg/ChangeLog9
-rw-r--r--app-crypt/gnupg/files/digest-gnupg-1.9.21-r13
-rw-r--r--app-crypt/gnupg/gnupg-1.9.21-r1.ebuild111
3 files changed, 122 insertions, 1 deletions
diff --git a/app-crypt/gnupg/ChangeLog b/app-crypt/gnupg/ChangeLog
index 78c67c6a15f1..58149e9c2935 100644
--- a/app-crypt/gnupg/ChangeLog
+++ b/app-crypt/gnupg/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-crypt/gnupg
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/ChangeLog,v 1.226 2006/09/16 13:27:38 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/ChangeLog,v 1.227 2006/09/23 06:53:52 dragonheart Exp $
+
+*gnupg-1.9.21-r1 (23 Sep 2006)
+
+ 23 Sep 2006; Daniel Black <dragonheart@gentoo.org> -gnupg-1.4.3.ebuild,
+ -gnupg-1.4.3-r1.ebuild, -gnupg-1.4.5_rc1.ebuild, -gnupg-1.9.20-r4.ebuild,
+ +gnupg-1.9.21-r1.ebuild:
+ smartcard improvments as per bug #147361 thanks to Alon
16 Sep 2006; Tobias Scherbaum <dertobi123@gentoo.org> gnupg-1.9.21.ebuild:
ppc stable
diff --git a/app-crypt/gnupg/files/digest-gnupg-1.9.21-r1 b/app-crypt/gnupg/files/digest-gnupg-1.9.21-r1
new file mode 100644
index 000000000000..7f65fdcd534c
--- /dev/null
+++ b/app-crypt/gnupg/files/digest-gnupg-1.9.21-r1
@@ -0,0 +1,3 @@
+MD5 94f4e2ded63820efa6903543c2e06017 gnupg-1.9.21.tar.bz2 1901908
+RMD160 f522125f30a29fd2bcacca5894958242946de430 gnupg-1.9.21.tar.bz2 1901908
+SHA256 7dfaa7867427dd44ac3277026dec3602626b657d95952b7a5bdeb9e567b5d34c gnupg-1.9.21.tar.bz2 1901908
diff --git a/app-crypt/gnupg/gnupg-1.9.21-r1.ebuild b/app-crypt/gnupg/gnupg-1.9.21-r1.ebuild
new file mode 100644
index 000000000000..629e92621ff7
--- /dev/null
+++ b/app-crypt/gnupg/gnupg-1.9.21-r1.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/gnupg-1.9.21-r1.ebuild,v 1.1 2006/09/23 06:53:52 dragonheart Exp $
+
+inherit eutils flag-o-matic autotools
+
+DESCRIPTION="The GNU Privacy Guard, a GPL pgp replacement"
+HOMEPAGE="http://www.gnupg.org/"
+SRC_URI="mirror://gnupg/alpha/gnupg/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="1.9"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="X gpg2-experimental ldap nls openct pcsc-lite smartcard selinux"
+#IUSE+=caps
+
+COMMON_DEPEND="
+ dev-lang/perl
+ sys-libs/zlib
+ virtual/libc
+ >=dev-libs/pth-1.3.7
+ smartcard? ( >=dev-libs/opensc-0.8.0 )
+ >=dev-libs/libgcrypt-1.1.94
+ >=dev-libs/libksba-0.9.15
+ >=dev-libs/libgpg-error-1.0
+ ~dev-libs/libassuan-0.6.10
+ pcsc-lite? ( >=sys-apps/pcsc-lite-1.3.0 )
+ openct? ( >=dev-libs/openct-0.5.0 )
+ ldap? ( net-nds/openldap )"
+# Needs sh and arm to be keyworded on pinentry
+# X? ( app-crypt/pinentry )
+# caps? ( sys-libs/libcap )"
+
+DEPEND="${COMMON_DEPEND}
+ nls? ( sys-devel/gettext )"
+
+RDEPEND="${COMMON_DEPEND}
+ !app-crypt/gpg-agent
+ =app-crypt/gnupg-1.4*
+ X? ( || ( media-gfx/xloadimage media-gfx/xli ) )
+ virtual/mta
+ selinux? ( sec-policy/selinux-gnupg )
+ nls? ( virtual/libintl )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i -e 's/PIC/__PIC__/g' intl/relocatable.c || die "PIC patching failed"
+
+ # this warning is only available on gcc4!
+ sed -i -e '/AM_CFLAGS/s!-Wno-pointer-sign!!g' ${S}/g10/Makefile.am
+ sed -i -e '/AM_CFLAGS/s!-Wno-pointer-sign!!g' ${S}/g10/Makefile.in
+
+ epatch "${FILESDIR}/${PN}-1.9.20-fbsd.patch"
+ #epatch "${FILESDIR}/${P}-fbsd-gcc41.patch"
+ AT_M4DIR="m4 gl/m4" eautoreconf
+}
+
+src_compile() {
+ local myconf=""
+
+ if use X; then
+ local viewer
+ if has_version 'media-gfx/xloadimage'; then
+ viewer=/usr/bin/xloadimage
+ else
+ viewer=/usr/bin/xli
+ fi
+ myconf="${myconf} --with-photo-viewer=${viewer}"
+ else
+ myconf="${myconf} --disable-photo-viewers"
+ fi
+
+ #use caps || append-ldflags $(bindnow-flags)
+ append-ldflags $(bindnow-flags)
+
+ #$(use_with caps capabilities) \
+ econf \
+ --enable-agent \
+ --enable-symcryptrun \
+ $(use_enable gpg2-experimental gpg) \
+ --enable-gpgsm \
+ $(use_enable smartcard scdaemon) \
+ $(use_enable nls) \
+ $(use_enable ldap) \
+ --disable-capabilities \
+ ${myconf} \
+ || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc ChangeLog NEWS README THANKS TODO VERSION
+
+ #if ! use caps; then
+ use gpg2-experimental && fperms u+s,go-r /usr/bin/gpg2
+ fperms u+s,go-r /usr/bin/gpg-agent
+ #fi
+}
+
+pkg_postinst() {
+ #if ! use caps; then
+ # einfo "gpg is installed suid root to make use of protected memory space"
+ # einfo "This is needed in order to have a secure place to store your"
+ # einfo "passphrases, etc. at runtime but may make some sysadmins nervous."
+ #fi
+ einfo
+ einfo "See http://www.gentoo.org/doc/en/gnupg-user.xml for documentation on gnupg"
+ einfo
+}