summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Holm <dholm@gentoo.org>2005-03-08 22:21:43 +0000
committerDavid Holm <dholm@gentoo.org>2005-03-08 22:21:43 +0000
commitad93d948fc85e0e4d1ef04f5415261d4ac22e005 (patch)
tree884a575de21e853fa84be00b4f3a3a5106e44207
parentBug #77556 finally unmask PHP. (diff)
downloadhistorical-ad93d948fc85e0e4d1ef04f5415261d4ac22e005.tar.gz
historical-ad93d948fc85e0e4d1ef04f5415261d4ac22e005.tar.bz2
historical-ad93d948fc85e0e4d1ef04f5415261d4ac22e005.zip
Version bumped
Package-Manager: portage-2.0.51.19
-rw-r--r--app-emulation/aranym/ChangeLog7
-rw-r--r--app-emulation/aranym/Manifest4
-rw-r--r--app-emulation/aranym/aranym-0.9.0_beta2.ebuild58
-rw-r--r--app-emulation/aranym/files/digest-aranym-0.9.0_beta22
4 files changed, 69 insertions, 2 deletions
diff --git a/app-emulation/aranym/ChangeLog b/app-emulation/aranym/ChangeLog
index e71ac47960a5..3932edc0c0ce 100644
--- a/app-emulation/aranym/ChangeLog
+++ b/app-emulation/aranym/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/aranym
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/aranym/ChangeLog,v 1.5 2005/01/01 14:08:01 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/aranym/ChangeLog,v 1.6 2005/03/08 22:21:42 dholm Exp $
+
+*aranym-0.9.0_beta2 (08 Mar 2005)
+
+ 08 Mar 2005; David Holm <dholm@gentoo.org> +aranym-0.9.0_beta2.ebuild:
+ Version bumped
29 Jun 2004; Aron Griffis <agriffis@gentoo.org> aranym-0.8.6_beta.ebuild:
sync IUSE (+opengl, -sdl), add sed-4 dep
diff --git a/app-emulation/aranym/Manifest b/app-emulation/aranym/Manifest
index a1be2f909569..0d29fe9ebcf2 100644
--- a/app-emulation/aranym/Manifest
+++ b/app-emulation/aranym/Manifest
@@ -1,4 +1,6 @@
-MD5 b1db70d80a353ddd137656e20f298446 ChangeLog 576
+MD5 4b545a12c31f1ddf3fef37ca69ed115e ChangeLog 697
MD5 cbdcbfed1e4c825ece1f16600cc03b1e aranym-0.8.6_beta.ebuild 1533
MD5 c5adfd2f910938e12793f487a3790f53 metadata.xml 713
+MD5 fa90a8a47d36308eb13631d1af89a8a7 aranym-0.9.0_beta2.ebuild 1559
MD5 31f6327245354bd8a3dd5cb0ef529b5a files/digest-aranym-0.8.6_beta 133
+MD5 fb52622d4dbfaece22372902618fbcfd files/digest-aranym-0.9.0_beta2 135
diff --git a/app-emulation/aranym/aranym-0.9.0_beta2.ebuild b/app-emulation/aranym/aranym-0.9.0_beta2.ebuild
new file mode 100644
index 000000000000..98e206b09de4
--- /dev/null
+++ b/app-emulation/aranym/aranym-0.9.0_beta2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/aranym/aranym-0.9.0_beta2.ebuild,v 1.1 2005/03/08 22:21:43 dholm Exp $
+
+inherit flag-o-matic eutils
+
+MY_PV="0.9.0beta2"
+AFROS="afros-200502026.zip"
+S="${WORKDIR}/${PN}-${MY_PV}"
+DESCRIPTION="Atari Running on Any Machine, is a virtual machine software for running Atari ST/TT/Falcon operating systems and TOS/GEM applications"
+HOMEPAGE="http://aranym.sourceforge.net/"
+SRC_URI="mirror://sourceforge/aranym/${PN}-${MY_PV}.tar.gz
+ mirror://sourceforge/aranym/${AFROS}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE="opengl"
+
+DEPEND="media-libs/libsdl
+ games-emulation/emutos
+ app-arch/unzip
+ opengl? ( virtual/opengl )
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack "${PN}-${MY_PV}.tar.gz"
+}
+
+src_compile() {
+ filter-flags -mpowerpc-gfxopt
+
+ use opengl && myconf="--enable-opengl"
+ if [ "${ARCH}" = "x86" ]; then
+ myconf="${myconf} --enable-jit-compiler"
+ fi
+
+ cd ${S}/src/Unix
+ econf ${myconf} || die "configure failed"
+
+ emake dep || die "failed while building dependencies"
+ emake || die "failed during compilation"
+}
+
+src_install() {
+ cd ${S}/src/Unix
+ emake DESTDIR=${D} install || die "installation failed"
+
+ dosym /usr/games/lib/etos512k.img /usr/share/aranym
+
+ cd ${D}/usr/share/aranym
+ unzip ${DISTDIR}/${AFROS}
+ sed -i -e "s|tmp|usr/share/aranym|g" ${D}/usr/share/aranym/afros/config
+}
+
+pkg_postinst() {
+ einfo "To run ARAnyM with AFROS type: aranym --config /usr/share/aranym/afros/config"
+}
diff --git a/app-emulation/aranym/files/digest-aranym-0.9.0_beta2 b/app-emulation/aranym/files/digest-aranym-0.9.0_beta2
new file mode 100644
index 000000000000..43687911c776
--- /dev/null
+++ b/app-emulation/aranym/files/digest-aranym-0.9.0_beta2
@@ -0,0 +1,2 @@
+MD5 511a3d424db8e87c1d47aed20ad3cc31 aranym-0.9.0beta2.tar.gz 1632148
+MD5 919a94261f55d8f670f35a2b9f4b1ebf afros-200502026.zip 1794011